summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLim Siew Hoon <siew.hoon.lim@intel.com>2021-01-04 19:29:12 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-01-04 22:55:19 +0800
commitbb8479a75cc305877edbfbc38abbf5fd3e308688 (patch)
tree18808ad26c8c2836be0691c5c3cefb37f991d3c7
parentb583097f7dd9511b39daf2e5aeda6faf2e4f4bde (diff)
downloadmeta-intel-bb8479a75cc305877edbfbc38abbf5fd3e308688.tar.gz
intel-media-driver: upgrade 20.4.3 -> 20.4.5
Drops patches already merged. * 0001-Encode-Fixed-VP9-444-frame-header.patch * 0001-media_libva-export-packed-YUV-when-VA_EXPORT_SURFACE.patch * 0002-media-libva-Add-export-AYUV-color-in-vaExportSurface.patch Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-multimedia/libva/files/0001-Encode-Fixed-VP9-444-frame-header.patch43
-rw-r--r--recipes-multimedia/libva/files/0001-media_libva-export-packed-YUV-when-VA_EXPORT_SURFACE.patch62
-rw-r--r--recipes-multimedia/libva/files/0002-media-libva-Add-export-AYUV-color-in-vaExportSurface.patch33
-rw-r--r--recipes-multimedia/libva/intel-media-driver_20.4.5.bb (renamed from recipes-multimedia/libva/intel-media-driver_20.4.3.bb)5
4 files changed, 1 insertions, 142 deletions
diff --git a/recipes-multimedia/libva/files/0001-Encode-Fixed-VP9-444-frame-header.patch b/recipes-multimedia/libva/files/0001-Encode-Fixed-VP9-444-frame-header.patch
deleted file mode 100644
index cd046c65..00000000
--- a/recipes-multimedia/libva/files/0001-Encode-Fixed-VP9-444-frame-header.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 24da63ad1e0215b103c29b1bce29e126ca94ba00 Mon Sep 17 00:00:00 2001
2From: Lim Siew Hoon <siew.hoon.lim@intel.com>
3Date: Thu, 17 Dec 2020 14:33:21 +0800
4Subject: [PATCH] [Encode] Fixed VP9 444 frame header
5
6According VP9 spec section 7.2.2 color config semantics,
7both subsampling_x and subsampling_y should be 0 for YUV444.
8Only YUV440 subsampling_x=0 and subsampling_y=1.
9
10fixes #1074
11
12Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
13
14The patch was imported from the iHD media-driver git server
15(https://github.com/intel/media-driver.git) as of commit id
16a33eaaec2f71f04c8850db9287ee4012e143e283.
17
18Upstream-status: Backport
19
20Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
21---
22 media_driver/linux/common/codec/ddi/media_libvpx_vp9.cpp | 4 ++--
23 1 file changed, 2 insertions(+), 2 deletions(-)
24
25diff --git a/media_driver/linux/common/codec/ddi/media_libvpx_vp9.cpp b/media_driver/linux/common/codec/ddi/media_libvpx_vp9.cpp
26index df89f4fe..41357b0e 100644
27--- a/media_driver/linux/common/codec/ddi/media_libvpx_vp9.cpp
28+++ b/media_driver/linux/common/codec/ddi/media_libvpx_vp9.cpp
29@@ -97,9 +97,9 @@ void write_bitdepth_colorspace_sampling(uint32_t codecProfile,
30 (codecProfile == VP9_PROFILE_3))
31 {
32 /* sub_sampling_x/y */
33- /* Currently the sub_sampling_x = 0, sub_sampling_y = 1 */
34+ /* Currently the sub_sampling_x = 0, sub_sampling_y = 0 */
35+ vp9_wb_write_bit(wb, 0);
36 vp9_wb_write_bit(wb, 0);
37- vp9_wb_write_bit(wb, 1);
38 vp9_wb_write_bit(wb, 0); // unused
39 }
40 }
41--
422.17.1
43
diff --git a/recipes-multimedia/libva/files/0001-media_libva-export-packed-YUV-when-VA_EXPORT_SURFACE.patch b/recipes-multimedia/libva/files/0001-media_libva-export-packed-YUV-when-VA_EXPORT_SURFACE.patch
deleted file mode 100644
index 5260dc19..00000000
--- a/recipes-multimedia/libva/files/0001-media_libva-export-packed-YUV-when-VA_EXPORT_SURFACE.patch
+++ /dev/null
@@ -1,62 +0,0 @@
1From 8fc1d919fd33db698e5470602942ab6a2d6b7841 Mon Sep 17 00:00:00 2001
2From: Haihao Xiang <haihao.xiang@intel.com>
3Date: Thu, 3 Dec 2020 10:52:15 +0800
4Subject: [PATCH 1/2] media_libva: export packed YUV when
5 VA_EXPORT_SURFACE_COMPOSED_LAYERS is not set
6
7vaExportSurfaceHandle works for packed RGB w/wo
8VA_EXPORT_SURFACE_COMPOSED_LAYERS, it should work for packed YUV too
9w/wo VA_EXPORT_SURFACE_COMPOSED_LAYERS
10
11Example:
12gst-launch-1.0 videotestsrc ! msdkvpp ! \
13'video/x-raw(memory:DMABuf)',format=YUY2 ! glimagesink
14
15The patch was imported from the iHD media-driver git server
16(https://github.com/intel/media-driver.git) as of commit id
1738e5f4ab95a5c4fb3fe55d3d132795ee804d9310.
18
19Upstream-Status: Backport
20
21Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
22---
23 media_driver/linux/common/ddi/media_libva.cpp | 22 +++++++++++++++++--
24 1 file changed, 20 insertions(+), 2 deletions(-)
25
26diff --git a/media_driver/linux/common/ddi/media_libva.cpp b/media_driver/linux/common/ddi/media_libva.cpp
27index 91c3ff14..778b7011 100755
28--- a/media_driver/linux/common/ddi/media_libva.cpp
29+++ b/media_driver/linux/common/ddi/media_libva.cpp
30@@ -6672,9 +6672,27 @@ static uint32_t DdiMedia_GetDrmFormatOfSeparatePlane(uint32_t fourcc, int plane)
31 return DRM_FORMAT_R16;
32
33 case VA_FOURCC_YUY2:
34+ return DRM_FORMAT_YUYV;
35+ case VA_FOURCC_YVYU:
36+ return DRM_FORMAT_YVYU;
37+ case VA_FOURCC_VYUY:
38+ return DRM_FORMAT_VYUY;
39 case VA_FOURCC_UYVY:
40- // These are not representable as separate planes.
41- return 0;
42+ return DRM_FORMAT_UYVY;
43+ case VA_FOURCC_Y210:
44+ return DRM_FORMAT_Y210;
45+ case VA_FOURCC_Y216:
46+ return DRM_FORMAT_Y216;
47+ case VA_FOURCC_Y410:
48+ return DRM_FORMAT_Y410;
49+ case VA_FOURCC_Y416:
50+ return DRM_FORMAT_Y416;
51+#if VA_CHECK_VERSION(1, 9, 0)
52+ case VA_FOURCC_Y212:
53+ return DRM_FORMAT_Y216;
54+ case VA_FOURCC_Y412:
55+ return DRM_FORMAT_Y416;
56+#endif
57
58 case VA_FOURCC_ARGB:
59 return DRM_FORMAT_ARGB8888;
60--
612.17.1
62
diff --git a/recipes-multimedia/libva/files/0002-media-libva-Add-export-AYUV-color-in-vaExportSurface.patch b/recipes-multimedia/libva/files/0002-media-libva-Add-export-AYUV-color-in-vaExportSurface.patch
deleted file mode 100644
index a3fef964..00000000
--- a/recipes-multimedia/libva/files/0002-media-libva-Add-export-AYUV-color-in-vaExportSurface.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 979e90d7bc9ff6d9064e1f0378015abf40d86af2 Mon Sep 17 00:00:00 2001
2From: Lim Siew Hoon <siew.hoon.lim@intel.com>
3Date: Thu, 24 Dec 2020 18:47:56 +0800
4Subject: [PATCH 2/2] media-libva: Add export AYUV color in
5 vaExportSurfaceHandle when VA_EXPORT_SURFACE_COMPOSED_LAYERS is not set.
6
7Example:
8gst-launch-1.0 videotestsrc ! msdkvpp \
9'video/x-raw(memory:DMABuf)',format=VUYA ! glimagesink
10
11Upstream-Status: Submitted [https://github.com/intel/media-driver/pull/1115]
12
13Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
14---
15 media_driver/linux/common/ddi/media_libva.cpp | 2 ++
16 1 file changed, 2 insertions(+)
17
18diff --git a/media_driver/linux/common/ddi/media_libva.cpp b/media_driver/linux/common/ddi/media_libva.cpp
19index 778b7011..0e9f07d3 100755
20--- a/media_driver/linux/common/ddi/media_libva.cpp
21+++ b/media_driver/linux/common/ddi/media_libva.cpp
22@@ -6679,6 +6679,8 @@ static uint32_t DdiMedia_GetDrmFormatOfSeparatePlane(uint32_t fourcc, int plane)
23 return DRM_FORMAT_VYUY;
24 case VA_FOURCC_UYVY:
25 return DRM_FORMAT_UYVY;
26+ case VA_FOURCC_AYUV:
27+ return DRM_FORMAT_AYUV;
28 case VA_FOURCC_Y210:
29 return DRM_FORMAT_Y210;
30 case VA_FOURCC_Y216:
31--
322.17.1
33
diff --git a/recipes-multimedia/libva/intel-media-driver_20.4.3.bb b/recipes-multimedia/libva/intel-media-driver_20.4.5.bb
index dcae5c29..513f9ba6 100644
--- a/recipes-multimedia/libva/intel-media-driver_20.4.3.bb
+++ b/recipes-multimedia/libva/intel-media-driver_20.4.5.bb
@@ -19,12 +19,9 @@ REQUIRED_DISTRO_FEATURES = "opengl"
19DEPENDS += "libva gmmlib" 19DEPENDS += "libva gmmlib"
20 20
21SRC_URI = "git://github.com/intel/media-driver.git;protocol=https;branch=intel-media-20.4 \ 21SRC_URI = "git://github.com/intel/media-driver.git;protocol=https;branch=intel-media-20.4 \
22 file://0001-Encode-Fixed-VP9-444-frame-header.patch \
23 file://0001-media_libva-export-packed-YUV-when-VA_EXPORT_SURFACE.patch \
24 file://0002-media-libva-Add-export-AYUV-color-in-vaExportSurface.patch \
25 " 22 "
26 23
27SRCREV = "1daed90e58cb9fb0a0dc6de9697aaad34b114507" 24SRCREV = "74e2f11131def34314ce52940e8d0028a4aba01c"
28S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
29 26
30COMPATIBLE_HOST_x86-x32 = "null" 27COMPATIBLE_HOST_x86-x32 = "null"