summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-12-08 06:54:12 -0800
committerCalifornia Sullivan <california.l.sullivan@intel.com>2017-12-08 15:04:46 -0800
commita0342186f8b8a7730769cba020bea366ee7ed5d3 (patch)
treee38d0dbe002d544963debf7df8591f45e2c42ce6
parent48b96fee2bc39a1014fd52d339f5749ca9910560 (diff)
downloadmeta-intel-a0342186f8b8a7730769cba020bea366ee7ed5d3.tar.gz
linux-*: remove quark references from kernel
This is an early step to removing the meta-quark machine type, as the Quark processor has been EOL'ed by Intel, this release will remove it from the kernel recipes Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
-rw-r--r--recipes-kernel/linux/linux-intel.inc5
-rw-r--r--recipes-kernel/linux/linux-yocto-dev.bbappend5
-rw-r--r--recipes-kernel/linux/linux-yocto-rt_4.10.bbappend4
-rw-r--r--recipes-kernel/linux/linux-yocto-rt_4.12.bbappend4
-rw-r--r--recipes-kernel/linux/linux-yocto-rt_4.4.bbappend8
-rw-r--r--recipes-kernel/linux/linux-yocto-rt_4.9.bbappend4
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend4
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny_4.12.bbappend4
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend7
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend7
-rw-r--r--recipes-kernel/linux/linux-yocto_4.10.bbappend4
-rw-r--r--recipes-kernel/linux/linux-yocto_4.12.bbappend4
-rw-r--r--recipes-kernel/linux/linux-yocto_4.4.bbappend10
-rw-r--r--recipes-kernel/linux/linux-yocto_4.9.bbappend4
14 files changed, 1 insertions, 73 deletions
diff --git a/recipes-kernel/linux/linux-intel.inc b/recipes-kernel/linux/linux-intel.inc
index f03ef463..b8a9798b 100644
--- a/recipes-kernel/linux/linux-intel.inc
+++ b/recipes-kernel/linux/linux-intel.inc
@@ -22,7 +22,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
22 22
23KERNEL_FEATURES_INTEL_COMMON ?= "" 23KERNEL_FEATURES_INTEL_COMMON ?= ""
24 24
25COMPATIBLE_MACHINE ?= "(intel-corei7-64|intel-core2-32|intel-quark)" 25COMPATIBLE_MACHINE ?= "(intel-corei7-64|intel-core2-32)"
26COMPATIBLE_MACHINE_intel-x86-common = "${MACHINE}" 26COMPATIBLE_MACHINE_intel-x86-common = "${MACHINE}"
27 27
28KMACHINE_core2-32-intel-common = "intel-core2-32" 28KMACHINE_core2-32-intel-common = "intel-core2-32"
@@ -31,9 +31,6 @@ KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
31KMACHINE_corei7-64-intel-common = "intel-corei7-64" 31KMACHINE_corei7-64-intel-common = "intel-corei7-64"
32KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 32KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
33 33
34KMACHINE_i586-nlp-32-intel-common = "intel-quark"
35KERNEL_FEATURES_append_i586-nlp-32-intel-common = "features/qat/qat.scc"
36
37# Functionality flags 34# Functionality flags
38KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}" 35KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
39KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}" 36KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"
diff --git a/recipes-kernel/linux/linux-yocto-dev.bbappend b/recipes-kernel/linux/linux-yocto-dev.bbappend
index ee33ecc3..6173148c 100644
--- a/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -8,11 +8,6 @@ COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
8KMACHINE_corei7-64-intel-common = "intel-corei7-64" 8KMACHINE_corei7-64-intel-common = "intel-corei7-64"
9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10 10
11# Quark / X1000 BSP Info
12COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
13KMACHINE_i586-nlp-32-intel-common = "intel-quark"
14KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
15
16# NOTE: We do not set SRCREVs here as -dev is intended to be built with AUTOREV 11# NOTE: We do not set SRCREVs here as -dev is intended to be built with AUTOREV
17# and setting them here breaks the default mechanism to use AUTOREV if the 12# and setting them here breaks the default mechanism to use AUTOREV if the
18# default SRCREV is set and linux-yocto-dev is the preferred provider. 13# default SRCREV is set and linux-yocto-dev is the preferred provider.
diff --git a/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend b/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend
index 17569a1c..de336b04 100644
--- a/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend
+++ b/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend
@@ -7,7 +7,3 @@ KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
8KMACHINE_corei7-64-intel-common = "intel-corei7-64" 8KMACHINE_corei7-64-intel-common = "intel-corei7-64"
9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10
11COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
12KMACHINE_i586-nlp-32-intel-common = "intel-quark"
13KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
diff --git a/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend b/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend
index 17569a1c..de336b04 100644
--- a/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend
+++ b/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend
@@ -7,7 +7,3 @@ KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
8KMACHINE_corei7-64-intel-common = "intel-corei7-64" 8KMACHINE_corei7-64-intel-common = "intel-corei7-64"
9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10
11COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
12KMACHINE_i586-nlp-32-intel-common = "intel-quark"
13KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
diff --git a/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend b/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
index c18f4a11..b8dba297 100644
--- a/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
+++ b/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
@@ -23,11 +23,3 @@ KBRANCH_corei7-64-intel-common = "${KBRANCH_INTEL_COMMON}"
23SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}" 23SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
24SRCREV_machine_corei7-64-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}" 24SRCREV_machine_corei7-64-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
25KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 25KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
26
27LINUX_VERSION_i586-nlp-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
28COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
29KMACHINE_i586-nlp-32-intel-common = "intel-quark"
30KBRANCH_i586-nlp-32-intel-common = "${KBRANCH_INTEL_COMMON}"
31SRCREV_meta_i586-nlp-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
32SRCREV_machine_i586-nlp-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
33KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
diff --git a/recipes-kernel/linux/linux-yocto-rt_4.9.bbappend b/recipes-kernel/linux/linux-yocto-rt_4.9.bbappend
index 9d2e3c0b..3e591799 100644
--- a/recipes-kernel/linux/linux-yocto-rt_4.9.bbappend
+++ b/recipes-kernel/linux/linux-yocto-rt_4.9.bbappend
@@ -7,7 +7,3 @@ KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
8KMACHINE_corei7-64-intel-common = "intel-corei7-64" 8KMACHINE_corei7-64-intel-common = "intel-corei7-64"
9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10
11COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
12KMACHINE_i586-nlp-32-intel-common = "intel-quark"
13KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
diff --git a/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend b/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend
index b8d3d81c..e8c27707 100644
--- a/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend
+++ b/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend
@@ -2,18 +2,14 @@ FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON ?= "" 3KERNEL_FEATURES_INTEL_COMMON ?= ""
4 4
5COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 5COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 6COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
8 7
9KBRANCH_i586-nlp-32-intel-common = "standard/tiny/base"
10KBRANCH_core2-32-intel-common = "standard/tiny/base" 8KBRANCH_core2-32-intel-common = "standard/tiny/base"
11KBRANCH_corei7-64-intel-common = "standard/tiny/base" 9KBRANCH_corei7-64-intel-common = "standard/tiny/base"
12 10
13KMACHINE_i586-nlp-32-intel-common = "intel-quark"
14KMACHINE_core2-32-intel-common = "intel-core2-32" 11KMACHINE_core2-32-intel-common = "intel-core2-32"
15KMACHINE_corei7-64-intel-common = "intel-corei7-64" 12KMACHINE_corei7-64-intel-common = "intel-corei7-64"
16 13
17KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
18KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" 14KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" 15KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
diff --git a/recipes-kernel/linux/linux-yocto-tiny_4.12.bbappend b/recipes-kernel/linux/linux-yocto-tiny_4.12.bbappend
index b8d3d81c..e8c27707 100644
--- a/recipes-kernel/linux/linux-yocto-tiny_4.12.bbappend
+++ b/recipes-kernel/linux/linux-yocto-tiny_4.12.bbappend
@@ -2,18 +2,14 @@ FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON ?= "" 3KERNEL_FEATURES_INTEL_COMMON ?= ""
4 4
5COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 5COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 6COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
8 7
9KBRANCH_i586-nlp-32-intel-common = "standard/tiny/base"
10KBRANCH_core2-32-intel-common = "standard/tiny/base" 8KBRANCH_core2-32-intel-common = "standard/tiny/base"
11KBRANCH_corei7-64-intel-common = "standard/tiny/base" 9KBRANCH_corei7-64-intel-common = "standard/tiny/base"
12 10
13KMACHINE_i586-nlp-32-intel-common = "intel-quark"
14KMACHINE_core2-32-intel-common = "intel-core2-32" 11KMACHINE_core2-32-intel-common = "intel-core2-32"
15KMACHINE_corei7-64-intel-common = "intel-corei7-64" 12KMACHINE_corei7-64-intel-common = "intel-corei7-64"
16 13
17KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
18KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" 14KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" 15KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
diff --git a/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend b/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
index 54430e21..84bb1d23 100644
--- a/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
+++ b/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
@@ -4,30 +4,23 @@ EXTRA_OEMAKE = "LD=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}ld AR=${
4 4
5KERNEL_FEATURES_INTEL_COMMON ?= "" 5KERNEL_FEATURES_INTEL_COMMON ?= ""
6 6
7LINUX_VERSION_i586-nlp-32-intel-common = "4.4.87"
8LINUX_VERSION_core2-32-intel-common = "4.4.87" 7LINUX_VERSION_core2-32-intel-common = "4.4.87"
9LINUX_VERSION_corei7-64-intel-common = "4.4.87" 8LINUX_VERSION_corei7-64-intel-common = "4.4.87"
10 9
11SRCREV_meta_i586-nlp-32-intel-common = "804d2b3164ec25ed519fd695de9aa0908460c92e"
12SRCREV_meta_core2-32-intel-common = "804d2b3164ec25ed519fd695de9aa0908460c92e" 10SRCREV_meta_core2-32-intel-common = "804d2b3164ec25ed519fd695de9aa0908460c92e"
13SRCREV_meta_corei7-64-intel-common = "804d2b3164ec25ed519fd695de9aa0908460c92e" 11SRCREV_meta_corei7-64-intel-common = "804d2b3164ec25ed519fd695de9aa0908460c92e"
14 12
15SRCREV_machine_i586-nlp-32-intel-common = "85b913cc9d5e13602d69e50bd9cf1a6ef242f9ee"
16SRCREV_machine_core2-32-intel-common = "85b913cc9d5e13602d69e50bd9cf1a6ef242f9ee" 13SRCREV_machine_core2-32-intel-common = "85b913cc9d5e13602d69e50bd9cf1a6ef242f9ee"
17SRCREV_machine_corei7-64-intel-common = "85b913cc9d5e13602d69e50bd9cf1a6ef242f9ee" 14SRCREV_machine_corei7-64-intel-common = "85b913cc9d5e13602d69e50bd9cf1a6ef242f9ee"
18 15
19COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
20COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 16COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
21COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 17COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
22 18
23KBRANCH_i586-nlp-32-intel-common = "standard/tiny/intel/base"
24KBRANCH_core2-32-intel-common = "standard/tiny/intel/base" 19KBRANCH_core2-32-intel-common = "standard/tiny/intel/base"
25KBRANCH_corei7-64-intel-common = "standard/tiny/intel/base" 20KBRANCH_corei7-64-intel-common = "standard/tiny/intel/base"
26 21
27KMACHINE_i586-nlp-32-intel-common = "intel-quark"
28KMACHINE_core2-32-intel-common = "intel-core2-32" 22KMACHINE_core2-32-intel-common = "intel-core2-32"
29KMACHINE_corei7-64-intel-common = "intel-corei7-64" 23KMACHINE_corei7-64-intel-common = "intel-corei7-64"
30 24
31KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
32KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" 25KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
33KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" 26KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
diff --git a/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend b/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend
index 9ecdb95a..84d61ab4 100644
--- a/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend
+++ b/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend
@@ -2,30 +2,23 @@ FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
2 2
3EXTRA_OEMAKE = "LD=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}ld AR=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}gcc-ar" 3EXTRA_OEMAKE = "LD=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}ld AR=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}gcc-ar"
4 4
5LINUX_VERSION_i586-nlp-32-intel-common = "4.9.13"
6LINUX_VERSION_core2-32-intel-common = "4.9.13" 5LINUX_VERSION_core2-32-intel-common = "4.9.13"
7LINUX_VERSION_corei7-64-intel-common = "4.9.13" 6LINUX_VERSION_corei7-64-intel-common = "4.9.13"
8 7
9SRCREV_meta_i586-nlp-32-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de"
10SRCREV_meta_core2-32-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de" 8SRCREV_meta_core2-32-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de"
11SRCREV_meta_corei7-64-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de" 9SRCREV_meta_corei7-64-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de"
12 10
13SRCREV_machine_i586-nlp-32-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098"
14SRCREV_machine_core2-32-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098" 11SRCREV_machine_core2-32-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098"
15SRCREV_machine_corei7-64-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098" 12SRCREV_machine_corei7-64-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098"
16 13
17COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
18COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 14COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
19COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 15COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
20 16
21KBRANCH_i586-nlp-32-intel-common = "standard/tiny/base"
22KBRANCH_core2-32-intel-common = "standard/tiny/base" 17KBRANCH_core2-32-intel-common = "standard/tiny/base"
23KBRANCH_corei7-64-intel-common = "standard/tiny/base" 18KBRANCH_corei7-64-intel-common = "standard/tiny/base"
24 19
25KMACHINE_i586-nlp-32-intel-common = "intel-quark"
26KMACHINE_core2-32-intel-common = "intel-core2-32" 20KMACHINE_core2-32-intel-common = "intel-core2-32"
27KMACHINE_corei7-64-intel-common = "intel-corei7-64" 21KMACHINE_corei7-64-intel-common = "intel-corei7-64"
28 22
29KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
30KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" 23KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
31KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" 24KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
diff --git a/recipes-kernel/linux/linux-yocto_4.10.bbappend b/recipes-kernel/linux/linux-yocto_4.10.bbappend
index 20504637..b99001ed 100644
--- a/recipes-kernel/linux/linux-yocto_4.10.bbappend
+++ b/recipes-kernel/linux/linux-yocto_4.10.bbappend
@@ -8,10 +8,6 @@ COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
8KMACHINE_corei7-64-intel-common = "intel-corei7-64" 8KMACHINE_corei7-64-intel-common = "intel-corei7-64"
9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10 10
11COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
12KMACHINE_i586-nlp-32-intel-common = "intel-quark"
13KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
14
15# For Crystalforest and Romley 11# For Crystalforest and Romley
16KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" 12KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
17KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" 13KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
diff --git a/recipes-kernel/linux/linux-yocto_4.12.bbappend b/recipes-kernel/linux/linux-yocto_4.12.bbappend
index 20504637..b99001ed 100644
--- a/recipes-kernel/linux/linux-yocto_4.12.bbappend
+++ b/recipes-kernel/linux/linux-yocto_4.12.bbappend
@@ -8,10 +8,6 @@ COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
8KMACHINE_corei7-64-intel-common = "intel-corei7-64" 8KMACHINE_corei7-64-intel-common = "intel-corei7-64"
9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10 10
11COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
12KMACHINE_i586-nlp-32-intel-common = "intel-quark"
13KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
14
15# For Crystalforest and Romley 11# For Crystalforest and Romley
16KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" 12KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
17KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" 13KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
diff --git a/recipes-kernel/linux/linux-yocto_4.4.bbappend b/recipes-kernel/linux/linux-yocto_4.4.bbappend
index 3b02a932..33d75f0a 100644
--- a/recipes-kernel/linux/linux-yocto_4.4.bbappend
+++ b/recipes-kernel/linux/linux-yocto_4.4.bbappend
@@ -24,16 +24,6 @@ SRCREV_machine_corei7-64-intel-common ?= "${@bb.utils.contains('INTEL_MACHINE_SU
24KBRANCH_corei7-64-intel-common = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'standard/intel/bxt-rebase;rebaseable=1', '${KBRANCH_INTEL_COMMON}', d)}" 24KBRANCH_corei7-64-intel-common = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'standard/intel/bxt-rebase;rebaseable=1', '${KBRANCH_INTEL_COMMON}', d)}"
25KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 25KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
26 26
27# Quark / X1000 BSP Info
28LINUX_VERSION_i586-nlp-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
29COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
30KMACHINE_i586-nlp-32-intel-common = "intel-quark"
31KBRANCH_i586-nlp-32-intel-common = "${KBRANCH_INTEL_COMMON}"
32SRCREV_meta_i586-nlp-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
33SRCREV_machine_i586-nlp-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
34KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
35
36
37# For Crystalforest and Romley 27# For Crystalforest and Romley
38KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" 28KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
39KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" 29KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
diff --git a/recipes-kernel/linux/linux-yocto_4.9.bbappend b/recipes-kernel/linux/linux-yocto_4.9.bbappend
index a09fe1a4..9be620bb 100644
--- a/recipes-kernel/linux/linux-yocto_4.9.bbappend
+++ b/recipes-kernel/linux/linux-yocto_4.9.bbappend
@@ -8,10 +8,6 @@ COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
8KMACHINE_corei7-64-intel-common = "intel-corei7-64" 8KMACHINE_corei7-64-intel-common = "intel-corei7-64"
9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10 10
11COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
12KMACHINE_i586-nlp-32-intel-common = "intel-quark"
13KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
14
15# For Crystalforest and Romley 11# For Crystalforest and Romley
16KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" 12KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
17KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" 13KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"