summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2024-02-28 11:53:10 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2024-02-28 22:38:44 +0800
commit9ed54a13803e42ca40589d6ce02c76f3162f6b73 (patch)
treebbef9541d15005fae22b65754b1049b8fa89596e
parent0935c639d48141b7dec50be525008e9907f32933 (diff)
downloadmeta-intel-9ed54a13803e42ca40589d6ce02c76f3162f6b73.tar.gz
ispc: upgrade 1.22.0 -> 1.23.0
Release notes: https://github.com/ispc/ispc/releases/tag/v1.23.0 llvm-dis is no longer a build dependency. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Add-print-function-to-print-test-run-status-in-ptest.patch13
-rw-r--r--dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch9
-rw-r--r--dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-return-type-of-lParseOperator.patch51
-rw-r--r--dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch11
-rw-r--r--dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.23.0.bb (renamed from dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.22.0.bb)4
5 files changed, 14 insertions, 74 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Add-print-function-to-print-test-run-status-in-ptest.patch b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Add-print-function-to-print-test-run-status-in-ptest.patch
index 3ce431d4..4d583657 100644
--- a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Add-print-function-to-print-test-run-status-in-ptest.patch
+++ b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Add-print-function-to-print-test-run-status-in-ptest.patch
@@ -1,4 +1,4 @@
1From 6ba81efe971fb6038af6e950e853d35ee6dd9cc3 Mon Sep 17 00:00:00 2001 1From deccc0c69c2c8759c52885be8bdda54d3cee481c Mon Sep 17 00:00:00 2001
2From: Yogesh Tyagi <yogesh.tyagi@intel.com> 2From: Yogesh Tyagi <yogesh.tyagi@intel.com>
3Date: Sun, 11 Dec 2022 22:34:15 +0800 3Date: Sun, 11 Dec 2022 22:34:15 +0800
4Subject: [PATCH] Add print function to print test run status in ptest format 4Subject: [PATCH] Add print function to print test run status in ptest format
@@ -11,10 +11,10 @@ Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
11 1 file changed, 16 insertions(+) 11 1 file changed, 16 insertions(+)
12 12
13diff --git a/run_tests.py b/run_tests.py 13diff --git a/run_tests.py b/run_tests.py
14index 87305a06..4f2f0f59 100755 14index 1cd796dd..e3ffd1ab 100755
15--- a/run_tests.py 15--- a/run_tests.py
16+++ b/run_tests.py 16+++ b/run_tests.py
17@@ -385,6 +385,9 @@ def run_test(testname, host, target): 17@@ -327,6 +327,9 @@ def run_test(testname, host, target):
18 else: 18 else:
19 ispc_exe_rel = add_prefix(host.ispc_cmd, host, target) 19 ispc_exe_rel = add_prefix(host.ispc_cmd, host, target)
20 20
@@ -24,7 +24,7 @@ index 87305a06..4f2f0f59 100755
24 # is this a test to make sure an error is issued? 24 # is this a test to make sure an error is issued?
25 want_error = (filename.find("tests_errors") != -1) 25 want_error = (filename.find("tests_errors") != -1)
26 if want_error == True: 26 if want_error == True:
27@@ -844,6 +847,17 @@ def check_compiler_exists(compiler_exe): 27@@ -795,6 +798,17 @@ def check_compiler_exists(compiler_exe):
28 return 28 return
29 error("missing the required compiler: %s \n" % compiler_exe, 1) 29 error("missing the required compiler: %s \n" % compiler_exe, 1)
30 30
@@ -42,7 +42,7 @@ index 87305a06..4f2f0f59 100755
42 def print_result(status, results, s, run_tests_log, csv): 42 def print_result(status, results, s, run_tests_log, csv):
43 title = StatusStr[status] 43 title = StatusStr[status]
44 file_list = [fname for fname, fstatus in results if status == fstatus] 44 file_list = [fname for fname, fstatus in results if status == fstatus]
45@@ -987,6 +1001,8 @@ def run_tests(options1, args, print_version): 45@@ -938,6 +952,8 @@ def run_tests(options1, args, print_version):
46 pass_rate = -1 46 pass_rate = -1
47 print_debug("PASSRATE (%d/%d) = %d%% \n\n" % (len(run_succeed_files), total_tests_executed, pass_rate), s, run_tests_log) 47 print_debug("PASSRATE (%d/%d) = %d%% \n\n" % (len(run_succeed_files), total_tests_executed, pass_rate), s, run_tests_log)
48 48
@@ -51,6 +51,3 @@ index 87305a06..4f2f0f59 100755
51 for status in Status: 51 for status in Status:
52 print_result(status, results, s, run_tests_log, options.csv) 52 print_result(status, results, s, run_tests_log, options.csv)
53 fails = [status != Status.Compfail and status != Status.Runfail for _, status in results] 53 fails = [status != Status.Compfail and status != Status.Runfail for _, status in results]
54--
552.37.3
56
diff --git a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch
index e7bb599e..b0a76ff9 100644
--- a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch
+++ b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch
@@ -1,4 +1,4 @@
1From 139b94a7fb72114c31a2a6ab3f7e6024b4a738ec Mon Sep 17 00:00:00 2001 1From 7beff95c11071170eb27b6fa7d0cc77588caee8e Mon Sep 17 00:00:00 2001
2From: Yogesh Tyagi <yogesh.tyagi@intel.com> 2From: Yogesh Tyagi <yogesh.tyagi@intel.com>
3Date: Tue, 26 Jul 2022 15:25:10 +0800 3Date: Tue, 26 Jul 2022 15:25:10 +0800
4Subject: [PATCH] Fix QA Issues 4Subject: [PATCH] Fix QA Issues
@@ -8,16 +8,15 @@ Stop ispc from inserting host file path in generated headers which leads to repr
8Upstream-Status: Inappropriate [OE build specific] 8Upstream-Status: Inappropriate [OE build specific]
9 9
10Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> 10Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
11
12--- 11---
13 src/module.cpp | 4 ++-- 12 src/module.cpp | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-) 13 1 file changed, 2 insertions(+), 2 deletions(-)
15 14
16diff --git a/src/module.cpp b/src/module.cpp 15diff --git a/src/module.cpp b/src/module.cpp
17index 58a2ae83..82673052 100644 16index e2084d2e..e2626865 100644
18--- a/src/module.cpp 17--- a/src/module.cpp
19+++ b/src/module.cpp 18+++ b/src/module.cpp
20@@ -2105,7 +2105,7 @@ bool Module::writeHeader(const char *fn) { 19@@ -2555,7 +2555,7 @@ bool Module::writeHeader(const char *fn) {
21 perror("fopen"); 20 perror("fopen");
22 return false; 21 return false;
23 } 22 }
@@ -26,7 +25,7 @@ index 58a2ae83..82673052 100644
26 fprintf(f, "// DO NOT EDIT THIS FILE.\n//\n\n"); 25 fprintf(f, "// DO NOT EDIT THIS FILE.\n//\n\n");
27 26
28 // Create a nice guard string from the filename, turning any 27 // Create a nice guard string from the filename, turning any
29@@ -2219,7 +2219,7 @@ bool Module::writeDispatchHeader(DispatchHeaderInfo *DHI) { 28@@ -2677,7 +2677,7 @@ bool Module::writeDispatchHeader(DispatchHeaderInfo *DHI) {
30 FILE *f = DHI->file; 29 FILE *f = DHI->file;
31 30
32 if (DHI->EmitFrontMatter) { 31 if (DHI->EmitFrontMatter) {
diff --git a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-return-type-of-lParseOperator.patch b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-return-type-of-lParseOperator.patch
deleted file mode 100644
index 6ef6cba1..00000000
--- a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-return-type-of-lParseOperator.patch
+++ /dev/null
@@ -1,51 +0,0 @@
1From 1d1b0f4eacb7d3875d7dd53e2df8dfca2031fa3a Mon Sep 17 00:00:00 2001
2From: Aleksei Nurmukhametov <aleksei.nurmukhametov@intel.com>
3Date: Tue, 28 Nov 2023 04:11:44 -0800
4Subject: [PATCH] Fix return type of lParseOperator
5
6When bison is used in -y mode that emulates POSIX Yacc, tokens are
7defined as enums (under YYTOKENTYPE ifdef) or as int via macro
8definitions. Defining return type as yytokentype causes compile error:
9invalid conversion from 'int' to 'yytokentype'. To avoid it, return int
10as we do with lParseInteger and lParseFP.
11
12Upstream-Status: Submitted [https://github.com/ispc/ispc/pull/2709]
13
14Signed-off-by: Aleksei Nurmukhametov <aleksei.nurmukhametov@intel.com>
15Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
16---
17 src/lex.ll | 4 ++--
18 1 file changed, 2 insertions(+), 2 deletions(-)
19
20diff --git a/src/lex.ll b/src/lex.ll
21index f9e47578..0279831d 100644
22--- a/src/lex.ll
23+++ b/src/lex.ll
24@@ -20,6 +20,7 @@ using namespace ispc;
25 static uint64_t lParseBinary(const char *ptr, SourcePos pos, char **endPtr);
26 static int lParseInteger(bool dotdotdot);
27 static int lParseFP();
28+static int lParseOperator(const char *ptr);
29 static void lCComment(SourcePos *);
30 static void lCppComment(SourcePos *);
31 static void lNextValidChar(SourcePos *, char const*&);
32@@ -29,7 +30,6 @@ static bool lConsumePragma(YYSTYPE *, SourcePos *);
33 static void lHandleCppHash(SourcePos *);
34 static void lStringConst(YYSTYPE *, SourcePos *);
35 static double lParseHexFloat(const char *ptr);
36-static yytokentype lParseOperator(const char *ptr);
37 extern const char *RegisterDependency(const std::string &fileName);
38
39 #define YY_USER_ACTION \
40@@ -1162,7 +1162,7 @@ lParseHexFloat(const char *ptr) {
41
42 /** Parse an operator.
43 */
44-static yytokentype
45+static int
46 lParseOperator(const char *ptr) {
47 yylval.stringVal = new std::string(ptr);
48 if (m->symbolTable->LookupFunctionTemplate(yytext))
49--
502.37.3
51
diff --git a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch
index ef9d99c0..f452dc50 100644
--- a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch
+++ b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch
@@ -1,4 +1,4 @@
1From cad70deae39566fa11814e27f06d5fe8ddcb1cbc Mon Sep 17 00:00:00 2001 1From 16a2c22339287122d2c25d8bb33a5a51b4e6ee51 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com> 2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Thu, 24 Feb 2022 20:01:11 +0530 3Date: Thu, 24 Feb 2022 20:01:11 +0530
4Subject: [PATCH] cmake: don't build for 32-bit targets 4Subject: [PATCH] cmake: don't build for 32-bit targets
@@ -20,7 +20,7 @@ Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
20 1 file changed, 3 insertions(+), 3 deletions(-) 20 1 file changed, 3 insertions(+), 3 deletions(-)
21 21
22diff --git a/cmake/GenerateBuiltins.cmake b/cmake/GenerateBuiltins.cmake 22diff --git a/cmake/GenerateBuiltins.cmake b/cmake/GenerateBuiltins.cmake
23index 936590a7..b8f731de 100644 23index f84494ed..d90cb1ec 100644
24--- a/cmake/GenerateBuiltins.cmake 24--- a/cmake/GenerateBuiltins.cmake
25+++ b/cmake/GenerateBuiltins.cmake 25+++ b/cmake/GenerateBuiltins.cmake
26@@ -253,7 +253,7 @@ function(builtin_to_cpp bit os_name arch supported_archs supported_oses resultFi 26@@ -253,7 +253,7 @@ function(builtin_to_cpp bit os_name arch supported_archs supported_oses resultFi
@@ -32,7 +32,7 @@ index 936590a7..b8f731de 100644
32 endif() 32 endif()
33 endif() 33 endif()
34 34
35@@ -340,7 +340,7 @@ function (generate_target_builtins resultList) 35@@ -339,7 +339,7 @@ function (generate_target_builtins resultList)
36 set(regular_targets ${ARGN}) 36 set(regular_targets ${ARGN})
37 list(FILTER regular_targets EXCLUDE REGEX wasm) 37 list(FILTER regular_targets EXCLUDE REGEX wasm)
38 foreach (ispc_target ${regular_targets}) 38 foreach (ispc_target ${regular_targets})
@@ -41,7 +41,7 @@ index 936590a7..b8f731de 100644
41 foreach (os_name ${TARGET_OS_LIST_FOR_LL}) 41 foreach (os_name ${TARGET_OS_LIST_FOR_LL})
42 target_ll_to_cpp(target-${ispc_target} ${bit} ${os_name} output${os_name}${bit}) 42 target_ll_to_cpp(target-${ispc_target} ${bit} ${os_name} output${os_name}${bit})
43 list(APPEND tmpList ${output${os_name}${bit}}) 43 list(APPEND tmpList ${output${os_name}${bit}})
44@@ -406,7 +406,7 @@ function (generate_common_builtins resultList) 44@@ -405,7 +405,7 @@ function (generate_common_builtins resultList)
45 endif() 45 endif()
46 46
47 message (STATUS "ISPC will be built with support of ${supported_oses} for ${supported_archs}") 47 message (STATUS "ISPC will be built with support of ${supported_oses} for ${supported_archs}")
@@ -50,6 +50,3 @@ index 936590a7..b8f731de 100644
50 foreach (os_name "windows" "linux" "freebsd" "macos" "android" "ios" "ps4" "web") 50 foreach (os_name "windows" "linux" "freebsd" "macos" "android" "ios" "ps4" "web")
51 foreach (arch "x86" "arm" "wasm") 51 foreach (arch "x86" "arm" "wasm")
52 builtin_to_cpp(${bit} ${os_name} ${arch} "${supported_archs}" "${supported_oses}" res${bit}${os_name}${arch}) 52 builtin_to_cpp(${bit} ${os_name} ${arch} "${supported_archs}" "${supported_oses}" res${bit}${os_name}${arch})
53--
542.41.0
55
diff --git a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.22.0.bb b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.23.0.bb
index 4b434bb0..ed8df859 100644
--- a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.22.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.23.0.bb
@@ -15,11 +15,10 @@ SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \
15 file://0002-cmake-don-t-build-for-32-bit-targets.patch \ 15 file://0002-cmake-don-t-build-for-32-bit-targets.patch \
16 file://0001-Fix-QA-Issues.patch \ 16 file://0001-Fix-QA-Issues.patch \
17 file://0001-Add-print-function-to-print-test-run-status-in-ptest.patch \ 17 file://0001-Add-print-function-to-print-test-run-status-in-ptest.patch \
18 file://0001-Fix-return-type-of-lParseOperator.patch \
19 file://run-ptest \ 18 file://run-ptest \
20 " 19 "
21 20
22SRCREV = "bd2c42d42e0cc3da1baf92160b82d4dc820a02ee" 21SRCREV = "bcb2cf896c00f9a802a11cbf291ef6e44b205416"
23 22
24COMPATIBLE_HOST = '(x86_64).*-linux' 23COMPATIBLE_HOST = '(x86_64).*-linux'
25 24
@@ -59,7 +58,6 @@ EXTRA_OECMAKE += " \
59 -DSYSROOT_DIR=${STAGING_DIR} \ 58 -DSYSROOT_DIR=${STAGING_DIR} \
60 -DCLANG_EXECUTABLE=${STAGING_BINDIR_NATIVE}/clang \ 59 -DCLANG_EXECUTABLE=${STAGING_BINDIR_NATIVE}/clang \
61 -DCLANGPP_EXECUTABLE=${STAGING_BINDIR_NATIVE}/clang++ \ 60 -DCLANGPP_EXECUTABLE=${STAGING_BINDIR_NATIVE}/clang++ \
62 -DLLVM_DIS_EXECUTABLE=${STAGING_BINDIR_NATIVE}/llvm-dis \
63 -DLLVM_AS_EXECUTABLE=${STAGING_BINDIR_NATIVE}/llvm-as \ 61 -DLLVM_AS_EXECUTABLE=${STAGING_BINDIR_NATIVE}/llvm-as \
64 " 62 "
65 63