summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2014-09-04 15:34:11 -0700
committerTom Zanussi <tom.zanussi@linux.intel.com>2014-09-16 20:12:13 -0500
commit964d5daa7cea2b357c68eb2c91d17779eeba6a49 (patch)
tree8834b5d2053b51353b3d97e9267ee203b3421995
parent5f67993caf7eb3423c965259fedaa91e0734cdd0 (diff)
downloadmeta-intel-964d5daa7cea2b357c68eb2c91d17779eeba6a49.tar.gz
Remove fri2 machine support
The fri2 machine has been retired with this commit. This does not affect the fri2-noemgd machine and it is supported as usual. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
-rw-r--r--meta-fri2/README51
-rw-r--r--meta-fri2/conf/machine/fri2.conf47
-rw-r--r--meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2/asound.state411
-rw-r--r--meta-fri2/recipes-bsp/formfactor/formfactor/fri2/machconfig3
-rw-r--r--meta-fri2/recipes-core/init-ifupdown/files/fri2/interfaces9
-rw-r--r--meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config/fri2/xorg.conf60
-rw-r--r--meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend1
-rw-r--r--meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend7
-rw-r--r--meta-fri2/recipes-kernel/linux/linux-yocto-tiny_3.10.bbappend8
-rw-r--r--meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend11
10 files changed, 6 insertions, 602 deletions
diff --git a/meta-fri2/README b/meta-fri2/README
index d5ac6674..6e90c335 100644
--- a/meta-fri2/README
+++ b/meta-fri2/README
@@ -12,9 +12,6 @@ Intel EG20T Platform Controller Hub (Tunnel Creek + Topcliff). The Fish River
12Island II includes a variety of communications options and other 12Island II includes a variety of communications options and other
13machine-to-machine (m2m) capabilities. 13machine-to-machine (m2m) capabilities.
14 14
15It also supports the E6xx embedded on-chip graphics via the Intel
16Embedded Media and Graphics Driver (EMGD).
17
18Information on all Intel embedded platforms can be found here: 15Information on all Intel embedded platforms can be found here:
19 16
20 http://www.intel.com/p/en_US/embedded/hwsw/hardware 17 http://www.intel.com/p/en_US/embedded/hwsw/hardware
@@ -96,33 +93,12 @@ bblayers.conf, e.g.:
96 yocto/meta-intel \ 93 yocto/meta-intel \
97 yocto/meta-intel/meta-fri2 \ 94 yocto/meta-intel/meta-fri2 \
98 95
99The meta-fri2 layer contains support for two different machine 96The meta-fri2 layer contains support for fri2-noemgd machine configuration.
100configurations. These configurations are identical except for the fact 97The previously supported fri2 machine with the proprietary EMGD graphics
101that the one prefixed with 'fri2' makes use of the Intel-proprietary 98driver has been retired. The 'fri2-noemgd' machine configuration uses
102EMGD graphics driver, while the one prefixed with 'fri2-noemgd' 99the open source 'vesa' kernel driver.
103does not.
104
105If you want to enable the layer that supports EMGD graphics add the
106following to the local.conf file:
107
108 MACHINE ?= "fri2"
109
110The 'fri2' machine includes the emgd-driver-bin package, which has a
111proprietary license that must be whitelisted by adding the string
112"license_emgd-driver-bin" to the LICENSE_FLAGS_WHITELIST variable in
113your local.conf. For example:
114
115 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin"
116
117The emgd recipe depends on Xorg's dri and glx modules, which are built
118only when 'opengl' is listed in DISTRO_FEATURES. So if the distro
119doesn't list 'opengl' in the DISTRO_FEATURES you would need this
120additional line to your local.conf:
121 100
122 DISTRO_FEATURES_append = " opengl" 101To enable the layer add the following to the local.conf file:
123
124If you want to enable the layer that does not support EMGD graphics,
125add the following to the local.conf file:
126 102
127 MACHINE ?= "fri2-noemgd" 103 MACHINE ?= "fri2-noemgd"
128 104
@@ -135,21 +111,6 @@ At the end of a successful build, you should have a live image that
135you can boot from a USB flash drive (see instructions on how to do 111you can boot from a USB flash drive (see instructions on how to do
136that below, in the section 'Booting the images from /binary'). 112that below, in the section 'Booting the images from /binary').
137 113
138NOTE: The 'fri2' machine will include support for hardware video
139acceleration via gstreamer if and only if the "commercial" string is
140added to the the LICENSE_FLAGS_WHITELIST variable in your local.conf.
141
142For example:
143
144 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin commercial"
145
146The reason this is needed is to prevent the image from including
147anything that might violate the license terms of the packages used to
148implement the the video acceleration feature, such as gst-ffmpeg and
149ffmpeg. As always, please consult the licenses included in the
150specific packages for details if you use packages that require
151particular LICENSE_FLAGS.
152
153As an alternative to downloading the BSP tarball, you can also work 114As an alternative to downloading the BSP tarball, you can also work
154directly from the meta-intel git repository. For each BSP in the 115directly from the meta-intel git repository. For each BSP in the
155'meta-intel' repository, there are multiple branches, one 116'meta-intel' repository, there are multiple branches, one
@@ -171,7 +132,7 @@ Under Linux, insert a USB flash drive. Assuming the USB flash drive
171takes device /dev/sdf, use dd to copy the live image to it. For 132takes device /dev/sdf, use dd to copy the live image to it. For
172example: 133example:
173 134
174# dd if=core-image-sato-fri2.hddimg of=/dev/sdf 135# dd if=core-image-sato-fri2-noemgd.hddimg of=/dev/sdf
175# sync 136# sync
176# eject /dev/sdf 137# eject /dev/sdf
177 138
diff --git a/meta-fri2/conf/machine/fri2.conf b/meta-fri2/conf/machine/fri2.conf
deleted file mode 100644
index 83072d3b..00000000
--- a/meta-fri2/conf/machine/fri2.conf
+++ /dev/null
@@ -1,47 +0,0 @@
1#@TYPE: Machine
2#@NAME: fri2
3
4#@WEBTITLE: Intel Atom E640T Processor with Intel EG20T Controller Hub Development Kit (Queens Bay) with Proprietary IEMGD Accelerated Graphics for Fish River Island II systems
5
6#@DESCRIPTION: Machine configuration for Fish River Island II systems
7
8require conf/machine/include/intel-core2-32-common.inc
9require conf/machine/include/meta-intel.inc
10require conf/machine/include/meta-intel-emgd.inc
11
12MACHINE_HWCODECS ?= "va-intel"
13XSERVERCODECS ?= "emgd-driver-video emgd-gst-plugins-va \
14 emgd-gst-plugins-mixvideo gst-va-intel"
15
16MACHINE_FEATURES += "wifi 3g pcbios efi va-impl-mixvideo"
17MACHINE_EXTRA_RRECOMMENDS += "linux-firmware-iwlwifi-6000g2a-5"
18
19PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
20PREFERRED_VERSION_linux-yocto = "3.10%"
21
22XSERVER ?= "${XSERVER_X86_BASE} \
23 ${XSERVER_X86_EXT} \
24 ${XSERVER_X86_EMGD} \
25 "
26
27PREFERRED_VERSION_xserver-xorg ?= "1.9.3"
28PREFERRED_VERSION_xf86-input-synaptics ?= "1.6.3"
29PREFERRED_VERSION_xf86-input-evdev ?= "2.6.0"
30PREFERRED_VERSION_emgd-driver-bin ?= "1.18"
31PREFERRED_VERSION_libva ?= "1.0.16"
32
33# Syslinux does not know about the 64MHz uart clock and it does not detect the
34# serial device by number. Use the IO port directly and divide the baud down to
35# trick syslinux into configuring a 115200 baud.
36SYSLINUX_OPTS = "serial 0xb060 3318"
37SERIAL_CONSOLE = "115200 ttyPCH1"
38APPEND += "console=ttyPCH1,115200 console=tty0"
39
40# EFI boot will ignore this and use the EFI framebuffer at 800x600
41APPEND += "video=vesafb vga=0x318"
42
43# EMGD kernel driver needs at least 256MB of vmalloc space
44APPEND += "vmalloc=256MB"
45
46# MSI interrupts fail for the HDA device when using the EFI firmware
47APPEND += "snd_hda_intel.enable_msi=0"
diff --git a/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2/asound.state b/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2/asound.state
deleted file mode 100644
index 8a89f0bc..00000000
--- a/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2/asound.state
+++ /dev/null
@@ -1,411 +0,0 @@
1state.MID {
2 control.1 {
3 iface MIXER
4 name 'PCM Playback Volume'
5 value.0 24
6 value.1 24
7 comment {
8 access 'read write'
9 type INTEGER
10 count 2
11 range '0 - 30'
12 dbmin -4500
13 dbmax 0
14 dbvalue.0 -900
15 dbvalue.1 -900
16 }
17 }
18 control.2 {
19 iface MIXER
20 name 'PCM Playback Switch'
21 value.0 true
22 value.1 true
23 comment {
24 access 'read write'
25 type BOOLEAN
26 count 2
27 }
28 }
29 control.3 {
30 iface MIXER
31 name 'Headphone Playback Volume'
32 value.0 0
33 value.1 0
34 comment {
35 access 'read write'
36 type INTEGER
37 count 2
38 range '0 - 30'
39 dbmin -4500
40 dbmax 0
41 dbvalue.0 -4500
42 dbvalue.1 -4500
43 }
44 }
45 control.4 {
46 iface MIXER
47 name 'Headphone Playback Switch'
48 value.0 false
49 value.1 false
50 comment {
51 access 'read write'
52 type BOOLEAN
53 count 2
54 }
55 }
56 control.5 {
57 iface MIXER
58 name 'Rear Mic Playback Volume'
59 value.0 0
60 value.1 0
61 comment {
62 access 'read write'
63 type INTEGER
64 count 2
65 range '0 - 31'
66 dbmin -3450
67 dbmax 1200
68 dbvalue.0 -3450
69 dbvalue.1 -3450
70 }
71 }
72 control.6 {
73 iface MIXER
74 name 'Rear Mic Playback Switch'
75 value.0 false
76 value.1 false
77 comment {
78 access 'read write'
79 type BOOLEAN
80 count 2
81 }
82 }
83 control.7 {
84 iface MIXER
85 name 'Front Mic Playback Volume'
86 value.0 0
87 value.1 0
88 comment {
89 access 'read write'
90 type INTEGER
91 count 2
92 range '0 - 31'
93 dbmin -3450
94 dbmax 1200
95 dbvalue.0 -3450
96 dbvalue.1 -3450
97 }
98 }
99 control.8 {
100 iface MIXER
101 name 'Front Mic Playback Switch'
102 value.0 false
103 value.1 false
104 comment {
105 access 'read write'
106 type BOOLEAN
107 count 2
108 }
109 }
110 control.9 {
111 iface MIXER
112 name 'Line Playback Volume'
113 value.0 0
114 value.1 0
115 comment {
116 access 'read write'
117 type INTEGER
118 count 2
119 range '0 - 31'
120 dbmin -3450
121 dbmax 1200
122 dbvalue.0 -3450
123 dbvalue.1 -3450
124 }
125 }
126 control.10 {
127 iface MIXER
128 name 'Line Playback Switch'
129 value.0 false
130 value.1 false
131 comment {
132 access 'read write'
133 type BOOLEAN
134 count 2
135 }
136 }
137 control.11 {
138 iface MIXER
139 name 'CD Playback Volume'
140 value.0 0
141 value.1 0
142 comment {
143 access 'read write'
144 type INTEGER
145 count 2
146 range '0 - 31'
147 dbmin -3450
148 dbmax 1200
149 dbvalue.0 -3450
150 dbvalue.1 -3450
151 }
152 }
153 control.12 {
154 iface MIXER
155 name 'CD Playback Switch'
156 value.0 false
157 value.1 false
158 comment {
159 access 'read write'
160 type BOOLEAN
161 count 2
162 }
163 }
164 control.13 {
165 iface MIXER
166 name 'Auto-Mute Mode'
167 value Disabled
168 comment {
169 access 'read write'
170 type ENUMERATED
171 count 1
172 item.0 Disabled
173 item.1 Enabled
174 }
175 }
176 control.14 {
177 iface MIXER
178 name 'Rear Mic Boost Volume'
179 value.0 0
180 value.1 0
181 comment {
182 access 'read write'
183 type INTEGER
184 count 2
185 range '0 - 3'
186 dbmin 0
187 dbmax 3000
188 dbvalue.0 0
189 dbvalue.1 0
190 }
191 }
192 control.15 {
193 iface MIXER
194 name 'Front Mic Boost Volume'
195 value.0 0
196 value.1 0
197 comment {
198 access 'read write'
199 type INTEGER
200 count 2
201 range '0 - 3'
202 dbmin 0
203 dbmax 3000
204 dbvalue.0 0
205 dbvalue.1 0
206 }
207 }
208 control.16 {
209 iface MIXER
210 name 'Capture Switch'
211 value.0 true
212 value.1 true
213 comment {
214 access 'read write'
215 type BOOLEAN
216 count 2
217 }
218 }
219 control.17 {
220 iface MIXER
221 name 'Capture Switch'
222 index 1
223 value.0 false
224 value.1 false
225 comment {
226 access 'read write'
227 type BOOLEAN
228 count 2
229 }
230 }
231 control.18 {
232 iface MIXER
233 name 'Capture Switch'
234 index 2
235 value.0 false
236 value.1 false
237 comment {
238 access 'read write'
239 type BOOLEAN
240 count 2
241 }
242 }
243 control.19 {
244 iface MIXER
245 name 'Capture Volume'
246 value.0 25
247 value.1 25
248 comment {
249 access 'read write'
250 type INTEGER
251 count 2
252 range '0 - 31'
253 dbmin -1200
254 dbmax 3450
255 dbvalue.0 2550
256 dbvalue.1 2550
257 }
258 }
259 control.20 {
260 iface MIXER
261 name 'Capture Volume'
262 index 1
263 value.0 0
264 value.1 0
265 comment {
266 access 'read write'
267 type INTEGER
268 count 2
269 range '0 - 31'
270 dbmin -1200
271 dbmax 3450
272 dbvalue.0 -1200
273 dbvalue.1 -1200
274 }
275 }
276 control.21 {
277 iface MIXER
278 name 'Capture Volume'
279 index 2
280 value.0 0
281 value.1 0
282 comment {
283 access 'read write'
284 type INTEGER
285 count 2
286 range '0 - 31'
287 dbmin -1200
288 dbmax 3450
289 dbvalue.0 -1200
290 dbvalue.1 -1200
291 }
292 }
293 control.22 {
294 iface MIXER
295 name 'Input Source'
296 value Line
297 comment {
298 access 'read write'
299 type ENUMERATED
300 count 1
301 item.0 'Rear Mic'
302 item.1 'Front Mic'
303 item.2 Line
304 item.3 CD
305 }
306 }
307 control.23 {
308 iface MIXER
309 name 'Input Source'
310 index 1
311 value 'Rear Mic'
312 comment {
313 access 'read write'
314 type ENUMERATED
315 count 1
316 item.0 'Rear Mic'
317 item.1 'Front Mic'
318 item.2 Line
319 item.3 CD
320 }
321 }
322 control.24 {
323 iface MIXER
324 name 'Input Source'
325 index 2
326 value 'Rear Mic'
327 comment {
328 access 'read write'
329 type ENUMERATED
330 count 1
331 item.0 'Rear Mic'
332 item.1 'Front Mic'
333 item.2 Line
334 item.3 CD
335 }
336 }
337 control.25 {
338 iface MIXER
339 name 'IEC958 Playback Con Mask'
340 value '0fff000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
341 comment {
342 access read
343 type IEC958
344 count 1
345 }
346 }
347 control.26 {
348 iface MIXER
349 name 'IEC958 Playback Pro Mask'
350 value '0f00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
351 comment {
352 access read
353 type IEC958
354 count 1
355 }
356 }
357 control.27 {
358 iface MIXER
359 name 'IEC958 Playback Default'
360 value '0400000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
361 comment {
362 access 'read write'
363 type IEC958
364 count 1
365 }
366 }
367 control.28 {
368 iface MIXER
369 name 'IEC958 Playback Switch'
370 value true
371 comment {
372 access 'read write'
373 type BOOLEAN
374 count 1
375 }
376 }
377 control.29 {
378 iface MIXER
379 name 'IEC958 Default PCM Playback Switch'
380 value true
381 comment {
382 access 'read write'
383 type BOOLEAN
384 count 1
385 }
386 }
387 control.30 {
388 iface MIXER
389 name 'Master Playback Volume'
390 value 24
391 comment {
392 access 'read write'
393 type INTEGER
394 count 1
395 range '0 - 30'
396 dbmin -4500
397 dbmax 0
398 dbvalue.0 -900
399 }
400 }
401 control.31 {
402 iface MIXER
403 name 'Master Playback Switch'
404 value true
405 comment {
406 access 'read write'
407 type BOOLEAN
408 count 1
409 }
410 }
411}
diff --git a/meta-fri2/recipes-bsp/formfactor/formfactor/fri2/machconfig b/meta-fri2/recipes-bsp/formfactor/formfactor/fri2/machconfig
deleted file mode 100644
index ffce0122..00000000
--- a/meta-fri2/recipes-bsp/formfactor/formfactor/fri2/machconfig
+++ /dev/null
@@ -1,3 +0,0 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-fri2/recipes-core/init-ifupdown/files/fri2/interfaces b/meta-fri2/recipes-core/init-ifupdown/files/fri2/interfaces
deleted file mode 100644
index f5bb9468..00000000
--- a/meta-fri2/recipes-core/init-ifupdown/files/fri2/interfaces
+++ /dev/null
@@ -1,9 +0,0 @@
1# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
2
3# The loopback interface
4auto lo
5iface lo inet loopback
6
7# Wired or wireless interfaces
8auto eth0
9iface eth0 inet dhcp
diff --git a/meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config/fri2/xorg.conf b/meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config/fri2/xorg.conf
deleted file mode 100644
index a9211e78..00000000
--- a/meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config/fri2/xorg.conf
+++ /dev/null
@@ -1,60 +0,0 @@
1##
2## X Config options generated from CED
3## x11 conf skeleton
4## DriverVer=
5##
6
7Section "Screen"
8 Identifier "Screen0"
9 Device "IntelEMGD-0"
10 Monitor "Monitor0"
11 SubSection "Display"
12 EndSubSection
13EndSection
14
15# Primary (First/only) display
16Section "Device"
17 Identifier "IntelEMGD-0"
18 Driver "emgd"
19 VendorName "Intel(R) DEG"
20 BoardName "Embedded Graphics"
21 BusID "0:2:0"
22 Screen 0
23 Option "PcfVersion" "1792"
24 Option "ConfigId" "1"
25 Option "ALL/1/name" "e6xx"
26 Option "ALL/1/General/PortOrder" "24000"
27 Option "ALL/1/General/DisplayConfig" "1"
28 Option "ALL/1/General/DisplayDetect" "1"
29 Option "ALL/1/General/TuningWA" "1"
30
31 # Primary display (upper HDMI port, driven by sDVOB)
32 Option "ALL/1/Port/2/General/name" "Primary"
33 Option "ALL/1/Port/2/General/Edid" "1"
34 Option "ALL/1/Port/2/General/EdidAvail" "7"
35 Option "ALL/1/Port/2/General/EdidNotAvail" "5"
36 Option "ALL/1/Port/2/General/Rotation" "0"
37 Option "ALL/1/Port/2/Attr/71" "20300"
38
39 # Secondary display (lower HDMI port, driven by LVDS, 1366x768)
40 Option "ALL/1/Port/4/General/name" "Secondary"
41 Option "ALL/1/Port/4/General/Edid" "0"
42 Option "ALL/1/Port/4/General/Rotation" "0"
43
44 # Panel depth (the default 18 results in a dim display)
45 # Force dither off for 24-bit panels
46 Option "ALL/1/Port/4/Attr/26" "24"
47 Option "ALL/1/Port/4/Attr/45" "0"
48
49 # Backlight intensity and inverter frequency for E6xx CPUs
50 Option "ALL/1/Port/4/Attr/70" "100"
51 Option "ALL/1/Port/4/Attr/71" "20300"
52EndSection
53
54Section "ServerLayout"
55 Identifier "Default Layout"
56 Screen 0 "Screen0" 0 0
57 # InputDevice "Mouse0" "CorePointer"
58 # InputDevice "Keyboard0" "CoreKeyboard"
59 # InputDevice "DevInputMice" "SendCoreEvents"
60EndSection
diff --git a/meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
deleted file mode 100644
index 72d991c7..00000000
--- a/meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend b/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
index 25361e88..375a0c72 100644
--- a/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
+++ b/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
@@ -1,16 +1,9 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3COMPATIBLE_MACHINE_fri2 = "fri2"
4KMACHINE_fri2 = "fri2"
5KBRANCH_fri2 = "standard/preempt-rt/fri2"
6SRCREV_machine_pn-linux-yocto-rt_fri2 ?= "b669af08737562ef86e7cba328966d05222d3e64"
7#SRCREV_meta_pn-linux-yocto-rt_fri2 ?= "XXX"
8
9COMPATIBLE_MACHINE_fri2-noemgd = "fri2-noemgd" 3COMPATIBLE_MACHINE_fri2-noemgd = "fri2-noemgd"
10KMACHINE_fri2-noemgd = "fri2" 4KMACHINE_fri2-noemgd = "fri2"
11KBRANCH_fri2-noemgd = "standard/preempt-rt/fri2" 5KBRANCH_fri2-noemgd = "standard/preempt-rt/fri2"
12SRCREV_machine_pn-linux-yocto-rt_fri2-noemgd ?= "b669af08737562ef86e7cba328966d05222d3e64" 6SRCREV_machine_pn-linux-yocto-rt_fri2-noemgd ?= "b669af08737562ef86e7cba328966d05222d3e64"
13#SRCREV_meta_pn-linux-yocto-rt_fri2-noemgd ?= "XXX" 7#SRCREV_meta_pn-linux-yocto-rt_fri2-noemgd ?= "XXX"
14 8
15KERNEL_MODULE_AUTOLOAD_append_fri2 = " iwlwifi"
16KERNEL_MODULE_AUTOLOAD_append_fri2-noemgd = " iwlwifi" 9KERNEL_MODULE_AUTOLOAD_append_fri2-noemgd = " iwlwifi"
diff --git a/meta-fri2/recipes-kernel/linux/linux-yocto-tiny_3.10.bbappend b/meta-fri2/recipes-kernel/linux/linux-yocto-tiny_3.10.bbappend
index b4d2dfd6..3514fc6f 100644
--- a/meta-fri2/recipes-kernel/linux/linux-yocto-tiny_3.10.bbappend
+++ b/meta-fri2/recipes-kernel/linux/linux-yocto-tiny_3.10.bbappend
@@ -1,13 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3
4COMPATIBLE_MACHINE_fri2 = "fri2"
5KMACHINE_fri2 = "fri2"
6KBRANCH_fri2 = "standard/tiny/base"
7#SRCREV_machine_pn-linux-yocto-tiny_fri2 ?= "XXX"
8#SRCREV_meta_pn-linux-yocto-tiny_fri2 ?= "XXX"
9
10
11COMPATIBLE_MACHINE_fri2-noemgd = "fri2-noemgd" 3COMPATIBLE_MACHINE_fri2-noemgd = "fri2-noemgd"
12KMACHINE_fri2-noemgd = "fri2" 4KMACHINE_fri2-noemgd = "fri2"
13KBRANCH_fri2-noemgd = "standard/tiny/base" 5KBRANCH_fri2-noemgd = "standard/tiny/base"
diff --git a/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend
index bfbb7540..1fdeb219 100644
--- a/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -1,15 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3COMPATIBLE_MACHINE_fri2 = "fri2"
4KMACHINE_fri2 = "fri2"
5KBRANCH_fri2 = "standard/fri2"
6KERNEL_FEATURES_append_fri2 = " features/drm-emgd/drm-emgd-1.18 cfg/vesafb"
7LINUX_VERSION_fri2 = "3.10.38"
8SRCREV_meta_fri2 = "e1f26aeccfd43bc3d7e95873ceda469b631b8473"
9SRCREV_machine_fri2 = "02f7e63e56c061617957388c23bd5cf9b05c5388"
10SRCREV_emgd_fri2 = "42d5e4548e8e79e094fa8697949eed4cf6af00a3"
11SRC_URI_fri2 = "git://git.yoctoproject.org/linux-yocto-3.10.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.18;name=machine,meta,emgd"
12
13COMPATIBLE_MACHINE_fri2-noemgd = "fri2-noemgd" 3COMPATIBLE_MACHINE_fri2-noemgd = "fri2-noemgd"
14KMACHINE_fri2-noemgd = "fri2" 4KMACHINE_fri2-noemgd = "fri2"
15KBRANCH_fri2-noemgd = "standard/fri2" 5KBRANCH_fri2-noemgd = "standard/fri2"
@@ -18,5 +8,4 @@ LINUX_VERSION_fri2-noemgd = "3.10.38"
18SRCREV_meta_fri2-noemgd = "e1f26aeccfd43bc3d7e95873ceda469b631b8473" 8SRCREV_meta_fri2-noemgd = "e1f26aeccfd43bc3d7e95873ceda469b631b8473"
19SRCREV_machine_fri2-noemgd = "02f7e63e56c061617957388c23bd5cf9b05c5388" 9SRCREV_machine_fri2-noemgd = "02f7e63e56c061617957388c23bd5cf9b05c5388"
20 10
21KERNEL_MODULE_AUTOLOAD_append_fri2 = " iwlwifi"
22KERNEL_MODULE_AUTOLOAD_append_fri2-noemgd = " iwlwifi" 11KERNEL_MODULE_AUTOLOAD_append_fri2-noemgd = " iwlwifi"