summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTeoh Suh Haw <suh.haw.teoh@intel.com>2023-03-28 09:22:32 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-03-28 09:29:21 +0800
commit8a7f46aa916fb41702c4a84081b2a0ca876d2d24 (patch)
treeb74e2b4ba0f26405a8d9503a8d5ea50930dfcccf
parente27e988fe540ae7afdb5922a3e84bf8811b62c83 (diff)
downloadmeta-intel-8a7f46aa916fb41702c4a84081b2a0ca876d2d24.tar.gz
ipmctl : upgrade 03.00.00.0468 -> 03.00.00.0483
Release Notes: ipmctl: https://github.com/intel/ipmctl/releases/tag/v03.00.00.0483 edk2: https://github.com/tianocore/edk2/releases/tag/edk2-stable202302 Adapt patch for edk2 202302 release Signed-off-by: Teoh Suh Haw <suh.haw.teoh@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch38
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0483.bb (renamed from dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0468.bb)8
2 files changed, 24 insertions, 22 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch
index 7fede93c..11305e83 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch
@@ -1,48 +1,50 @@
1 1Subject: [PATCH] [PATCH]: ignore static asserts and null define for os and ut
2 builds
2Upstream-Status: Backport 3Upstream-Status: Backport
3Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 4Signed-off-by: Teoh Suh Haw <suh.haw.teoh@intel.com>
4 5---
5 MdePkg/Include/Base.h | 12 ++++++++++++ 6 MdePkg/Include/Base.h | 12 ++++++++++++
6 1 file changed, 12 insertions(+) 7 1 file changed, 12 insertions(+)
7 8
8diff --git a/MdePkg/Include/Base.h b/MdePkg/Include/Base.h 9diff --git a/MdePkg/Include/Base.h b/MdePkg/Include/Base.h
9index 2da08b0c78..072eefdb94 100644 10index d209e6de28..6e61b8f3d3 100644
10--- a/MdePkg/Include/Base.h 11--- a/MdePkg/Include/Base.h
11+++ b/MdePkg/Include/Base.h 12+++ b/MdePkg/Include/Base.h
12@@ -318,7 +318,11 @@ struct _LIST_ENTRY { 13@@ -316,8 +316,12 @@ struct _LIST_ENTRY {
13 /// 14 #define NULL __null
14 /// NULL pointer (VOID *) 15 #endif
15 /// 16 #else
16+#ifndef OS_BUILD 17+#ifndef OS_BUILD
17+#ifndef UNIT_TEST_UEFI_BUILD 18+#ifndef UNIT_TEST_UEFI_BUILD
18 #define NULL ((VOID *) 0) 19 #define NULL ((VOID *) 0)
20 #endif
19+#endif 21+#endif
20+#endif 22+#endif
21 23
22 // 24 //
23 // Null character 25 // Null character
24@@ -810,6 +814,8 @@ typedef UINTN *BASE_LIST; 26@@ -779,6 +783,8 @@ typedef UINTN *BASE_LIST;
25 // Section 2.3.1 of the UEFI 2.3 Specification. 27 // Section 2.3.1 of the UEFI 2.3 Specification.
26 // 28 //
27 29
28+#ifndef OS_BUILD 30+#ifndef OS_BUILD
29+#ifndef UNIT_TEST_UEFI_BUILD 31+#ifndef UNIT_TEST_UEFI_BUILD
30 STATIC_ASSERT (sizeof (BOOLEAN) == 1, "sizeof (BOOLEAN) does not meet UEFI Specification Data Type requirements"); 32 STATIC_ASSERT (sizeof (BOOLEAN) == 1, "sizeof (BOOLEAN) does not meet UEFI Specification Data Type requirements");
31 STATIC_ASSERT (sizeof (INT8) == 1, "sizeof (INT8) does not meet UEFI Specification Data Type requirements"); 33 STATIC_ASSERT (sizeof (INT8) == 1, "sizeof (INT8) does not meet UEFI Specification Data Type requirements");
32 STATIC_ASSERT (sizeof (UINT8) == 1, "sizeof (UINT8) does not meet UEFI Specification Data Type requirements"); 34 STATIC_ASSERT (sizeof (UINT8) == 1, "sizeof (UINT8) does not meet UEFI Specification Data Type requirements");
33@@ -823,6 +829,8 @@ STATIC_ASSERT (sizeof (CHAR8) == 1, "sizeof (CHAR8) does not meet UEFI Specifi 35@@ -792,6 +798,8 @@ STATIC_ASSERT (sizeof (CHAR8) == 1, "sizeof (CHAR8) does not meet UEFI Specifi
34 STATIC_ASSERT (sizeof (CHAR16) == 2, "sizeof (CHAR16) does not meet UEFI Specification Data Type requirements"); 36 STATIC_ASSERT (sizeof (CHAR16) == 2, "sizeof (CHAR16) does not meet UEFI Specification Data Type requirements");
35 STATIC_ASSERT (sizeof (L'A') == 2, "sizeof (L'A') does not meet UEFI Specification Data Type requirements"); 37 STATIC_ASSERT (sizeof (L'A') == 2, "sizeof (L'A') does not meet UEFI Specification Data Type requirements");
36 STATIC_ASSERT (sizeof (L"A") == 4, "sizeof (L\"A\") does not meet UEFI Specification Data Type requirements"); 38 STATIC_ASSERT (sizeof (L"A") == 4, "sizeof (L\"A\") does not meet UEFI Specification Data Type requirements");
37+#endif 39+#endif
38+#endif 40+#endif
39 41
40 // 42 //
41 // The following three enum types are used to verify that the compiler 43 // The following three enum types are used to verify that the compiler
42@@ -843,9 +851,13 @@ typedef enum { 44@@ -812,9 +820,13 @@ typedef enum {
43 __VerifyUint32EnumValue = 0xffffffff 45 __VerifyUint32EnumValue = 0xffffffff
44 } __VERIFY_UINT32_ENUM_SIZE; 46 } __VERIFY_UINT32_ENUM_SIZE;
45 47
46+#ifndef OS_BUILD 48+#ifndef OS_BUILD
47+#ifndef UNIT_TEST_UEFI_BUILD 49+#ifndef UNIT_TEST_UEFI_BUILD
48 STATIC_ASSERT (sizeof (__VERIFY_UINT8_ENUM_SIZE) == 4, "Size of enum does not meet UEFI Specification Data Type requirements"); 50 STATIC_ASSERT (sizeof (__VERIFY_UINT8_ENUM_SIZE) == 4, "Size of enum does not meet UEFI Specification Data Type requirements");
@@ -50,8 +52,8 @@ index 2da08b0c78..072eefdb94 100644
50 STATIC_ASSERT (sizeof (__VERIFY_UINT32_ENUM_SIZE) == 4, "Size of enum does not meet UEFI Specification Data Type requirements"); 52 STATIC_ASSERT (sizeof (__VERIFY_UINT32_ENUM_SIZE) == 4, "Size of enum does not meet UEFI Specification Data Type requirements");
51+#endif 53+#endif
52+#endif 54+#endif
53 55
54 /** 56 /**
55 Macro that returns a pointer to the data structure that contains a specified field of 57 Macro that returns a pointer to the data structure that contains a specified field of
56-- 58--
572.31.0.windows.1 592.37.3
diff --git a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0468.bb b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0483.bb
index f38a64c3..f2b1b5ed 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0468.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0483.bb
@@ -15,15 +15,15 @@ LICENSE = "BSD-3-Clause | BSD-2-Clause"
15LIC_FILES_CHKSUM = "file://LICENSE;md5=72b9da60da6219d612ce30b746a0fe71 \ 15LIC_FILES_CHKSUM = "file://LICENSE;md5=72b9da60da6219d612ce30b746a0fe71 \
16 file://edk2/License.txt;md5=6123e5bf044a66db96c4ce88a36b2d08" 16 file://edk2/License.txt;md5=6123e5bf044a66db96c4ce88a36b2d08"
17 17
18SRC_URI = "git://github.com/intel/ipmctl.git;protocol=https;branch=development;name=ipmctl; \ 18SRC_URI = "git://github.com/intel/ipmctl.git;protocol=https;branch=master;name=ipmctl; \
19 git://github.com/tianocore/edk2.git;protocol=https;name=edk2;destsuffix=git/edk2;branch=master \ 19 git://github.com/tianocore/edk2.git;protocol=https;name=edk2;destsuffix=git/edk2;branch=master \
20 file://0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch;patchdir=edk2 \ 20 file://0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch;patchdir=edk2 \
21 file://0001-CMakeLists-disable-Werror.patch \ 21 file://0001-CMakeLists-disable-Werror.patch \
22" 22"
23 23
24SRCREV_ipmctl = "cd3bd60f84cb7167fa81257bd33db90fa1f5a70b" 24SRCREV_ipmctl = "eca59dc53741c7f9d0ac5320ef790a1932a9a499"
25#tag edk2-stable202208 25#tag edk2-stable202302
26SRCREV_edk2 = "ba0e0e4c6a174b71b18ccd6e47319cc45878893c" 26SRCREV_edk2 = "f80f052277c88a67c55e107b550f504eeea947d3"
27 27
28S = "${WORKDIR}/git" 28S = "${WORKDIR}/git"
29 29