summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLim Siew Hoon <siew.hoon.lim@intel.com>2022-05-17 16:50:48 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-05-18 09:28:18 +0800
commit81197e3bded450162b880d74539626be50f6a78e (patch)
treeaf74581a79ac7d160fd7807da7a6920831225bfc
parent0346578f871f9a8ca045948e95902df2ca41fdfe (diff)
downloadmeta-intel-81197e3bded450162b880d74539626be50f6a78e.tar.gz
intel-media-driver: upgrade 22.1.1 -> 22.3.1
Drops patches already merged: * 0001-upstream-ADLN.patch * 0002-Add-support-for-ADL-N-Enable-the-cmake-options.patch Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-multimedia/libva/files/0001-upstream-ADLN.patch376
-rw-r--r--recipes-multimedia/libva/files/0002-Add-support-for-ADL-N-Enable-the-cmake-options.patch44
-rw-r--r--recipes-multimedia/libva/intel-media-driver_22.3.1.bb (renamed from recipes-multimedia/libva/intel-media-driver_22.1.1.bb)4
3 files changed, 1 insertions, 423 deletions
diff --git a/recipes-multimedia/libva/files/0001-upstream-ADLN.patch b/recipes-multimedia/libva/files/0001-upstream-ADLN.patch
deleted file mode 100644
index 806b1db6..00000000
--- a/recipes-multimedia/libva/files/0001-upstream-ADLN.patch
+++ /dev/null
@@ -1,376 +0,0 @@
1From 647893d233066b3ca79bccb48de4c26867fb9a88 Mon Sep 17 00:00:00 2001
2From: aidan2020sh <dan.ai@intel.com>
3Date: Fri, 24 Dec 2021 15:11:29 +0800
4Subject: [PATCH 1/2] upstream ADLN
5
6this patch is used to upstream new platform ADLN support
7
8This patch was imported from iHD media-driver git server
9(https://github.com/intel/media-driver/commit/348e98e90d240deecd3040f3846a27e9bb6c3ac1)
10
11Upstream-status: Backport
12Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
13---
14 .../linux/gen12/ddi/media_libva_caps_g12.cpp | 6 +
15 .../linux/gen12/ddi/media_sku_wa_g12.cpp | 47 ++++++++
16 .../linux/gen12/ddi/media_sysinfo_g12.cpp | 32 ++++++
17 .../media_interfaces_g12_adln.cpp | 106 ++++++++++++++++++
18 .../media_interfaces_g12_adln.h | 45 ++++++++
19 .../media_srcs.cmake | 49 ++++++++
20 media_driver/media_interface/media_srcs.cmake | 4 +
21 7 files changed, 289 insertions(+)
22 create mode 100644 media_driver/media_interface/media_interfaces_m12_adln/media_interfaces_g12_adln.cpp
23 create mode 100644 media_driver/media_interface/media_interfaces_m12_adln/media_interfaces_g12_adln.h
24 create mode 100644 media_driver/media_interface/media_interfaces_m12_adln/media_srcs.cmake
25
26diff --git a/media_driver/linux/gen12/ddi/media_libva_caps_g12.cpp b/media_driver/linux/gen12/ddi/media_libva_caps_g12.cpp
27index 1c47cb369..de6273089 100644
28--- a/media_driver/linux/gen12/ddi/media_libva_caps_g12.cpp
29+++ b/media_driver/linux/gen12/ddi/media_libva_caps_g12.cpp
30@@ -2813,3 +2813,9 @@ static bool adlpRegistered = MediaLibvaCapsFactory<MediaLibvaCaps, DDI_MEDIA_CON
31 RegisterCaps<MediaLibvaCapsG12>((uint32_t)IGFX_ALDERLAKE_P);
32 #endif
33
34+#ifdef IGFX_GEN12_ADLN_SUPPORTED
35+static bool adlnRegistered = MediaLibvaCapsFactory<MediaLibvaCaps, DDI_MEDIA_CONTEXT>::
36+ RegisterCaps<MediaLibvaCapsG12>((uint32_t)IGFX_ALDERLAKE_N);
37+#endif
38+
39+
40diff --git a/media_driver/linux/gen12/ddi/media_sku_wa_g12.cpp b/media_driver/linux/gen12/ddi/media_sku_wa_g12.cpp
41index 88e03705e..8155d885d 100644
42--- a/media_driver/linux/gen12/ddi/media_sku_wa_g12.cpp
43+++ b/media_driver/linux/gen12/ddi/media_sku_wa_g12.cpp
44@@ -587,6 +587,53 @@ static bool adlpDeviceRegister = DeviceInfoFactory<LinuxDeviceInit>::
45
46 #endif
47
48+#ifdef IGFX_GEN12_ADLN_SUPPORTED
49+static bool InitAdlnMediaSku(struct GfxDeviceInfo *devInfo,
50+ MediaFeatureTable * skuTable,
51+ struct LinuxDriverInfo * drvInfo)
52+{
53+ if (!InitTglMediaSku(devInfo, skuTable, drvInfo))
54+ {
55+ return false;
56+ }
57+
58+ if (devInfo->eGTType == GTTYPE_GT0_5)
59+ {
60+ MEDIA_WR_SKU(skuTable, FtrGT0_5, 1);
61+ }
62+
63+ MEDIA_WR_SKU(skuTable, FtrAV1VLDLSTDecoding, 1);
64+ MEDIA_WR_SKU(skuTable, FtrGucSubmission, 1);
65+
66+ return true;
67+}
68+
69+static bool InitAdlnMediaWa(struct GfxDeviceInfo *devInfo,
70+ MediaWaTable * waTable,
71+ struct LinuxDriverInfo * drvInfo)
72+{
73+ if (!InitTglMediaWa(devInfo, waTable, drvInfo))
74+ {
75+ return false;
76+ }
77+
78+ //ADL-N keeps below setting same as ADL-S/ADL-P
79+ MEDIA_WR_WA(waTable, Wa_1409820462, 0);
80+
81+ return true;
82+}
83+
84+static struct LinuxDeviceInit adlnDeviceInit =
85+ {
86+ .productFamily = IGFX_ALDERLAKE_N,
87+ .InitMediaFeature = InitAdlnMediaSku,
88+ .InitMediaWa = InitAdlnMediaWa,
89+};
90+
91+static bool adlnDeviceRegister = DeviceInfoFactory<LinuxDeviceInit>::
92+ RegisterDevice(IGFX_ALDERLAKE_N, &adlnDeviceInit);
93+
94+#endif
95
96 static struct LinuxDeviceInit tgllpDeviceInit =
97 {
98diff --git a/media_driver/linux/gen12/ddi/media_sysinfo_g12.cpp b/media_driver/linux/gen12/ddi/media_sysinfo_g12.cpp
99index b3c402191..f68fe6665 100644
100--- a/media_driver/linux/gen12/ddi/media_sysinfo_g12.cpp
101+++ b/media_driver/linux/gen12/ddi/media_sysinfo_g12.cpp
102@@ -460,6 +460,38 @@ static bool adlpGt2Device4626 = DeviceInfoFactory<GfxDeviceInfo>::
103
104 #endif
105
106+#ifdef IGFX_GEN12_ADLN_SUPPORTED
107+static struct GfxDeviceInfo adlnGt1Info = {
108+ .platformType = PLATFORM_MOBILE,
109+ .productFamily = IGFX_ALDERLAKE_N,
110+ .displayFamily = IGFX_GEN12_CORE,
111+ .renderFamily = IGFX_GEN12_CORE,
112+ .eGTType = GTTYPE_GT1,
113+ .L3CacheSizeInKb = 0,
114+ .L3BankCount = 8,
115+ .EUCount = 0,
116+ .SliceCount = 0,
117+ .SubSliceCount = 0,
118+ .MaxEuPerSubSlice = 0,
119+ .isLCIA = 0,
120+ .hasLLC = 0,
121+ .hasERAM = 0,
122+ .InitMediaSysInfo = InitTglMediaSysInfo,
123+ .InitShadowSku = InitTglShadowSku,
124+ .InitShadowWa = InitTglShadowWa,
125+};
126+
127+static bool adlnGt1Device46D0 = DeviceInfoFactory<GfxDeviceInfo>::
128+ RegisterDevice(0x46D0, &adlnGt1Info);
129+
130+static bool adlnGt1Device46D1 = DeviceInfoFactory<GfxDeviceInfo>::
131+ RegisterDevice(0x46D1, &adlnGt1Info);
132+
133+static bool adlnGt1Device46D2 = DeviceInfoFactory<GfxDeviceInfo>::
134+ RegisterDevice(0x46D2, &adlnGt1Info);
135+#endif
136+
137+
138 static bool tgllpGt2Device9a40 = DeviceInfoFactory<GfxDeviceInfo>::
139 RegisterDevice(0x9A40, &tgllpGt2Info);
140
141diff --git a/media_driver/media_interface/media_interfaces_m12_adln/media_interfaces_g12_adln.cpp b/media_driver/media_interface/media_interfaces_m12_adln/media_interfaces_g12_adln.cpp
142new file mode 100644
143index 000000000..089c8a51c
144--- /dev/null
145+++ b/media_driver/media_interface/media_interfaces_m12_adln/media_interfaces_g12_adln.cpp
146@@ -0,0 +1,106 @@
147+/*
148+* Copyright (c) 2011-2022, Intel Corporation
149+*
150+* Permission is hereby granted, free of charge, to any person obtaining a
151+* copy of this software and associated documentation files (the "Software"),
152+* to deal in the Software without restriction, including without limitation
153+* the rights to use, copy, modify, merge, publish, distribute, sublicense,
154+* and/or sell copies of the Software, and to permit persons to whom the
155+* Software is furnished to do so, subject to the following conditions:
156+*
157+* The above copyright notice and this permission notice shall be included
158+* in all copies or substantial portions of the Software.
159+*
160+* THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
161+* OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
162+* FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
163+* THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR
164+* OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
165+* ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
166+* OTHER DEALINGS IN THE SOFTWARE.
167+*/
168+
169+//!
170+//! \file media_interfaces_g12_adln.cpp
171+
172+//! \brief Helps with Gen12 ADL-N factory creation.
173+//!
174+
175+#include "media_interfaces_g12_adln.h"
176+
177+extern template class MediaInterfacesFactory<MhwInterfaces>;
178+extern template class MediaInterfacesFactory<MmdDevice>;
179+extern template class MediaInterfacesFactory<MosUtilDevice>;
180+extern template class MediaInterfacesFactory<CodechalDevice>;
181+extern template class MediaInterfacesFactory<CMHalDevice>;
182+extern template class MediaInterfacesFactory<VphalDevice>;
183+extern template class MediaInterfacesFactory<RenderHalDevice>;
184+extern template class MediaInterfacesFactory<Nv12ToP010Device>;
185+extern template class MediaInterfacesFactory<DecodeHistogramDevice>;
186+
187+static bool adlnRegisteredVphal =
188+MediaInterfacesFactory<VphalDevice>::
189+RegisterHal<VphalInterfacesG12Tgllp>((uint32_t)IGFX_ALDERLAKE_N);
190+
191+static bool adlnRegisteredMhw =
192+ MediaInterfacesFactory<MhwInterfaces>::
193+ RegisterHal<MhwInterfacesG12Tgllp>((uint32_t)IGFX_ALDERLAKE_N);
194+
195+#ifdef _MMC_SUPPORTED
196+static bool adlnRegisteredMmd =
197+ MediaInterfacesFactory<MmdDevice>::
198+ RegisterHal<MmdDeviceG12Tgllp>((uint32_t)IGFX_ALDERLAKE_N);
199+#endif
200+
201+#define PLATFORM_INTEL_ADLN 24
202+#define GENX_TGLLP 12
203+
204+static bool adlnRegisteredNv12ToP010 =
205+ MediaInterfacesFactory<Nv12ToP010Device>::
206+ RegisterHal<Nv12ToP010DeviceG12Tgllp>((uint32_t)IGFX_ALDERLAKE_N);
207+
208+static bool adlnRegisteredCodecHal =
209+ MediaInterfacesFactory<CodechalDevice>::
210+ RegisterHal<CodechalInterfacesG12Tgllp>((uint32_t)IGFX_ALDERLAKE_N);
211+
212+static bool adlnRegisteredCMHal =
213+ MediaInterfacesFactory<CMHalDevice>::
214+ RegisterHal<CMHalInterfacesG12Adln>((uint32_t)IGFX_ALDERLAKE_N);
215+
216+
217+MOS_STATUS CMHalInterfacesG12Adln::Initialize(CM_HAL_STATE *pCmState)
218+{
219+ if (pCmState == nullptr)
220+ {
221+ MHW_ASSERTMESSAGE("pCmState is nullptr.")
222+ return MOS_STATUS_INVALID_PARAMETER;
223+ }
224+
225+ m_cmhalDevice = MOS_New(CMHal, pCmState);
226+ if (m_cmhalDevice == nullptr)
227+ {
228+ MHW_ASSERTMESSAGE("Create CM Hal interfaces failed.")
229+ return MOS_STATUS_NO_SPACE;
230+ }
231+
232+ m_cmhalDevice->SetGenPlatformInfo(PLATFORM_INTEL_ADLN, PLATFORM_INTEL_GT1, "TGLLP");
233+ uint32_t cisaIDs[] = { GENX_TGLLP };
234+ m_cmhalDevice->AddSupportedCisaIDs(cisaIDs, sizeof(cisaIDs)/sizeof(uint32_t));
235+ m_cmhalDevice->m_l3Plane = TGL_L3_PLANE;
236+ m_cmhalDevice->m_l3ConfigCount = TGL_L3_CONFIG_NUM;
237+ return MOS_STATUS_SUCCESS;
238+}
239+
240+static bool adlnRegisteredMosUtil =
241+ MediaInterfacesFactory<MosUtilDevice>::
242+ RegisterHal<MosUtilDeviceG12Tgllp>((uint32_t)IGFX_ALDERLAKE_N);
243+
244+
245+static bool adlnRegisteredRenderHal =
246+ MediaInterfacesFactory<RenderHalDevice>::
247+ RegisterHal<RenderHalInterfacesG12Tgllp>((uint32_t)IGFX_ALDERLAKE_N);
248+
249+static bool adlnRegisteredDecodeHistogram =
250+ MediaInterfacesFactory<DecodeHistogramDevice>::
251+ RegisterHal<DecodeHistogramDeviceG12Tgllp>((uint32_t)IGFX_ALDERLAKE_N);
252+
253diff --git a/media_driver/media_interface/media_interfaces_m12_adln/media_interfaces_g12_adln.h b/media_driver/media_interface/media_interfaces_m12_adln/media_interfaces_g12_adln.h
254new file mode 100644
255index 000000000..a1f9c0d40
256--- /dev/null
257+++ b/media_driver/media_interface/media_interfaces_m12_adln/media_interfaces_g12_adln.h
258@@ -0,0 +1,45 @@
259+/*
260+* Copyright (c) 2011-2022, Intel Corporation
261+*
262+* Permission is hereby granted, free of charge, to any person obtaining a
263+* copy of this software and associated documentation files (the "Software"),
264+* to deal in the Software without restriction, including without limitation
265+* the rights to use, copy, modify, merge, publish, distribute, sublicense,
266+* and/or sell copies of the Software, and to permit persons to whom the
267+* Software is furnished to do so, subject to the following conditions:
268+*
269+* The above copyright notice and this permission notice shall be included
270+* in all copies or substantial portions of the Software.
271+*
272+* THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
273+* OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
274+* FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
275+* THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR
276+* OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
277+* ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
278+* OTHER DEALINGS IN THE SOFTWARE.
279+*/
280+
281+//!
282+//! \file media_interfaces_gen12_adln.h
283+//! \brief All interfaces used for Gen12 ADL-N that require factory creation
284+//!
285+
286+#ifndef __MEDIA_INTERFACES_G12_adln_H__
287+#define __MEDIA_INTERFACES_G12_adln_H__
288+
289+
290+#include "media_interfaces_g12_tgllp.h"
291+#include "renderhal_g12_base.h"
292+
293+
294+class CMHalInterfacesG12Adln : public CMHalDevice
295+{
296+protected:
297+ using CMHal = CM_HAL_G12_X;
298+ MOS_STATUS Initialize(
299+ CM_HAL_STATE *pCmState);
300+};
301+
302+#endif // __MEDIA_INTERFACES_G12_adln_H__
303+
304diff --git a/media_driver/media_interface/media_interfaces_m12_adln/media_srcs.cmake b/media_driver/media_interface/media_interfaces_m12_adln/media_srcs.cmake
305new file mode 100644
306index 000000000..834c2298a
307--- /dev/null
308+++ b/media_driver/media_interface/media_interfaces_m12_adln/media_srcs.cmake
309@@ -0,0 +1,49 @@
310+# Copyright (c) 2022, Intel Corporation
311+#
312+# Permission is hereby granted, free of charge, to any person obtaining a
313+# copy of this software and associated documentation files (the "Software"),
314+# to deal in the Software without restriction, including without limitation
315+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
316+# and/or sell copies of the Software, and to permit persons to whom the
317+# Software is furnished to do so, subject to the following conditions:
318+#
319+# The above copyright notice and this permission notice shall be included
320+# in all copies or substantial portions of the Software.
321+#
322+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
323+# OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
324+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
325+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR
326+# OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
327+# ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
328+# OTHER DEALINGS IN THE SOFTWARE.
329+
330+set(TMP_SOURCES_
331+ ${CMAKE_CURRENT_LIST_DIR}/media_interfaces_g12_adln.cpp
332+)
333+
334+set(TMP_HEADERS_
335+ ${CMAKE_CURRENT_LIST_DIR}/media_interfaces_g12_adln.h
336+)
337+
338+set(SOURCES_
339+ ${SOURCES_}
340+ ${TMP_SOURCES_}
341+)
342+
343+set(HEADERS_
344+ ${HEADERS_}
345+ ${TMP_HEADERS_}
346+)
347+
348+set(COMMON_SOURCES_
349+ ${COMMON_SOURCES_}
350+ ${TMP_SOURCES_}
351+)
352+
353+set(COMMON_HEADERS_
354+ ${COMMON_HEADERS_}
355+ ${TMP_HEADERS_}
356+)
357+
358+media_add_curr_to_include_path()
359diff --git a/media_driver/media_interface/media_srcs.cmake b/media_driver/media_interface/media_srcs.cmake
360index e4cb114d8..dfa7aa3f1 100644
361--- a/media_driver/media_interface/media_srcs.cmake
362+++ b/media_driver/media_interface/media_srcs.cmake
363@@ -75,6 +75,10 @@ if(GEN12_ADLP)
364 media_include_subdirectory(media_interfaces_m12_adlp)
365 endif()
366
367+if(GEN12_ADLN)
368+ media_include_subdirectory(media_interfaces_m12_adln)
369+endif()
370+
371 if(XEHP_SDV)
372 media_include_subdirectory(media_interfaces_xehp_sdv)
373 endif()
374--
3752.34.1
376
diff --git a/recipes-multimedia/libva/files/0002-Add-support-for-ADL-N-Enable-the-cmake-options.patch b/recipes-multimedia/libva/files/0002-Add-support-for-ADL-N-Enable-the-cmake-options.patch
deleted file mode 100644
index 16cbf6f5..00000000
--- a/recipes-multimedia/libva/files/0002-Add-support-for-ADL-N-Enable-the-cmake-options.patch
+++ /dev/null
@@ -1,44 +0,0 @@
1From a31f63721adbc39a96d75ba170669afd2e53c948 Mon Sep 17 00:00:00 2001
2From: Sudarshan S <sudarshan.s@intel.com>
3Date: Wed, 19 Jan 2022 16:06:10 +0530
4Subject: [PATCH 2/2] Add support for ADL-N: Enable the cmake options
5
6This patch was imported from iHD media-driver git server
7(https://github.com/intel/media-driver.git) as of pull request
8https://github.com/intel/media-driver/pull/1327
9
10Upstream status: submitted
11Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
12---
13 media_driver/cmake/linux/media_gen_flags_linux.cmake | 8 ++++++++
14 1 file changed, 8 insertions(+)
15
16diff --git a/media_driver/cmake/linux/media_gen_flags_linux.cmake b/media_driver/cmake/linux/media_gen_flags_linux.cmake
17index 936b09309..b8f256288 100644
18--- a/media_driver/cmake/linux/media_gen_flags_linux.cmake
19+++ b/media_driver/cmake/linux/media_gen_flags_linux.cmake
20@@ -81,6 +81,10 @@ cmake_dependent_option(GEN12_ADLP
21 "Enabled ADLP support (Gen12)" ON
22 "GEN12_TGLLP" OFF)
23
24+cmake_dependent_option(GEN12_ADLN
25+ "Enabled ADLN support (Gen12)" ON
26+ "GEN12_TGLLP" OFF)
27+
28 cmake_dependent_option(Xe_M
29 "Enabled support for Xehp_sdv+ platforms" ON
30 "ENABLE_PRODUCTION_KMD" OFF)
31@@ -184,6 +188,10 @@ if(GEN12_ADLP)
32 add_definitions(-DIGFX_GEN12_ADLP_SUPPORTED)
33 endif()
34
35+if(GEN12_ADLN)
36+ add_definitions(-DIGFX_GEN12_ADLN_SUPPORTED)
37+endif()
38+
39 if(DG2)
40 add_definitions(-DIGFX_DG2_SUPPORTED)
41 add_definitions(-DIGFX_DG2_CMFCPATCH_SUPPORTED)
42--
432.34.1
44
diff --git a/recipes-multimedia/libva/intel-media-driver_22.1.1.bb b/recipes-multimedia/libva/intel-media-driver_22.3.1.bb
index 3613bb1b..4e64c1b6 100644
--- a/recipes-multimedia/libva/intel-media-driver_22.1.1.bb
+++ b/recipes-multimedia/libva/intel-media-driver_22.3.1.bb
@@ -19,12 +19,10 @@ REQUIRED_DISTRO_FEATURES = "opengl"
19DEPENDS += "libva gmmlib" 19DEPENDS += "libva gmmlib"
20 20
21SRC_URI = "git://github.com/intel/media-driver.git;protocol=https;nobranch=1 \ 21SRC_URI = "git://github.com/intel/media-driver.git;protocol=https;nobranch=1 \
22 file://0001-upstream-ADLN.patch \
23 file://0002-Add-support-for-ADL-N-Enable-the-cmake-options.patch \
24 file://c8457540aed1ab9424661087276fb788c0e3aabb.patch \ 22 file://c8457540aed1ab9424661087276fb788c0e3aabb.patch \
25 " 23 "
26 24
27SRCREV = "31c1b995f49ef118a4b02f0b8e45bccdacf0d15e" 25SRCREV = "6547f46584633a7619440b39b34908e13c8c857d"
28S = "${WORKDIR}/git" 26S = "${WORKDIR}/git"
29 27
30COMPATIBLE_HOST:x86-x32 = "null" 28COMPATIBLE_HOST:x86-x32 = "null"