summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiweiSong <liwei.song@windriver.com>2020-06-02 18:45:49 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-06-03 15:47:47 +0800
commit7497da8042641548cec0c56d191fd2d8fc4c8202 (patch)
treeb94ad53ce19edd89bc98950e9d6834c0bce3a114
parente4bbd6967dc9960c95ab7f47ce28e097a7bb618c (diff)
downloadmeta-intel-7497da8042641548cec0c56d191fd2d8fc4c8202.tar.gz
dldt-inference-engine: fix int64_t does not name a type compile error
fix compile error: inference-engine/src/mkldnn_plugin/mkldnn_memory_solver.hpp:60:9: error: 'int64_t' does not name a type | 60 | int64_t size; | | ^~~~~~~ include stdint.h to fix it. Signed-off-by: Liwei Song <liwei.song@windriver.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb1
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-mkldnn_memory_solver.hpp-include-stdint.h-to-avoid-b.patch37
2 files changed, 38 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb
index 42d223c9..ea13f392 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb
@@ -9,6 +9,7 @@ SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2020 \
9 https://download.01.org/opencv/2020/openvinotoolkit/2020.1/inference_engine/firmware_pcie-ma248x_942_R10.15.zip;name=ma248x \ 9 https://download.01.org/opencv/2020/openvinotoolkit/2020.1/inference_engine/firmware_pcie-ma248x_942_R10.15.zip;name=ma248x \
10 https://download.01.org/opencv/2020/openvinotoolkit/2020.1/inference_engine/firmware_usb-ma2x8x_942_R10.15.zip;name=ma2x8x \ 10 https://download.01.org/opencv/2020/openvinotoolkit/2020.1/inference_engine/firmware_usb-ma2x8x_942_R10.15.zip;name=ma2x8x \
11 file://0001-Installation-and-build-fixes.patch \ 11 file://0001-Installation-and-build-fixes.patch \
12 file://0001-mkldnn_memory_solver.hpp-include-stdint.h-to-avoid-b.patch \
12 file://run-ptest \ 13 file://run-ptest \
13 " 14 "
14 15
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-mkldnn_memory_solver.hpp-include-stdint.h-to-avoid-b.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-mkldnn_memory_solver.hpp-include-stdint.h-to-avoid-b.patch
new file mode 100644
index 00000000..057eff23
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-mkldnn_memory_solver.hpp-include-stdint.h-to-avoid-b.patch
@@ -0,0 +1,37 @@
1From 91d72cc97138e5349e36bba9329ae29dee814388 Mon Sep 17 00:00:00 2001
2From: Liwei Song <liwei.song@windriver.com>
3Date: Tue, 2 Jun 2020 09:55:49 +0000
4Subject: [PATCH] mkldnn_memory_solver.hpp: include stdint.h to avoid build
5 error
6
7fix the following compile error:
8
9inference-engine/src/mkldnn_plugin/mkldnn_memory_solver.hpp:60:9: error: 'int64_t' does not name a type
10| 60 | int64_t size;
11| | ^~~~~~~
12
13include stdint.h to fix this.
14
15Upstream-Status: Submitted [https://github.com/openvinotoolkit/openvino/pull/729]
16
17Signed-off-by: Liwei Song <liwei.song@windriver.com>
18---
19 inference-engine/src/mkldnn_plugin/mkldnn_memory_solver.hpp | 2 ++
20 1 file changed, 2 insertions(+)
21
22diff --git a/inference-engine/src/mkldnn_plugin/mkldnn_memory_solver.hpp b/inference-engine/src/mkldnn_plugin/mkldnn_memory_solver.hpp
23index 2c236a307276..aa52d29b310d 100644
24--- a/inference-engine/src/mkldnn_plugin/mkldnn_memory_solver.hpp
25+++ b/inference-engine/src/mkldnn_plugin/mkldnn_memory_solver.hpp
26@@ -10,6 +10,8 @@
27
28 #include "ie_api.h"
29
30+#include <stdint.h>
31+
32 #include <vector>
33 #include <map>
34
35--
362.24.1
37