summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2018-04-06 11:31:30 -0700
committerCalifornia Sullivan <california.l.sullivan@intel.com>2018-04-09 13:35:12 -0700
commit723c7b8624d6e37a1e2da50eccd75159476c9414 (patch)
tree7858dce364e53e3706443b52f742d708cc992b7b
parent006d2f0c9fcda8f7b25e558256715bec6fef65d4 (diff)
downloadmeta-intel-723c7b8624d6e37a1e2da50eccd75159476c9414.tar.gz
ixgbe: update to v5.3.6
Also remove the python snippet limiting it to pre-4.14 kernels, as the new version is compatible. Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
-rw-r--r--recipes-kernel/intel-ethernet/ixgbe.bb15
1 files changed, 3 insertions, 12 deletions
diff --git a/recipes-kernel/intel-ethernet/ixgbe.bb b/recipes-kernel/intel-ethernet/ixgbe.bb
index caa6f42a..e23d57a3 100644
--- a/recipes-kernel/intel-ethernet/ixgbe.bb
+++ b/recipes-kernel/intel-ethernet/ixgbe.bb
@@ -6,7 +6,7 @@ SECTION = "kernel/network"
6LICENSE = "GPLv2" 6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 7LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8 8
9PV = "5.1.3" 9PV = "5.3.6"
10PR = "r0" 10PR = "r0"
11 11
12SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbe%20stable/${PV}/ixgbe-${PV}.tar.gz \ 12SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbe%20stable/${PV}/ixgbe-${PV}.tar.gz \
@@ -14,8 +14,8 @@ SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbe%20stable/${PV}/ixg
14 file://0001-ixgbe-skip-host-depmod.patch \ 14 file://0001-ixgbe-skip-host-depmod.patch \
15 " 15 "
16 16
17SRC_URI[md5sum] = "ae35ed547aa6a5087672c3f70ce1e676" 17SRC_URI[md5sum] = "d6816f2b6b8bddfa2d78267f84770d91"
18SRC_URI[sha256sum] = "9f537d79bddf0a087a17af632d57812d26d26bcfebbd4bdcf10df656ff055bb4" 18SRC_URI[sha256sum] = "6ba26de1bb9b55b92f5f54c6c7b25f837323ec3322a6ee54e882c8e54e6d0eaa"
19 19
20S = "${WORKDIR}/${PN}-${PV}/src" 20S = "${WORKDIR}/${PN}-${PV}/src"
21SCRIPT_DIR = "${WORKDIR}/${PN}-${PV}/scripts" 21SCRIPT_DIR = "${WORKDIR}/${PN}-${PV}/scripts"
@@ -43,12 +43,3 @@ FILES_${PN}-script += "/etc/network/set_irq_affinity"
43 43
44#Ignore "ERROR: QA Issue: ixgbe: Files/directories were installed but not shipped" 44#Ignore "ERROR: QA Issue: ixgbe: Files/directories were installed but not shipped"
45INSANE_SKIP_${PN} = "installed-vs-shipped" 45INSANE_SKIP_${PN} = "installed-vs-shipped"
46
47# Support for 4.14 not yet available
48python () {
49 if d.getVar("PREFERRED_PROVIDER_virtual/kernel") == "linux-intel" and \
50 d.getVar("PREFERRED_VERSION_linux-intel") == "4.14%" or \
51 d.getVar("PREFERRED_PROVIDER_virtual/kernel") == "linux-intel-rt" and \
52 d.getVar("PREFERRED_VERSION_linux-intel-rt") == "4.14%":
53 raise bb.parse.SkipPackage("out of tree ixgbe not yet available for Linux Kernel 4.14 or newer")
54}