summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Nita <george.nita@enea.com>2015-04-16 05:12:28 +0200
committerGeorge Nita <george.nita@enea.com>2015-04-16 05:12:28 +0200
commit6b4f86ab03d90bf8ed5cc19ed9cf3ee81c1b8431 (patch)
tree2593e3c33194acd377637ccf451a466944ce402b
parentf45464d4db852dad79963ae15a0c1a19140bae30 (diff)
parent4739f47e9358ec8cb82a72f3e185003c5ce40b2c (diff)
downloadmeta-intel-6b4f86ab03d90bf8ed5cc19ed9cf3ee81c1b8431.tar.gz
Merge remote-tracking branch 'origin/master' into master-enea
-rw-r--r--common/recipes-bsp/amt/lms7_7.1.20.bb16
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_3.14.bbappend12
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.14.bbappend12
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.19.bbappend12
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto_3.14.bbappend6
5 files changed, 33 insertions, 25 deletions
diff --git a/common/recipes-bsp/amt/lms7_7.1.20.bb b/common/recipes-bsp/amt/lms7_7.1.20.bb
index acc08c1e..1e8376e5 100644
--- a/common/recipes-bsp/amt/lms7_7.1.20.bb
+++ b/common/recipes-bsp/amt/lms7_7.1.20.bb
@@ -12,6 +12,8 @@ SRC_URI = "http://software.intel.com/sites/default/files/m/4/e/a/9/b/37962-${BPN
12 file://atnetworktool-printf-fix.patch \ 12 file://atnetworktool-printf-fix.patch \
13 file://readlink-declaration.patch" 13 file://readlink-declaration.patch"
14 14
15LOCALSRC = "file://${WORKDIR}/outputdir/${BPN}-${PV}-${PV_SUB}.tar.gz"
16
15COMPATIBLE_HOST = '(i.86|x86_64).*-linux' 17COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
16 18
17LIC_FILES_CHKSUM = "file://COPYING;md5=7264184cf88d9f27b719a9656255b47b" 19LIC_FILES_CHKSUM = "file://COPYING;md5=7264184cf88d9f27b719a9656255b47b"
@@ -24,12 +26,18 @@ inherit autotools update-rc.d
24INITSCRIPT_NAME = "lms7" 26INITSCRIPT_NAME = "lms7"
25INITSCRIPT_PARAMS = "defaults" 27INITSCRIPT_PARAMS = "defaults"
26 28
27do_unpack2() { 29python do_unpack() {
28 cd ${WORKDIR} 30 s = d.getVar('S', True)
29 tar -xvzf ${WORKDIR}/outputdir/${BPN}-${PV}-${PV_SUB}.tar.gz 31 d.setVar('S', '${WORKDIR}/outputdir')
32 bb.build.exec_func('base_do_unpack', d)
33 # temorarily change SRC_URI for unpack
34 src_uri = d.getVar('SRC_URI')
35 d.setVar('SRC_URI', '${LOCALSRC}')
36 d.setVar('S', s)
37 bb.build.exec_func('base_do_unpack', d)
38 d.setVar('SRC_URI', src_uri)
30} 39}
31 40
32addtask unpack2 after do_unpack before do_patch
33 41
34do_install_append () { 42do_install_append () {
35 mv ${D}/${sbindir}/lms ${D}/${sbindir}/lms7 43 mv ${D}/${sbindir}/lms ${D}/${sbindir}/lms7
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_3.14.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_3.14.bbappend
index a5edfff9..a0b43150 100644
--- a/common/recipes-kernel/linux/linux-yocto-rt_3.14.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-rt_3.14.bbappend
@@ -1,17 +1,17 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3LINUX_VERSION_core2-32-intel-common = "3.14.4" 3LINUX_VERSION_core2-32-intel-common = "3.14.36"
4COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 4COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
5SRCREV_meta_core2-32-intel-common = "fb6271a942b57bdc40c6e49f0203be153699f81c" 5SRCREV_meta_core2-32-intel-common = "162dfe3bb092c1a792e5ed224fe09672e9814b24"
6SRCREV_machine_core2-32-intel-common = "08229402523bdb153dceed0a7260180837396e7f" 6SRCREV_machine_core2-32-intel-common = "3fb54cf8f4c3254f628e6c4720fe3c731a9de0b2"
7KMACHINE_core2-32-intel-common = "intel-core2-32" 7KMACHINE_core2-32-intel-common = "intel-core2-32"
8KBRANCH_core2-32-intel-common = "standard/preempt-rt/base" 8KBRANCH_core2-32-intel-common = "standard/preempt-rt/base"
9KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 9KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10 10
11LINUX_VERSION_corei7-64-intel-common = "3.14.4" 11LINUX_VERSION_corei7-64-intel-common = "3.14.36"
12COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 12COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
13SRCREV_meta_corei7-64-intel-common = "fb6271a942b57bdc40c6e49f0203be153699f81c" 13SRCREV_meta_corei7-64-intel-common = "162dfe3bb092c1a792e5ed224fe09672e9814b24"
14SRCREV_machine_corei7-64-intel-common = "08229402523bdb153dceed0a7260180837396e7f" 14SRCREV_machine_corei7-64-intel-common = "3fb54cf8f4c3254f628e6c4720fe3c731a9de0b2"
15KMACHINE_corei7-64-intel-common = "intel-corei7-64" 15KMACHINE_corei7-64-intel-common = "intel-corei7-64"
16KBRANCH_corei7-64-intel-common = "standard/preempt-rt/base" 16KBRANCH_corei7-64-intel-common = "standard/preempt-rt/base"
17KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 17KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
diff --git a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
index 3177b7e6..dd05b1f0 100644
--- a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
@@ -3,18 +3,18 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3# For NUC 3# For NUC
4KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc" 4KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
5 5
6LINUX_VERSION_core2-32-intel-common = "3.14.19" 6LINUX_VERSION_core2-32-intel-common = "3.14.36"
7COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 7COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
8SRCREV_meta_core2-32-intel-common = "28e39741b8b3018334021d981369d3fd61f18f5b" 8SRCREV_meta_core2-32-intel-common = "162dfe3bb092c1a792e5ed224fe09672e9814b24"
9SRCREV_machine_core2-32-intel-common = "902f34d36102a4b2008b776ecae686f80d307e12" 9SRCREV_machine_core2-32-intel-common = "4434aa71ff7043c570f9eae493df1ccadbda9b85"
10KMACHINE_core2-32-intel-common = "intel-core2-32" 10KMACHINE_core2-32-intel-common = "intel-core2-32"
11KBRANCH_core2-32-intel-common = "standard/base" 11KBRANCH_core2-32-intel-common = "standard/base"
12KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 12KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
13 13
14LINUX_VERSION_corei7-64-intel-common = "3.14.19" 14LINUX_VERSION_corei7-64-intel-common = "3.14.36"
15COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 15COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
16SRCREV_meta_corei7-64-intel-common = "28e39741b8b3018334021d981369d3fd61f18f5b" 16SRCREV_meta_corei7-64-intel-common = "162dfe3bb092c1a792e5ed224fe09672e9814b24"
17SRCREV_machine_corei7-64-intel-common = "902f34d36102a4b2008b776ecae686f80d307e12" 17SRCREV_machine_corei7-64-intel-common = "4434aa71ff7043c570f9eae493df1ccadbda9b85"
18KMACHINE_corei7-64-intel-common = "intel-corei7-64" 18KMACHINE_corei7-64-intel-common = "intel-corei7-64"
19KBRANCH_corei7-64-intel-common = "standard/base" 19KBRANCH_corei7-64-intel-common = "standard/base"
20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
diff --git a/common/recipes-kernel/linux/linux-yocto_3.19.bbappend b/common/recipes-kernel/linux/linux-yocto_3.19.bbappend
index 1ebadf33..da91a782 100644
--- a/common/recipes-kernel/linux/linux-yocto_3.19.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_3.19.bbappend
@@ -3,18 +3,18 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3# For NUC 3# For NUC
4KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc" 4KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
5 5
6LINUX_VERSION_core2-32-intel-common = "3.19.0" 6LINUX_VERSION_core2-32-intel-common = "3.19.2"
7COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 7COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
8SRCREV_meta_core2-32-intel-common = "8897ef68b30e7426bc1d39895e71fb155d694974" 8SRCREV_meta_core2-32-intel-common = "e308b2c52519c4ec60fe51f020e711cc12b799ae"
9SRCREV_machine_core2-32-intel-common = "43b9eced9ba8a57add36af07736344dcc383f711" 9SRCREV_machine_core2-32-intel-common = "31b35da6a5c8a2b162f6c33202e9b64dd13757d5"
10KMACHINE_core2-32-intel-common = "intel-core2-32" 10KMACHINE_core2-32-intel-common = "intel-core2-32"
11KBRANCH_core2-32-intel-common = "standard/base" 11KBRANCH_core2-32-intel-common = "standard/base"
12KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 12KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
13 13
14LINUX_VERSION_corei7-64-intel-common = "3.19.0" 14LINUX_VERSION_corei7-64-intel-common = "3.19.2"
15COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 15COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
16SRCREV_meta_corei7-64-intel-common = "8897ef68b30e7426bc1d39895e71fb155d694974" 16SRCREV_meta_corei7-64-intel-common = "e308b2c52519c4ec60fe51f020e711cc12b799ae"
17SRCREV_machine_corei7-64-intel-common = "43b9eced9ba8a57add36af07736344dcc383f711" 17SRCREV_machine_corei7-64-intel-common = "31b35da6a5c8a2b162f6c33202e9b64dd13757d5"
18KMACHINE_corei7-64-intel-common = "intel-corei7-64" 18KMACHINE_corei7-64-intel-common = "intel-corei7-64"
19KBRANCH_corei7-64-intel-common = "standard/base" 19KBRANCH_corei7-64-intel-common = "standard/base"
20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.14.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.14.bbappend
index 6906a67b..60bd552c 100644
--- a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.14.bbappend
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.14.bbappend
@@ -5,6 +5,6 @@ KMACHINE_emenlow-noemgd = "emenlow"
5KBRANCH_emenlow-noemgd = "standard/base" 5KBRANCH_emenlow-noemgd = "standard/base"
6KERNEL_FEATURES_append_emenlow-noemgd = " features/drm-gma500/drm-gma500" 6KERNEL_FEATURES_append_emenlow-noemgd = " features/drm-gma500/drm-gma500"
7 7
8LINUX_VERSION_emenlow-noemgd = "3.14.19" 8LINUX_VERSION_emenlow-noemgd = "3.14.36"
9SRCREV_machine_emenlow-noemgd = "902f34d36102a4b2008b776ecae686f80d307e12" 9SRCREV_machine_emenlow-noemgd = "4434aa71ff7043c570f9eae493df1ccadbda9b85"
10SRCREV_meta_emenlow-noemgd = "28e39741b8b3018334021d981369d3fd61f18f5b" 10SRCREV_meta_emenlow-noemgd = "162dfe3bb092c1a792e5ed224fe09672e9814b24"