summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2020-09-03 11:03:53 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-09-03 11:08:23 +0800
commit4ea4dbbb43f06bdf53862790572f702f77bc2adf (patch)
tree71e6e41b807cc284aa570159773d81246d80b69b
parent6299adfca639af223e918198fb39cee234a8acb0 (diff)
downloadmeta-intel-4ea4dbbb43f06bdf53862790572f702f77bc2adf.tar.gz
intel-graphics-compiler: upgrade 1.0.4241 -> 1.0.4756
Release notes: https://github.com/intel/intel-graphics-compiler/releases/tag/igc-1.0.4756 Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/files/link-to-LLVMGenXIntrinsics.patch62
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4241.bb)7
2 files changed, 66 insertions, 3 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/link-to-LLVMGenXIntrinsics.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/link-to-LLVMGenXIntrinsics.patch
new file mode 100644
index 00000000..89a28097
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/link-to-LLVMGenXIntrinsics.patch
@@ -0,0 +1,62 @@
1From 483154871f72590b81c036b000be09627376b5a9 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Thu, 27 Aug 2020 12:17:12 +0800
4Subject: [PATCH] IGC/VectorCompiler/CMakeLists.txt: link to external
5 LLVMGenXIntrinsics
6
7By default LLVMGenXIntrinsics is to be build In-tree, but we want to
8link externally.
9
10Fix llvm-tblgen path.
11
12Upstream-Status: Inappropriate [configuration specific]
13
14Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
15---
16 IGC/VectorCompiler/CMakeLists.txt | 23 ++---------------------
17 1 file changed, 2 insertions(+), 21 deletions(-)
18
19diff --git a/IGC/VectorCompiler/CMakeLists.txt b/IGC/VectorCompiler/CMakeLists.txt
20index 3592e0b4..ae754b8b 100644
21--- a/IGC/VectorCompiler/CMakeLists.txt
22+++ b/IGC/VectorCompiler/CMakeLists.txt
23@@ -50,10 +50,7 @@ if(IGC_BUILD__USING_SYSTEM_LLVM OR (WIN32 AND LLVM_USE_PREBUILT))
24 message(STATUS "[VC] Using system llvm")
25
26 # Need to search for llvm-tblgen
27- find_program(LLVM_TABLEGEN_EXE "llvm-tblgen"
28- ${LLVM_TOOLS_BINARY_DIR}
29- NO_DEFAULT_PATH
30- )
31+ find_program(LLVM_TABLEGEN_EXE "llvm-tblgen")
32 if(LLVM_TABLEGEN_EXE-NOTFOUND)
33 message(FATAL_ERROR "[VC] llvm-tblgen is not found")
34 endif()
35@@ -131,23 +128,7 @@ if(LLVM_ON_WIN32)
36 add_compile_options(/wd4624)
37 endif()
38
39-if(DEFINED VC_INTRINSICS_SRC)
40- set(INTRSRC "${VC_INTRINSICS_SRC}/GenXIntrinsics")
41-endif()
42-
43-if(NOT DEFINED INTRSRC)
44- set(INTRSRC "${CMAKE_CURRENT_SOURCE_DIR}/../../../vc-intrinsics/GenXIntrinsics")
45-endif()
46-
47-message(STATUS "[VC] Using vc-intrinsics source from: ${INTRSRC}")
48-
49-# We are using prebuilt SPIRV and building intrinsics.
50-set(INTRBUILD "${CMAKE_CURRENT_BINARY_DIR}/intrbuild")
51-
52-
53-# Do not copy anything from prebuilts. libSPIRVDLL.so will be dynamically loaded at runtime.
54-add_subdirectory(${INTRSRC} ${INTRBUILD})
55-include_directories(${INTRSRC}/include ${INTRBUILD}/include)
56+find_package(LLVMGenXIntrinsics REQUIRED)
57
58 include(cmake/spirv.cmake)
59 include(${IGC_SOURCE_DIR}/cmake/utils.cmake)
60--
612.17.1
62
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4241.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb
index 762cd6b9..406f9f18 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4241.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb
@@ -10,9 +10,10 @@ LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc
10 10
11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \ 11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \
12 file://0001-skip-execution-of-ElfPackager.patch \ 12 file://0001-skip-execution-of-ElfPackager.patch \
13 file://link-to-LLVMGenXIntrinsics.patch \
13 " 14 "
14 15
15SRCREV = "9a456d81355b266ac60b26c1865935b4a266d6e2" 16SRCREV = "3623209b10b357ddb3a3d6eac3551c53ebc897f7"
16 17
17S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
18 19
@@ -21,12 +22,12 @@ inherit cmake
21COMPATIBLE_HOST = '(x86_64).*-linux' 22COMPATIBLE_HOST = '(x86_64).*-linux'
22COMPATIBLE_HOST_libc-musl = "null" 23COMPATIBLE_HOST_libc-musl = "null"
23 24
24DEPENDS += " flex-native bison-native clang opencl-clang" 25DEPENDS += " flex-native bison-native clang opencl-clang vc-intrinsics"
25DEPENDS_append_class-target = " clang-cross-x86_64" 26DEPENDS_append_class-target = " clang-cross-x86_64"
26 27
27RDEPENDS_${PN} += "opencl-clang" 28RDEPENDS_${PN} += "opencl-clang"
28 29
29EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=10.0.0 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3" 30EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=10.0.0 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 -DINSTALL_SPIRVDLL=0"
30 31
31BBCLASSEXTEND = "native nativesdk" 32BBCLASSEXTEND = "native nativesdk"
32 33