summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Nita <george.nita@enea.com>2014-06-26 14:20:14 +0200
committerGeorge Nita <george.nita@enea.com>2014-06-26 14:27:57 +0200
commit2f9c67ed08fcfc4452ad708e0f6815a2a0b38630 (patch)
treee1c996fe84fe716112153f561acce74d988d792a
parentf2ab696036dd2a0fb8432a10f18bed90dd938cfa (diff)
downloadmeta-intel-2f9c67ed08fcfc4452ad708e0f6815a2a0b38630.tar.gz
Revert "Revert "linux-yocto: Remove redundant recipes""
This reverts commit accc04b57bb68da4542bcecd49d95dcb03efd909 and as so reapplies 09d485dcce6ed4b654abc0c8a630f1d36bc1a7d6. Conflicts: common/recipes-kernel/linux/linux-yocto-dev.bbappend Signed-off-by: George Nita <george.nita@enea.com>
-rw-r--r--common/recipes-kernel/linux/linux-yocto-dev.bbappend8
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.10.bbappend8
-rw-r--r--meta-crystalforest/recipes-kernel/linux/linux-yocto_3.10.bbappend20
-rw-r--r--meta-isg/meta-haswell-wc/recipes-kernel/linux/linux-yocto_3.10.bbappend16
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend10
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend12
-rw-r--r--meta-romley/recipes-kernel/linux/linux-yocto_3.10.bbappend21
-rw-r--r--meta-sugarbay/recipes-kernel/linux/linux-yocto-dev.bbappend15
-rw-r--r--meta-sugarbay/recipes-kernel/linux/linux-yocto_3.10.bbappend13
9 files changed, 14 insertions, 109 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-dev.bbappend b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
index b303b47f..71e40957 100644
--- a/common/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON = "" 3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
4 4
5LINUX_VERSION_core2-32-intel-common = "3.14-rc8" 5LINUX_VERSION_core2-32-intel-common = "3.14-rc8"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
@@ -17,3 +17,9 @@ KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}
17# NOTE: We do not set SRCREVs here as -dev is intended to be built with AUTOREV 17# NOTE: We do not set SRCREVs here as -dev is intended to be built with AUTOREV
18# and setting them here breaks the default mechanism to use AUTOREV if the 18# and setting them here breaks the default mechanism to use AUTOREV if the
19# default SRCREV is set and linux-yocto-dev is the preferred provider. 19# default SRCREV is set and linux-yocto-dev is the preferred provider.
20
21# For Crystalforest and Romley
22KERNEL_MODULE_AUTOLOAD += "uio"
23
24# For FRI2
25KERNEL_MODULE_AUTOLOAD += "iwlwifi"
diff --git a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 1f6cc520..6f7ef2c4 100644
--- a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON = "" 3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
4 4
5LINUX_VERSION_core2-32-intel-common = "3.10.38" 5LINUX_VERSION_core2-32-intel-common = "3.10.38"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
@@ -17,3 +17,9 @@ SRCREV_machine_corei7-64-intel-common = "02f7e63e56c061617957388c23bd5cf9b05c538
17KMACHINE_corei7-64-intel-common = "intel-corei7-64" 17KMACHINE_corei7-64-intel-common = "intel-corei7-64"
18KBRANCH_corei7-64-intel-common = "standard/base" 18KBRANCH_corei7-64-intel-common = "standard/base"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
20
21# For Crystalforest and Romley
22module_autoload_uio = "uio"
23
24# For FRI2
25module_autoload_iwlwifi = "iwlwifi"
diff --git a/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
deleted file mode 100644
index 51551ef4..00000000
--- a/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ /dev/null
@@ -1,20 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4COMPATIBLE_MACHINE_crystalforest-gladden = "crystalforest-gladden"
5KMACHINE_crystalforest-gladden = "crystalforest"
6KBRANCH_crystalforest-gladden = "standard/common-pc-64/crystalforest"
7
8SRCREV_machine_pn-linux-yocto_crystalforest-gladden ?= "c03195ed6e3066494e3fb4be69154a57066e845b"
9SRCREV_meta_pn-linux-yocto_crystalforest-gladden ?= "f1c9080cd27f99700fa59b5375d1ddd0afe625ad"
10
11COMPATIBLE_MACHINE_crystalforest-server = "crystalforest-server"
12KMACHINE_crystalforest-server = "crystalforest"
13KBRANCH_crystalforest-server = "standard/common-pc-64/crystalforest"
14
15SRCREV_machine_pn-linux-yocto_crystalforest-server ?= "a9ec82e355130160f9094e670bd5be0022a84194"
16SRCREV_meta_pn-linux-yocto_crystalforest-server ?= "d9cd83c0292bd4e2a6754a96761027252e726a42"
17
18LINUX_VERSION = "3.10.19"
19
20module_autoload_uio = "uio"
diff --git a/meta-isg/meta-haswell-wc/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-isg/meta-haswell-wc/recipes-kernel/linux/linux-yocto_3.10.bbappend
deleted file mode 100644
index 0a12121c..00000000
--- a/meta-isg/meta-haswell-wc/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ /dev/null
@@ -1,16 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3KMETA = "meta"
4
5COMPATIBLE_MACHINE_haswell-wc = "haswell-wc"
6KMACHINE_haswell-wc = "haswell-wc"
7KBRANCH_haswell-wc = "standard/common-pc-64/base"
8
9KERNEL_FEATURES_haswell-wc += "features/amt/mei"
10
11LINUX_VERSION = "3.10.19"
12
13SRCREV_machine_haswell-wc = "a9ec82e355130160f9094e670bd5be0022a84194"
14SRCREV_meta_haswell-wc = "d9cd83c0292bd4e2a6754a96761027252e726a42"
15
16SRC_URI_haswell-wc = "git://git.yoctoproject.org/linux-yocto-3.10.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA};name=machine,meta"
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend
deleted file mode 100644
index 5d6f92fd..00000000
--- a/meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ /dev/null
@@ -1,10 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4COMPATIBLE_MACHINE_jasperforest = "jasperforest"
5
6KMACHINE_jasperforest = "jasperforest"
7KBRANCH_jasperforest = "standard/common-pc-64/jasperforest"
8
9SRCREV_machine_jasperforest = "60536206ad300ccf5b2be2c2d449f4ab27170238"
10SRCREV_meta_jasperforest = "fe20c99783387dab779472ff50a88666da1c6391"
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
deleted file mode 100644
index 45ab6b96..00000000
--- a/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ /dev/null
@@ -1,12 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4COMPATIBLE_MACHINE_jasperforest = "jasperforest"
5
6KMACHINE_jasperforest = "jasperforest"
7KBRANCH_jasperforest = "standard/common-pc-64/jasperforest"
8
9LINUX_VERSION = "3.10.19"
10
11SRCREV_meta_jasperforest = "d9cd83c0292bd4e2a6754a96761027252e726a42"
12SRCREV_machine_jasperforest = "a9ec82e355130160f9094e670bd5be0022a84194"
diff --git a/meta-romley/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-romley/recipes-kernel/linux/linux-yocto_3.10.bbappend
deleted file mode 100644
index 6fc0682d..00000000
--- a/meta-romley/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ /dev/null
@@ -1,21 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4COMPATIBLE_MACHINE_romley = "romley"
5
6KMACHINE_romley = "romley"
7KBRANCH_romley = "standard/common-pc-64/romley"
8
9SRCREV_machine_pn-linux-yocto_romley ?= "c03195ed6e3066494e3fb4be69154a57066e845b"
10SRCREV_meta_pn-linux-yocto_romley ?= "f1c9080cd27f99700fa59b5375d1ddd0afe625ad"
11
12COMPATIBLE_MACHINE_romley-ivb = "romley-ivb"
13KMACHINE_romley-ivb = "romley"
14KBRANCH_romley-ivb = "standard/common-pc-64/romley"
15
16SRCREV_machine_pn-linux-yocto_romley-ivb ?= "a9ec82e355130160f9094e670bd5be0022a84194"
17SRCREV_meta_pn-linux-yocto_romley-ivb ?= "d9cd83c0292bd4e2a6754a96761027252e726a42"
18
19LINUX_VERSION = "3.10.19"
20
21module_autoload_uio = "uio"
diff --git a/meta-sugarbay/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-sugarbay/recipes-kernel/linux/linux-yocto-dev.bbappend
deleted file mode 100644
index f09fbf60..00000000
--- a/meta-sugarbay/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ /dev/null
@@ -1,15 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4COMPATIBLE_MACHINE_sugarbay = "sugarbay"
5
6KMACHINE_sugarbay = "sugarbay"
7KBRANCH_sugarbay = "standard/common-pc-64/sugarbay"
8
9LINUX_VERSION = "3.12.0"
10
11SRCREV_meta_sugarbay = "75feecae0382601045f508bcce104b3d4af1923d"
12SRCREV_machine_sugarbay = "1f274173a8335dc27daabd9d9fe2e19a8b3978d1"
13
14SRCREV_machine_sugarbay = "60536206ad300ccf5b2be2c2d449f4ab27170238"
15SRCREV_meta_sugarbay = "fe20c99783387dab779472ff50a88666da1c6391"
diff --git a/meta-sugarbay/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-sugarbay/recipes-kernel/linux/linux-yocto_3.10.bbappend
deleted file mode 100644
index 8811fca5..00000000
--- a/meta-sugarbay/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ /dev/null
@@ -1,13 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4COMPATIBLE_MACHINE_sugarbay = "sugarbay"
5
6KMACHINE_sugarbay = "sugarbay"
7KBRANCH_sugarbay = "standard/common-pc-64/sugarbay"
8KERNEL_FEATURES_append_sugarbay = " features/media/media-usb-webcams.scc"
9
10LINUX_VERSION = "3.10.19"
11
12SRCREV_meta_sugarbay = "d9cd83c0292bd4e2a6754a96761027252e726a42"
13SRCREV_machine_sugarbay = "a9ec82e355130160f9094e670bd5be0022a84194"