summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-09-26 07:19:08 -0700
committerSaul Wold <sgw@linux.intel.com>2017-09-26 07:20:34 -0700
commit2f1bcac3fb3b42602f689fb4a1092aa5f4cf0c8a (patch)
treeb493f2ce5b78a56a70e76435658e370d44b2eab8
parent60bec582cefb6f6777fafb86e5ba4606d7e775e9 (diff)
downloadmeta-intel-2f1bcac3fb3b42602f689fb4a1092aa5f4cf0c8a.tar.gz
meta-*/layer.conf: Add LAYERDEPENDS
This adds the missing LAYERDEPENDS as appropriate Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--conf/layer.conf1
-rw-r--r--meta-dpdk/conf/layer.conf2
-rw-r--r--meta-qat/conf/layer.conf2
-rw-r--r--meta-tlk/conf/layer.conf3
4 files changed, 8 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 40f406d4..53f831e0 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -12,6 +12,7 @@ BBFILE_PRIORITY_intel = "5"
12# Additional license directories. 12# Additional license directories.
13LICENSE_PATH += "${LAYERDIR}/common/custom-licenses" 13LICENSE_PATH += "${LAYERDIR}/common/custom-licenses"
14 14
15LAYERDEPENDS_intel = "core"
15LAYERRECOMMENDS_intel = "dpdk intel-qat" 16LAYERRECOMMENDS_intel = "dpdk intel-qat"
16 17
17# This should only be incremented on significant changes that will 18# This should only be incremented on significant changes that will
diff --git a/meta-dpdk/conf/layer.conf b/meta-dpdk/conf/layer.conf
index 5c11debf..61331edc 100644
--- a/meta-dpdk/conf/layer.conf
+++ b/meta-dpdk/conf/layer.conf
@@ -9,6 +9,8 @@ BBFILE_COLLECTIONS += "dpdk"
9BBFILE_PATTERN_dpdk := "^${LAYERDIR}/" 9BBFILE_PATTERN_dpdk := "^${LAYERDIR}/"
10BBFILE_PRIORITY_dpdk = "5" 10BBFILE_PRIORITY_dpdk = "5"
11 11
12LAYERDEPENDS_dpdk = "core"
13
12# This should only be incremented on significant changes that will 14# This should only be incremented on significant changes that will
13# cause compatibility issues with other layers 15# cause compatibility issues with other layers
14LAYERVERSION_dpdk = "1" 16LAYERVERSION_dpdk = "1"
diff --git a/meta-qat/conf/layer.conf b/meta-qat/conf/layer.conf
index 08921659..2e3aa847 100644
--- a/meta-qat/conf/layer.conf
+++ b/meta-qat/conf/layer.conf
@@ -9,6 +9,8 @@ BBFILE_COLLECTIONS += "intel-qat"
9BBFILE_PATTERN_intel-qat := "^${LAYERDIR}/" 9BBFILE_PATTERN_intel-qat := "^${LAYERDIR}/"
10BBFILE_PRIORITY_intel-qat = "5" 10BBFILE_PRIORITY_intel-qat = "5"
11 11
12LAYERDEPENDS_intel-qat = "core intel"
13
12# This should only be incremented on significant changes that will 14# This should only be incremented on significant changes that will
13# cause compatibility issues with other layers 15# cause compatibility issues with other layers
14LAYERVERSION_intel-qat = "1" 16LAYERVERSION_intel-qat = "1"
diff --git a/meta-tlk/conf/layer.conf b/meta-tlk/conf/layer.conf
index fc104052..dea544fd 100644
--- a/meta-tlk/conf/layer.conf
+++ b/meta-tlk/conf/layer.conf
@@ -8,3 +8,6 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
8BBFILE_COLLECTIONS += "tlk" 8BBFILE_COLLECTIONS += "tlk"
9BBFILE_PATTERN_tlk := "^${LAYERDIR}/" 9BBFILE_PATTERN_tlk := "^${LAYERDIR}/"
10BBFILE_PRIORITY_tlk = "5" 10BBFILE_PRIORITY_tlk = "5"
11
12LAYERDEPENDS_tlk = "core intel"
13