summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2024-03-11 03:18:55 -0700
committerAnuj Mittal <anuj.mittal@intel.com>2024-03-11 22:42:52 +0800
commit1a7d12af5a8102029075800f25387d83e929bea1 (patch)
tree78d904c6d19ad46eed291e9f5ce0e15f82a7cf4a
parent353b0a4354ce03a4ebf5332b898709c0980e14ad (diff)
downloadmeta-intel-1a7d12af5a8102029075800f25387d83e929bea1.tar.gz
lms : upgrade 2322.0.0.0 -> 2406.0.0.0
Drop upstreamed patches Release Notes: https://github.com/intel/lms/releases/tag/v2406.0.0.0 Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms/0001-UNS-CMakeLists.txt-migrate-udev-rules-to-usr.patch33
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms/fix-gcc13.patch46
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb (renamed from dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2322.0.0.0.bb)4
3 files changed, 1 insertions, 82 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms/0001-UNS-CMakeLists.txt-migrate-udev-rules-to-usr.patch b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms/0001-UNS-CMakeLists.txt-migrate-udev-rules-to-usr.patch
deleted file mode 100644
index 80b64b37..00000000
--- a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms/0001-UNS-CMakeLists.txt-migrate-udev-rules-to-usr.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 072d20e6dcd99ff272a934fcfda8df9dd15d4359 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Fri, 16 Jun 2023 11:35:42 +0800
4Subject: [PATCH] UNS/CMakeLists.txt: migrate udev rules to /usr
5
6With the upcoming v254 release of systemd mandating usrmerge[1] this
7will become mandatory for anyone using systemd.
8
9[1] https://lists.freedesktop.org/archives/systemd-devel/2023-June/049173.html
10
11Upstream-Status: Submitted [https://github.com/intel/lms/pull/16]
12
13Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
14---
15 UNS/CMakeLists.txt | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/UNS/CMakeLists.txt b/UNS/CMakeLists.txt
19index 09000eb..c6b98c1 100644
20--- a/UNS/CMakeLists.txt
21+++ b/UNS/CMakeLists.txt
22@@ -139,7 +139,7 @@ if (UNIX)
23 install (FILES
24 ${CMAKE_CURRENT_SOURCE_DIR}/linux_scripts/70-persistent-mei.rules
25 ${CMAKE_CURRENT_SOURCE_DIR}/linux_scripts/70-mei-wdt.rules
26- DESTINATION /lib/udev/rules.d/
27+ DESTINATION /usr/lib/udev/rules.d/
28 )
29
30 install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/linux_scripts/20-lms.conf
31--
322.34.1
33
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms/fix-gcc13.patch b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms/fix-gcc13.patch
deleted file mode 100644
index 7e5e3bee..00000000
--- a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms/fix-gcc13.patch
+++ /dev/null
@@ -1,46 +0,0 @@
1Upstream-Status: Pending
2Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
3
4diff --git a/MEIClient/AMTHIClient/Include/AmtAnsiString.h b/MEIClient/AMTHIClient/Include/AmtAnsiString.h
5index 23114c9..deef61b 100644
6--- a/MEIClient/AMTHIClient/Include/AmtAnsiString.h
7+++ b/MEIClient/AMTHIClient/Include/AmtAnsiString.h
8@@ -12,6 +12,7 @@
9
10 #include <string>
11 #include <vector>
12+#include <cstdint>
13
14 namespace Intel
15 {
16diff --git a/MEIClient/Include/MEIparser.h b/MEIClient/Include/MEIparser.h
17index 0d47bb9..d4ffcd8 100644
18--- a/MEIClient/Include/MEIparser.h
19+++ b/MEIClient/Include/MEIparser.h
20@@ -8,6 +8,7 @@
21 #include "MEIClientException.h"
22 #include <cstring>
23 #include <vector>
24+#include <cstdint>
25
26 namespace Intel
27 {
28diff --git a/UNS/GMS_COMMON/FuncEntryExit.h b/UNS/GMS_COMMON/FuncEntryExit.h
29index 21862ab..7165906 100644
30--- a/UNS/GMS_COMMON/FuncEntryExit.h
31+++ b/UNS/GMS_COMMON/FuncEntryExit.h
32@@ -5,6 +5,7 @@
33 #ifndef FUNCENTRYEXIT_H
34 #define FUNCENTRYEXIT_H
35 #include "GMSCommonDllExport.h"
36+#include <cstdint>
37
38 GMS_COMMON_EXPORT void FlowLog(const wchar_t *name, const wchar_t *pref, const wchar_t *func);
39 GMS_COMMON_EXPORT void FuncEntry(const wchar_t *name, const wchar_t *func);
40@@ -48,4 +49,4 @@ private:
41 const wchar_t * name_;
42 const wchar_t * func_;
43 };
44-#endif // FUNCENTRYEXIT_H
45\ No newline at end of file
46+#endif // FUNCENTRYEXIT_H
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2322.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb
index 9c02bb95..63b69ce8 100644
--- a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2322.0.0.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb
@@ -30,10 +30,8 @@ S = "${WORKDIR}/git"
30SYSTEMD_SERVICE:${PN} = "lms.service" 30SYSTEMD_SERVICE:${PN} = "lms.service"
31 31
32SRC_URI = "git://github.com/intel/lms.git;branch=master;protocol=https \ 32SRC_URI = "git://github.com/intel/lms.git;branch=master;protocol=https \
33 file://fix-gcc13.patch \
34 file://0001-UNS-CMakeLists.txt-migrate-udev-rules-to-usr.patch \
35 " 33 "
36SRCREV = "cbc1e1019cf5dc2d03a3b722ee07fbfb9a90f2d1" 34SRCREV = "388f115b2aeb3ea11499971c65f828daefd32c47"
37 35
38do_install:append() { 36do_install:append() {
39 install -d ${D}${sysconfdir}/lms 37 install -d ${D}${sysconfdir}/lms