summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2024-03-18 14:58:33 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2024-03-18 15:16:23 +0800
commit06781f8c81a33766804a9a0c37e4c16bd2ed6232 (patch)
treecfc095cb48df27f58fbb2e1593a7b1060efa31a5
parent9ce6cc89c7a6c6de1b26356c1c14559571cf28a5 (diff)
downloadmeta-intel-06781f8c81a33766804a9a0c37e4c16bd2ed6232.tar.gz
openvino-inference-engine : upgrade 2023.3.0 -> 2024.0.0
- Removed the Cython patch, which is no longer relevant as Legacy IE python API has been removed: https://github.com/openvinotoolkit/openvino/commit/a561a2a484049cc63fd0959646ef5c1cb8f3c2e6 - Remove cython dependency as well from recipe - Remove the switch disabling MLAS support. It's enabled by default. Fetch the submodule as well and include the file pointing to its Apache-2.0 license in LIC_FILES_CHKSUM. - Update conditional check to exclude directories which have "/usr/include" in them to not add <sysroot>/usr/include as well. - Backport a patch which solves the build failure caused by setting the "ENABLE_OV_ONNX_FRONTEND" option to "OFF" Release Notes: https://github.com/openvinotoolkit/openvino/releases/tag/2024.0.0 Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-CPU-Solving-the-build-failure-caused-by-setting-the-.patch43
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-fix-build-when-using-sysroot.patch32
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Change-the-working-directory-to-source-to-workaround.patch29
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2024.0.0.bb (renamed from dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.3.0.bb)21
4 files changed, 87 insertions, 38 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-CPU-Solving-the-build-failure-caused-by-setting-the-.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-CPU-Solving-the-build-failure-caused-by-setting-the-.patch
new file mode 100644
index 00000000..d1851406
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-CPU-Solving-the-build-failure-caused-by-setting-the-.patch
@@ -0,0 +1,43 @@
1From b8c3bae71e6d3417ade5cb537cb1785fd75a75c8 Mon Sep 17 00:00:00 2001
2From: Razvan Apetroaie <117895604+razvanapetroaie@users.noreply.github.com>
3Date: Tue, 20 Feb 2024 02:28:14 +0200
4Subject: [PATCH] [CPU] Solving the build failure caused by setting the
5 "ENABLE_OV_ONNX_FRONTEND" option to "OFF" (#22934)
6
7### Details:
8See the [ticket
9description](https://jira.devtools.intel.com/browse/CVS-132119). The
10solution was checked only on a local setup on Ubuntu, if there's a way
11to check that using the CI please let me know (or if you could run the
12job and paste the link in the comments I would be grateful).
13
14Disclaimer: I'm not a CPU plugin developer, so I can't tell for sure if
15this is the ideal fix and no side effects are introduced. Please take
16that into account when reviewing/merging.
17
18### Tickets:
19 - [CVS-132119](https://jira.devtools.intel.com/browse/CVS-132119)
20
21Upstream-Status: Backport [https://github.com/openvinotoolkit/openvino/commit/b8c3bae71e6d3417ade5cb537cb1785fd75a75c8]
22
23Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
24---
25 src/plugins/intel_cpu/tests/functional/CMakeLists.txt | 2 +-
26 1 file changed, 1 insertion(+), 1 deletion(-)
27
28diff --git a/src/plugins/intel_cpu/tests/functional/CMakeLists.txt b/src/plugins/intel_cpu/tests/functional/CMakeLists.txt
29index db5ae8d01c..6941cb528d 100644
30--- a/src/plugins/intel_cpu/tests/functional/CMakeLists.txt
31+++ b/src/plugins/intel_cpu/tests/functional/CMakeLists.txt
32@@ -16,7 +16,7 @@ set(LINK_LIBRARIES funcSharedTests cpuSpecificRtInfo openvino::snippets ov_snipp
33 if(ENABLE_OV_ONNX_FRONTEND)
34 list(APPEND DEFINES TEST_MODELS="${TEST_MODEL_ZOO}")
35 else()
36- set(EXCLUDED_SOURCE_PATHS ${CMAKE_CURRENT_SOURCE_DIR}/extension ${CMAKE_CURRENT_SOURCE_DIR}/shared_tests_instances/onnx)
37+ set(EXCLUDED_SOURCE_PATHS ${CMAKE_CURRENT_SOURCE_DIR}/custom/extension ${CMAKE_CURRENT_SOURCE_DIR}/shared_tests_instances/onnx)
38 endif()
39
40 if(NOT (ARM OR AARCH64))
41--
422.34.1
43
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-fix-build-when-using-sysroot.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-fix-build-when-using-sysroot.patch
new file mode 100644
index 00000000..d251f21b
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-fix-build-when-using-sysroot.patch
@@ -0,0 +1,32 @@
1From b5dfcf8bc1245e804c847745c237068eb6f19931 Mon Sep 17 00:00:00 2001
2From: Yogesh Tyagi <yogesh.tyagi@intel.com>
3Date: Fri, 15 Mar 2024 16:28:41 +0800
4Subject: [PATCH] cmake: fix build when using sysroot
5
6When cross-compiling against a sysroot, system headers will not be at a place
7that starts with /usr. Update conditional check to exclude directories
8which have "/usr/include" in them to not add <sysroot>/usr/include as well.
9
10Upstream-Status: Submitted [https://github.com/openvinotoolkit/openvino/pull/23486]
11
12Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
13---
14 src/cmake/ov_parallel.cmake | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/src/cmake/ov_parallel.cmake b/src/cmake/ov_parallel.cmake
18index 3793db98e30..819d3410531 100644
19--- a/src/cmake/ov_parallel.cmake
20+++ b/src/cmake/ov_parallel.cmake
21@@ -296,7 +296,7 @@ function(ov_set_threading_interface_for TARGET_NAME)
22 if(include_directories)
23 foreach(include_directory IN LISTS include_directories)
24 # cannot include /usr/include headers as SYSTEM
25- if(NOT "${include_directory}" MATCHES "^/usr.*$")
26+ if(NOT "${include_directory}" MATCHES ".*/usr/include.*$")
27 target_include_directories(${TARGET_NAME} SYSTEM
28 ${LINK_TYPE} $<BUILD_INTERFACE:${include_directory}>)
29 else()
30--
312.34.1
32
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Change-the-working-directory-to-source-to-workaround.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Change-the-working-directory-to-source-to-workaround.patch
deleted file mode 100644
index e6fe3271..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Change-the-working-directory-to-source-to-workaround.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From a0ea332df477480f90d9dc841faf71f4b5be892e Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 29 Nov 2023 12:45:59 +0530
4Subject: [PATCH 2/4] Change the working directory to source to workaround
5 cython embedding absolute path to the pyx file in output.
6
7Upstream-Status: Inappropriate [OE build specific]
8
9Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
10---
11 .../python/src/compatibility/openvino/cmake/UseCython.cmake | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/src/bindings/python/src/compatibility/openvino/cmake/UseCython.cmake b/src/bindings/python/src/compatibility/openvino/cmake/UseCython.cmake
15index 03a208f03c2..be9af591b34 100644
16--- a/src/bindings/python/src/compatibility/openvino/cmake/UseCython.cmake
17+++ b/src/bindings/python/src/compatibility/openvino/cmake/UseCython.cmake
18@@ -258,7 +258,7 @@ function( compile_pyx _name generated_file )
19 add_custom_command( OUTPUT ${_generated_file}
20 COMMAND ${CYTHON_EXECUTABLE}
21 ARGS ${cxx_arg} ${include_directory_arg} ${version_arg}
22- ${annotate_arg} ${no_docstrings_arg} ${cython_debug_arg} ${CYTHON_FLAGS}
23+ ${annotate_arg} ${no_docstrings_arg} ${cython_debug_arg} ${CYTHON_FLAGS} -w ${CMAKE_CURRENT_SOURCE_DIR}
24 --output-file ${_generated_file} ${pyx_locations}
25 DEPENDS ${pyx_locations} ${pxd_dependencies} ${pxi_dependencies}
26 IMPLICIT_DEPENDS ${pyx_lang} ${c_header_dependencies}
27--
282.34.1
29
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.3.0.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2024.0.0.bb
index e465ab3e..94edd1b8 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.3.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2024.0.0.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "This toolkit allows developers to deploy pre-trained \
4deep learning models through a high-level C++ Inference Engine API \ 4deep learning models through a high-level C++ Inference Engine API \
5integrated with application logic." 5integrated with application logic."
6 6
7SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;name=openvino;branch=releases/2023/3;lfs=0 \ 7SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;name=openvino;branch=releases/2024/0;lfs=0 \
8 git://github.com/openvinotoolkit/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/onednn;name=mkl;nobranch=1 \ 8 git://github.com/openvinotoolkit/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/onednn;name=mkl;nobranch=1 \
9 git://github.com/oneapi-src/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_gpu/thirdparty/onednn_gpu;name=onednn;nobranch=1 \ 9 git://github.com/oneapi-src/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_gpu/thirdparty/onednn_gpu;name=onednn;nobranch=1 \
10 git://github.com/herumi/xbyak.git;protocol=https;destsuffix=git/thirdparty/xbyak;name=xbyak;branch=master \ 10 git://github.com/herumi/xbyak.git;protocol=https;destsuffix=git/thirdparty/xbyak;name=xbyak;branch=master \
@@ -13,26 +13,29 @@ SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;name=ope
13 git://github.com/protocolbuffers/protobuf.git;protocol=https;destsuffix=git/thirdparty/protobuf/protobuf;name=protobuf;branch=3.20.x \ 13 git://github.com/protocolbuffers/protobuf.git;protocol=https;destsuffix=git/thirdparty/protobuf/protobuf;name=protobuf;branch=3.20.x \
14 git://github.com/gflags/gflags.git;protocol=https;destsuffix=git/thirdparty/gflags/gflags;name=gflags;nobranch=1 \ 14 git://github.com/gflags/gflags.git;protocol=https;destsuffix=git/thirdparty/gflags/gflags;name=gflags;nobranch=1 \
15 git://github.com/madler/zlib.git;protocol=https;destsuffix=git/thirdparty/zlib/zlib;name=zlib;nobranch=1 \ 15 git://github.com/madler/zlib.git;protocol=https;destsuffix=git/thirdparty/zlib/zlib;name=zlib;nobranch=1 \
16 git://github.com/openvinotoolkit/mlas.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/mlas;name=mlas;nobranch=1 \
16 git://github.com/nodejs/node-api-headers.git;protocol=https;destsuffix=git/node-api-headers-src;name=node-api-headers;nobranch=1 \ 17 git://github.com/nodejs/node-api-headers.git;protocol=https;destsuffix=git/node-api-headers-src;name=node-api-headers;nobranch=1 \
17 git://github.com/nodejs/node-addon-api.git;protocol=https;destsuffix=git/node-addon-api-src;name=node-addon-api;nobranch=1 \ 18 git://github.com/nodejs/node-addon-api.git;protocol=https;destsuffix=git/node-addon-api-src;name=node-addon-api;nobranch=1 \
18 file://0001-cmake-yocto-specific-tweaks-to-the-build-process.patch \ 19 file://0001-cmake-yocto-specific-tweaks-to-the-build-process.patch \
19 file://0002-Change-the-working-directory-to-source-to-workaround.patch \
20 file://0003-cmake-Fix-overloaded-virtual-error.patch \ 20 file://0003-cmake-Fix-overloaded-virtual-error.patch \
21 file://0004-protobuf-allow-target-protoc-to-be-built.patch \ 21 file://0004-protobuf-allow-target-protoc-to-be-built.patch \
22 file://0001-cmake-fix-build-when-using-sysroot.patch \
23 file://0001-CPU-Solving-the-build-failure-caused-by-setting-the-.patch \
22 " 24 "
23 25
24SRCREV_openvino = "ceeafaf64f346c6f14a67c612e131da5c27ef620" 26SRCREV_openvino = "34caeefd07800b59065345d651949efbe8ab6649"
25SRCREV_mkl = "cb3060bbf4694e46a1359a3d4dfe70500818f72d" 27SRCREV_mkl = "f82148befdbdc9576ec721c9d500155ee4de8060"
26SRCREV_onednn = "cb77937ffcf5e83b5d1cf2940c94e8b508d8f7b4" 28SRCREV_onednn = "494af5f9921bdae98f1a0e2955fa7d76ff386c4f"
27SRCREV_xbyak = "740dff2e866f3ae1a70dd42d6e8836847ed95cc2" 29SRCREV_xbyak = "740dff2e866f3ae1a70dd42d6e8836847ed95cc2"
28SRCREV_json = "9cca280a4d0ccf0c08f47a99aa71d1b0e52f8d03" 30SRCREV_json = "9cca280a4d0ccf0c08f47a99aa71d1b0e52f8d03"
29SRCREV_ade = "0e8a2ccdd34f29dba55894f5f3c5179809888b9e" 31SRCREV_ade = "0e8a2ccdd34f29dba55894f5f3c5179809888b9e"
30SRCREV_protobuf = "fe271ab76f2ad2b2b28c10443865d2af21e27e0e" 32SRCREV_protobuf = "fe271ab76f2ad2b2b28c10443865d2af21e27e0e"
31SRCREV_gflags = "e171aa2d15ed9eb17054558e0b3a6a413bb01067" 33SRCREV_gflags = "e171aa2d15ed9eb17054558e0b3a6a413bb01067"
32SRCREV_zlib = "04f42ceca40f73e2978b50e93806c2a18c1281fc" 34SRCREV_zlib = "09155eaa2f9270dc4ed1fa13e2b4b2613e6e4851"
35SRCREV_mlas = "d1bc25ec4660cddd87804fcf03b2411b5dfb2e94"
33SRCREV_node-api-headers = "186e04b5e40e54d7fd1655bc67081cc483f12488" 36SRCREV_node-api-headers = "186e04b5e40e54d7fd1655bc67081cc483f12488"
34SRCREV_node-addon-api = "39a25bf27788ff7a7ea5c64978c4dcd1e7b9d80d" 37SRCREV_node-addon-api = "39a25bf27788ff7a7ea5c64978c4dcd1e7b9d80d"
35SRCREV_FORMAT = "openvino_mkl_onednn_xbyak_json_ade_protobuf_gflags_zlib_node-api-headers_node-addon-api" 38SRCREV_FORMAT = "openvino_mkl_onednn_xbyak_json_ade_protobuf_gflags_zlib_node-api-headers_node-addon-api_mlas"
36 39
37LICENSE = "Apache-2.0 & MIT & BSD-3-Clause & Zlib" 40LICENSE = "Apache-2.0 & MIT & BSD-3-Clause & Zlib"
38LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \ 41LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
@@ -42,6 +45,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
42 file://thirdparty/ade/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \ 45 file://thirdparty/ade/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
43 file://thirdparty/gflags/gflags/COPYING.txt;md5=c80d1a3b623f72bb85a4c75b556551df \ 46 file://thirdparty/gflags/gflags/COPYING.txt;md5=c80d1a3b623f72bb85a4c75b556551df \
44 file://thirdparty/zlib/zlib/LICENSE;md5=b51a40671bc46e961c0498897742c0b8 \ 47 file://thirdparty/zlib/zlib/LICENSE;md5=b51a40671bc46e961c0498897742c0b8 \
48 file://src/plugins/intel_cpu/thirdparty/mlas/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
45 file://src/plugins/intel_cpu/thirdparty/onednn/LICENSE;md5=3b64000f6e7d52516017622a37a94ce9 \ 49 file://src/plugins/intel_cpu/thirdparty/onednn/LICENSE;md5=3b64000f6e7d52516017622a37a94ce9 \
46 file://src/plugins/intel_gpu/thirdparty/onednn_gpu/LICENSE;md5=3b64000f6e7d52516017622a37a94ce9 \ 50 file://src/plugins/intel_gpu/thirdparty/onednn_gpu/LICENSE;md5=3b64000f6e7d52516017622a37a94ce9 \
47 file://node-api-headers-src/LICENSE;md5=6adb2909701d4605b4b2ae1a9b25d8bd \ 51 file://node-api-headers-src/LICENSE;md5=6adb2909701d4605b4b2ae1a9b25d8bd \
@@ -69,7 +73,6 @@ EXTRA_OECMAKE += " \
69 -DCPACK_GENERATOR=RPM \ 73 -DCPACK_GENERATOR=RPM \
70 -DENABLE_SYSTEM_FLATBUFFERS=ON \ 74 -DENABLE_SYSTEM_FLATBUFFERS=ON \
71 -DENABLE_SYSTEM_SNAPPY=ON \ 75 -DENABLE_SYSTEM_SNAPPY=ON \
72 -DENABLE_MLAS_FOR_CPU=OFF \
73 -DFETCHCONTENT_BASE_DIR="${S}" \ 76 -DFETCHCONTENT_BASE_DIR="${S}" \
74 " 77 "
75 78
@@ -88,7 +91,7 @@ COMPATIBLE_HOST:libc-musl = "null"
88 91
89PACKAGECONFIG ?= "opencl samples" 92PACKAGECONFIG ?= "opencl samples"
90PACKAGECONFIG[opencl] = "-DENABLE_INTEL_GPU=TRUE, -DENABLE_INTEL_GPU=FALSE, virtual/opencl-icd opencl-headers opencl-clhpp," 93PACKAGECONFIG[opencl] = "-DENABLE_INTEL_GPU=TRUE, -DENABLE_INTEL_GPU=FALSE, virtual/opencl-icd opencl-headers opencl-clhpp,"
91PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR} -DENABLE_PYTHON_PACKAGING=ON, -DENABLE_PYTHON=OFF, python3-cython-native patchelf-native, python3 python3-numpy python3-progress python3-cython" 94PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR} -DENABLE_PYTHON_PACKAGING=ON, -DENABLE_PYTHON=OFF, patchelf-native, python3 python3-numpy python3-progress"
92PACKAGECONFIG[samples] = "-DENABLE_SAMPLES=ON -DENABLE_COMPILE_TOOL=ON, -DENABLE_SAMPLES=OFF -DENABLE_COMPILE_TOOL=OFF, opencv" 95PACKAGECONFIG[samples] = "-DENABLE_SAMPLES=ON -DENABLE_COMPILE_TOOL=ON, -DENABLE_SAMPLES=OFF -DENABLE_COMPILE_TOOL=OFF, opencv"
93PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0" 96PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0"
94 97