diff options
author | Darren Hart <dvhart@linux.intel.com> | 2014-06-26 14:22:10 (GMT) |
---|---|---|
committer | Darren Hart <dvhart@linux.intel.com> | 2014-06-26 14:22:10 (GMT) |
commit | 05dd98cf5c117a8bdd566d36d20a84fff20e8cc3 (patch) | |
tree | eedb3499fcc3881c9c3bd8275e8f0269fbc3b3cd | |
parent | 76f529881208811e314dba1478cc3a70abf3160f (diff) | |
download | meta-intel-05dd98cf5c117a8bdd566d36d20a84fff20e8cc3.tar.gz |
linux-yocto: Make KERNEL_MODULE_AUTOLOAD machine specific
BSP linux-yocto bbappend files should make all variable updates with
machine-specific overrides. As it stands, building qemux86 with
meta-intel in BBLAYERS will add uio and iwlwifi to
KERNEL_MODULES_AUTOLOAD. This corrects that.
Signed-off-by: Darren Hart <dvhart@linux.intel.com>
6 files changed, 19 insertions, 10 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-dev.bbappend b/common/recipes-kernel/linux/linux-yocto-dev.bbappend index 71e4095..ddc1c4a 100644 --- a/common/recipes-kernel/linux/linux-yocto-dev.bbappend +++ b/common/recipes-kernel/linux/linux-yocto-dev.bbappend | |||
@@ -19,7 +19,9 @@ KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} | |||
19 | # default SRCREV is set and linux-yocto-dev is the preferred provider. | 19 | # default SRCREV is set and linux-yocto-dev is the preferred provider. |
20 | 20 | ||
21 | # For Crystalforest and Romley | 21 | # For Crystalforest and Romley |
22 | KERNEL_MODULE_AUTOLOAD += "uio" | 22 | KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "uio" |
23 | KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "uio" | ||
23 | 24 | ||
24 | # For FRI2 | 25 | # For FRI2, NUC |
25 | KERNEL_MODULE_AUTOLOAD += "iwlwifi" | 26 | KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "iwlwifi" |
27 | KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "iwlwifi" | ||
diff --git a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend index bbce8f4..a142e5b 100644 --- a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend +++ b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend | |||
@@ -21,7 +21,9 @@ KBRANCH_corei7-64-intel-common = "standard/base" | |||
21 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 21 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
22 | 22 | ||
23 | # For Crystalforest and Romley | 23 | # For Crystalforest and Romley |
24 | KERNEL_MODULE_AUTOLOAD += "uio" | 24 | KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "uio" |
25 | KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "uio" | ||
25 | 26 | ||
26 | # For FRI2, NUC | 27 | # For FRI2, NUC |
27 | KERNEL_MODULE_AUTOLOAD += "iwlwifi" | 28 | KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "iwlwifi" |
29 | KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "iwlwifi" | ||
diff --git a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend index 139c1f0..a0ca5fc 100644 --- a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend +++ b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend | |||
@@ -20,7 +20,9 @@ KBRANCH_corei7-64-intel-common = "standard/base" | |||
20 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 20 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
21 | 21 | ||
22 | # For Crystalforest and Romley | 22 | # For Crystalforest and Romley |
23 | KERNEL_MODULE_AUTOLOAD += "uio" | 23 | KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "uio" |
24 | KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "uio" | ||
24 | 25 | ||
25 | # For FRI2, NUC | 26 | # For FRI2, NUC |
26 | KERNEL_MODULE_AUTOLOAD += "iwlwifi" | 27 | KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "iwlwifi" |
28 | KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "iwlwifi" | ||
diff --git a/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend b/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend index 7aaf53a..e57449f 100644 --- a/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend +++ b/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend | |||
@@ -12,4 +12,5 @@ KBRANCH_fri2-noemgd = "standard/preempt-rt/fri2" | |||
12 | SRCREV_machine_pn-linux-yocto-rt_fri2-noemgd ?= "b669af08737562ef86e7cba328966d05222d3e64" | 12 | SRCREV_machine_pn-linux-yocto-rt_fri2-noemgd ?= "b669af08737562ef86e7cba328966d05222d3e64" |
13 | #SRCREV_meta_pn-linux-yocto-rt_fri2-noemgd ?= "XXX" | 13 | #SRCREV_meta_pn-linux-yocto-rt_fri2-noemgd ?= "XXX" |
14 | 14 | ||
15 | KERNEL_MODULE_AUTOLOAD += "iwlwifi" | 15 | KERNEL_MODULE_AUTOLOAD_fri2 += "iwlwifi" |
16 | KERNEL_MODULE_AUTOLOAD_fri2-noemgd += "iwlwifi" | ||
diff --git a/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend index 14bb81a..a4732f2 100644 --- a/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend +++ b/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend | |||
@@ -18,4 +18,5 @@ LINUX_VERSION_fri2-noemgd = "3.10.38" | |||
18 | SRCREV_meta_fri2-noemgd = "e1f26aeccfd43bc3d7e95873ceda469b631b8473" | 18 | SRCREV_meta_fri2-noemgd = "e1f26aeccfd43bc3d7e95873ceda469b631b8473" |
19 | SRCREV_machine_fri2-noemgd = "02f7e63e56c061617957388c23bd5cf9b05c5388" | 19 | SRCREV_machine_fri2-noemgd = "02f7e63e56c061617957388c23bd5cf9b05c5388" |
20 | 20 | ||
21 | KERNEL_MODULE_AUTOLOAD += "iwlwifi" | 21 | KERNEL_MODULE_AUTOLOAD_fri2 += "iwlwifi" |
22 | KERNEL_MODULE_AUTOLOAD_fri2-noemgd += "iwlwifi" | ||
diff --git a/meta-isg/meta-valleyisland/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-isg/meta-valleyisland/recipes-kernel/linux/linux-yocto_3.10.bbappend index e329712..c691a42 100644 --- a/meta-isg/meta-valleyisland/recipes-kernel/linux/linux-yocto_3.10.bbappend +++ b/meta-isg/meta-valleyisland/recipes-kernel/linux/linux-yocto_3.10.bbappend | |||
@@ -32,4 +32,5 @@ SRCREV_valleyisland-io_valleyisland-64 = "8ea4fb625f2654bbdd5dfcb9db67328d21ebe5 | |||
32 | 32 | ||
33 | SRC_URI_valleyisland-64 = "git://git.yoctoproject.org/linux-yocto-3.10.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},valleyisland-io-1.0;name=machine,meta,valleyisland-io" | 33 | SRC_URI_valleyisland-64 = "git://git.yoctoproject.org/linux-yocto-3.10.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},valleyisland-io-1.0;name=machine,meta,valleyisland-io" |
34 | 34 | ||
35 | KERNEL_MODULE_AUTOLOAD += "i2c-dev" | 35 | KERNEL_MODULE_AUTOLOAD_valleyisland-32 += "i2c-dev" |
36 | KERNEL_MODULE_AUTOLOAD_valleyisland-64 += "i2c-dev" | ||