summaryrefslogtreecommitdiffstats
path: root/recipes-extended/zlib-qat/zlib-qat
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/zlib-qat/zlib-qat')
-rw-r--r--recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-Remove-rpaths-from-makefile.patch63
-rw-r--r--recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-qat-add-a-install-target-to-makefile.patch30
-rw-r--r--recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-qat-correct-the-order-for-static-linking-libude.patch31
3 files changed, 124 insertions, 0 deletions
diff --git a/recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-Remove-rpaths-from-makefile.patch b/recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-Remove-rpaths-from-makefile.patch
new file mode 100644
index 0000000..2da2bb7
--- /dev/null
+++ b/recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-Remove-rpaths-from-makefile.patch
@@ -0,0 +1,63 @@
1From d14d6ea2072ede5d1afddf738cb1801263e90d70 Mon Sep 17 00:00:00 2001
2From: "Tan, Raymond" <raymond.tan@intel.com>
3Date: Fri, 10 Aug 2018 15:45:38 +0800
4Subject: [PATCH 2/3] zlib: Remove rpaths from makefile
5
6Upstream-Status: Inappropriate [configuration]
7
8This removes references to RPATHS that are no longer
9necesary when building using bitbake.
10
11Signed-off-by: Tan, Raymond <raymond.tan@intel.com>
12---
13 Makefile.in | 9 +++++----
14 contrib/qat/qat_zlib_test/Makefile | 3 ---
15 2 files changed, 5 insertions(+), 7 deletions(-)
16
17diff --git a/Makefile.in b/Makefile.in
18index 0100f59..8978ef1 100644
19--- a/Makefile.in
20+++ b/Makefile.in
21@@ -59,12 +59,13 @@ ICP_LAC_API_DIR=$(ICP_API_DIR)/lac/
22 ICP_DC_API_DIR=$(ICP_API_DIR)/dc/
23 CFLAGS+=-D_GNU_SOURCE -I$(ICP_API_DIR) -I$(ICP_DC_API_DIR) -I$(ICP_LAC_API_DIR) -I$(ICP_SAL_API_DIR)
24 SFLAGS+=-D_GNU_SOURCE -I$(ICP_API_DIR) -I$(ICP_DC_API_DIR) -I$(ICP_LAC_API_DIR) -I$(ICP_SAL_API_DIR)
25-ADDITIONAL_LDFLAGS+=-Wl,-rpath,$(ZLIB_ROOT) -lz
26-SHARED_APP_FLAGS=-Wl,-rpath,$(ZLIB_ROOT) -L$(ZLIB_ROOT) -lz
27+#ADDITIONAL_LDFLAGS+=-Wl,-rpath,$(ZLIB_ROOT) -lz
28+#SHARED_APP_FLAGS=-Wl,-rpath,$(ZLIB_ROOT) -L$(ZLIB_ROOT) -lz
29+SHARED_APP_FLAGS=-L$(ZLIB_ROOT) -lz
30
31 ifdef ICP_BUILD_OUTPUT
32 TEST_LDFLAGS+=-L$(ICP_BUILD_OUTPUT)
33- ADDITIONAL_LDFLAGS+=-Wl,-rpath,$(ICP_BUILD_OUTPUT) -L$(ICP_BUILD_OUTPUT)
34+# ADDITIONAL_LDFLAGS+=-Wl,-rpath,$(ICP_BUILD_OUTPUT) -L$(ICP_BUILD_OUTPUT)
35 endif
36
37 ifdef UPSTREAM_DRIVER_CMN_ROOT
38@@ -91,7 +92,7 @@ ADDITIONAL_SHAREDLIBC=-L$(ICP_BUILD_OUTPUT) -l$(DRIVER)_s -lpthread -lrt
39
40 ifeq ($(ZLIB_MEMORY_DRIVER),usdm_drv)
41 TEST_LDFLAGS+= $(CMN_ROOT)/libusdm_drv.a
42-ADDITIONAL_LDFLAGS+=-Wl,-rpath,$(CMN_ROOT) -L$(CMN_ROOT) -lusdm_drv_s
43+#ADDITIONAL_LDFLAGS+=-Wl,-rpath,$(CMN_ROOT) -L$(CMN_ROOT) -lusdm_drv_s
44 endif
45
46 STATICLIB=libz.a
47diff --git a/contrib/qat/qat_zlib_test/Makefile b/contrib/qat/qat_zlib_test/Makefile
48index 47829ac..bfcf86d 100644
49--- a/contrib/qat/qat_zlib_test/Makefile
50+++ b/contrib/qat/qat_zlib_test/Makefile
51@@ -85,9 +85,6 @@ COVERAGE_OBJS =
52 EXE=
53 LIBQAT=
54 UDEV=
55-ifdef ICP_BUILD_OUTPUT
56- LIBQAT+= -Wl,-rpath,$(ICP_BUILD_OUTPUT) -L$(ICP_BUILD_OUTPUT)
57-endif
58
59 ifdef UPSTREAM_DRIVER_CMN_ROOT
60 DRIVER=qat
61--
621.9.1
63
diff --git a/recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-qat-add-a-install-target-to-makefile.patch b/recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-qat-add-a-install-target-to-makefile.patch
new file mode 100644
index 0000000..3a202e9
--- /dev/null
+++ b/recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-qat-add-a-install-target-to-makefile.patch
@@ -0,0 +1,30 @@
1From 943dd3c2b9d68385c9e71b1cc215cf03e2dd74fd Mon Sep 17 00:00:00 2001
2From: "Tan, Raymond" <raymond.tan@intel.com>
3Date: Wed, 29 Aug 2018 13:35:44 +0800
4Subject: [PATCH 1/3] zlib-qat: add a install target to makefile
5
6Upstream-Status: Inappropriate [Configuration]$
7
8This adds an install target to qat_zlib_test makefiles
9to facilitate the installation of test binaries to {D}.
10
11Signed-off-by: Tan, Raymond <raymond.tan@intel.com>
12---
13 contrib/qat/qat_zlib_test/Makefile | 2 ++
14 1 file changed, 2 insertions(+)
15
16diff --git a/contrib/qat/qat_zlib_test/Makefile b/contrib/qat/qat_zlib_test/Makefile
17index 7b86028..47829ac 100644
18--- a/contrib/qat/qat_zlib_test/Makefile
19+++ b/contrib/qat/qat_zlib_test/Makefile
20@@ -132,5 +132,7 @@ comptestappsh$(EXE): $(OBJS) Makefile
21 $(CC) -o comptestappsh $(OBJS) $(COVERAGE) \
22 $(SHAREDLIBQAT)
23
24+install:
25+ cp comptestapp $(DESTDIR)$(bindir)
26 clean:
27 rm -f $(OBJS) $(COVERAGE_OBJS) comptestapp comptestappsh
28--
291.9.1
30
diff --git a/recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-qat-correct-the-order-for-static-linking-libude.patch b/recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-qat-correct-the-order-for-static-linking-libude.patch
new file mode 100644
index 0000000..5352cb9
--- /dev/null
+++ b/recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-qat-correct-the-order-for-static-linking-libude.patch
@@ -0,0 +1,31 @@
1From 7d74f6aa82042c2bb03e46fafe580bf4d117a24a Mon Sep 17 00:00:00 2001
2From: "Tan, Raymond" <raymond.tan@intel.com>
3Date: Thu, 16 Aug 2018 14:29:05 +0800
4Subject: [PATCH 3/3] zlib-qat: correct the order for static linking libudev
5
6Upstream-Status: Inappropriate [Configuration]
7
8This changes the order of linking command to link libudev after libadf
9to avoid undefined reference on udev.
10
11Signed-off-by: Tan, Raymond <raymond.tan@intel.com>
12---
13 contrib/qat/qat_zlib_test/Makefile | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/contrib/qat/qat_zlib_test/Makefile b/contrib/qat/qat_zlib_test/Makefile
17index bfcf86d..0498da8 100644
18--- a/contrib/qat/qat_zlib_test/Makefile
19+++ b/contrib/qat/qat_zlib_test/Makefile
20@@ -101,7 +101,7 @@ ifdef WITH_CPA_MUX
21 endif
22
23 SHAREDLIBQAT= -Wl,-rpath,$(ZLIB_ROOT) -L$(ZLIB_ROOT) -lz -ldl -lrt -lpthread
24-STATICLIBQAT= $(ZLIB_ROOT)/libz.a $(LIBQAT) $(UDEV) -l$(DRIVER) -l$(ADFPROXY) -losal -lcrypto -ldl -lrt -lpthread
25+STATICLIBQAT= $(ZLIB_ROOT)/libz.a $(LIBQAT) -l$(DRIVER) -l$(ADFPROXY) -losal -lcrypto -ldl -lrt -lpthread $(UDEV)
26
27 ifeq ($(ZLIB_MEMORY_DRIVER),usdm_drv)
28 STATICLIBQAT+= $(CMN_ROOT)/libusdm_drv.a
29--
301.9.1
31