summaryrefslogtreecommitdiffstats
path: root/recipes-extended/qat/files/0003-qat-override-CC-LD-AR-only-when-it-is-not-define.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/qat/files/0003-qat-override-CC-LD-AR-only-when-it-is-not-define.patch')
-rw-r--r--recipes-extended/qat/files/0003-qat-override-CC-LD-AR-only-when-it-is-not-define.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-extended/qat/files/0003-qat-override-CC-LD-AR-only-when-it-is-not-define.patch b/recipes-extended/qat/files/0003-qat-override-CC-LD-AR-only-when-it-is-not-define.patch
new file mode 100644
index 0000000..f3b8fe6
--- /dev/null
+++ b/recipes-extended/qat/files/0003-qat-override-CC-LD-AR-only-when-it-is-not-define.patch
@@ -0,0 +1,35 @@
1From 0a881aefea89006f21b82fcafc5a422b04fc0c9a Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Mon, 12 Apr 2021 08:40:47 +0800
4Subject: [PATCH 03/11] qat: override CC LD AR only when it is not define
5
6Upstream-Status: Inappropriate [Configuration]
7
8To make sure that compiler linker and archiver will override only when
9it is not defined by the environment.
10
11Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
12---
13 quickassist/build_system/build_files/Core/ia.mk | 6 +++---
14 1 file changed, 3 insertions(+), 3 deletions(-)
15
16diff --git a/quickassist/build_system/build_files/Core/ia.mk b/quickassist/build_system/build_files/Core/ia.mk
17index 230ee0f..f6fc755 100644
18--- a/quickassist/build_system/build_files/Core/ia.mk
19+++ b/quickassist/build_system/build_files/Core/ia.mk
20@@ -67,9 +67,9 @@
21 # e.g. setenv CROSS_COMPILE x86_64-linux
22 ifdef CROSS_COMPILE
23 ifdef MACHINE
24-CC = $(CROSS_COMPILE)gcc
25-LD = $(CROSS_COMPILE)ld
26-AR = $(CROSS_COMPILE)ar
27+CC ?= $(CROSS_COMPILE)gcc
28+LD ?= $(CROSS_COMPILE)ld
29+AR ?= $(CROSS_COMPILE)ar
30 else
31 $(error MACHINE is undefined. Please set your target i.e. x86_64 \
32 "-> setenv MACHINE x86_64 or export MACHINE=x86_64")
33--
342.14.5
35