summaryrefslogtreecommitdiffstats
path: root/recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-qat-add-a-install-target-to-makefile.patch
diff options
context:
space:
mode:
authorTan, Raymond <raymond.tan@intel.com>2018-09-04 22:46:14 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2018-09-04 22:31:38 +0800
commit1f03a46ab13b46f14beb2c566734d5fdd35f28f7 (patch)
treeecbdbfe420fddd12223a7ffa3c5f1cdc04df66b8 /recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-qat-add-a-install-target-to-makefile.patch
parent2eecd72ce9d42c3dcfca1bbee8a680386c8f385d (diff)
downloadmeta-intel-qat-1f03a46ab13b46f14beb2c566734d5fdd35f28f7.tar.gz
zlib-qat: add common zlib-qat.inc and zlib-qat shim version 0.4.10-001
This patch will do the following: 1) add zlib-qat.inc for common components across the zlib-qat shim version 0.4.7 and 0.4.10 2) add zlib-qat shim layer version 0.4.10-001, which works with QAT 1.7 hardware and uses the CMN driver(libusdm) provided by QAT17 package 3) inherit module.bbclass only in zlib-qat-0.4.7-002, which builds OOT kernel module (qat_mem.ko) 4) DEPENDS variable updated to respective zlib-qat shim version to respective QAT version; ver. 0.4.7-002 -> qat16, and ver. 0.4.10-001 -> qat17 Signed-off-by: Tan, Raymond <raymond.tan@intel.com>
Diffstat (limited to 'recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-qat-add-a-install-target-to-makefile.patch')
-rw-r--r--recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-qat-add-a-install-target-to-makefile.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-qat-add-a-install-target-to-makefile.patch b/recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-qat-add-a-install-target-to-makefile.patch
new file mode 100644
index 0000000..3a202e9
--- /dev/null
+++ b/recipes-extended/zlib-qat/zlib-qat/zlib-qat-0.4.10-001-zlib-qat-add-a-install-target-to-makefile.patch
@@ -0,0 +1,30 @@
1From 943dd3c2b9d68385c9e71b1cc215cf03e2dd74fd Mon Sep 17 00:00:00 2001
2From: "Tan, Raymond" <raymond.tan@intel.com>
3Date: Wed, 29 Aug 2018 13:35:44 +0800
4Subject: [PATCH 1/3] zlib-qat: add a install target to makefile
5
6Upstream-Status: Inappropriate [Configuration]$
7
8This adds an install target to qat_zlib_test makefiles
9to facilitate the installation of test binaries to {D}.
10
11Signed-off-by: Tan, Raymond <raymond.tan@intel.com>
12---
13 contrib/qat/qat_zlib_test/Makefile | 2 ++
14 1 file changed, 2 insertions(+)
15
16diff --git a/contrib/qat/qat_zlib_test/Makefile b/contrib/qat/qat_zlib_test/Makefile
17index 7b86028..47829ac 100644
18--- a/contrib/qat/qat_zlib_test/Makefile
19+++ b/contrib/qat/qat_zlib_test/Makefile
20@@ -132,5 +132,7 @@ comptestappsh$(EXE): $(OBJS) Makefile
21 $(CC) -o comptestappsh $(OBJS) $(COVERAGE) \
22 $(SHAREDLIBQAT)
23
24+install:
25+ cp comptestapp $(DESTDIR)$(bindir)
26 clean:
27 rm -f $(OBJS) $(COVERAGE_OBJS) comptestapp comptestappsh
28--
291.9.1
30