summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYongxin Liu <yongxin.liu@windriver.com>2020-01-16 22:13:13 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-01-20 13:20:40 +0800
commit3f32ece68a4bda31e654eb72f5a1c18d941d12ca (patch)
tree287dd8337c83d58ac5bbebf1b2e226002e1103e9
parenta13a008d15e8176ba8b086883d6354faf03b49c8 (diff)
downloadmeta-intel-qat-3f32ece68a4bda31e654eb72f5a1c18d941d12ca.tar.gz
qat: Fix do_patch error in parallel buildingzeus
1) When doing patch for qat, the variable KERNEL_VERSION may not be set yet, so qat17_4.7.0-00006-Switch-to-skcipher-API.patch cannot be applied. Add task dependency to fix it. 2) Changing SRC_URI may lead to "basehash value changed" error message. Doing patch in a separate function to avoid it. Signed-off-by: Yongxin Liu <yongxin.liu@windriver.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-extended/qat/qat17_4.7.0-00006.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/recipes-extended/qat/qat17_4.7.0-00006.bb b/recipes-extended/qat/qat17_4.7.0-00006.bb
index 693a2f8..a77f4c0 100644
--- a/recipes-extended/qat/qat17_4.7.0-00006.bb
+++ b/recipes-extended/qat/qat17_4.7.0-00006.bb
@@ -21,11 +21,19 @@ SRC_URI = "https://01.org/sites/default/files/downloads/qat1.7.l.4.7.0-00006.tar
21 file://qat17_4.1.0-00022-qat-use-static-lib-for-linking.patch \ 21 file://qat17_4.1.0-00022-qat-use-static-lib-for-linking.patch \
22 file://qat17_4.7.0-00006-Link-driver-with-object-files.patch \ 22 file://qat17_4.7.0-00006-Link-driver-with-object-files.patch \
23 file://qat17_4.7.0-00006-Drop-pr_warning-definition.patch \ 23 file://qat17_4.7.0-00006-Drop-pr_warning-definition.patch \
24 file://qat17_4.7.0-00006-Switch-to-skcipher-API.patch;apply=0 \
24 " 25 "
25 26
26python __anonymous () { 27do_patch[depends] += "virtual/kernel:do_shared_workdir"
28
29do_patch_append () {
27 if d.getVar("KERNEL_VERSION") >= "5.5%": 30 if d.getVar("KERNEL_VERSION") >= "5.5%":
28 d.appendVar('SRC_URI', "file://qat17_4.7.0-00006-Switch-to-skcipher-API.patch") 31 bb.build.exec_func('do_switch_to_skcipher_api', d)
32}
33
34do_switch_to_skcipher_api () {
35 cd "${S}"
36 patch -p1 < "${WORKDIR}/qat17_4.7.0-00006-Switch-to-skcipher-API.patch"
29} 37}
30 38
31SRC_URI[md5sum] = "ac939b51cc8836c182e31e309c065002" 39SRC_URI[md5sum] = "ac939b51cc8836c182e31e309c065002"