summaryrefslogtreecommitdiffstats
path: root/recipes-support/gnupg/gnupg-1.4.7/0001-Make-it-build-with-gettext-0.20.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/gnupg/gnupg-1.4.7/0001-Make-it-build-with-gettext-0.20.patch')
-rw-r--r--recipes-support/gnupg/gnupg-1.4.7/0001-Make-it-build-with-gettext-0.20.patch80
1 files changed, 80 insertions, 0 deletions
diff --git a/recipes-support/gnupg/gnupg-1.4.7/0001-Make-it-build-with-gettext-0.20.patch b/recipes-support/gnupg/gnupg-1.4.7/0001-Make-it-build-with-gettext-0.20.patch
new file mode 100644
index 0000000..a8eddbe
--- /dev/null
+++ b/recipes-support/gnupg/gnupg-1.4.7/0001-Make-it-build-with-gettext-0.20.patch
@@ -0,0 +1,80 @@
1From 26076b28b79f6a2f2989a301ad7474cfa1153ebd Mon Sep 17 00:00:00 2001
2From: Peter Kjellerstedt <pkj@axis.com>
3Date: Tue, 7 Jan 2020 11:08:39 +0100
4Subject: [PATCH] Make it build with gettext 0.20
5
6Upstream-Status: Inappropriate [legacy version]
7Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
8---
9 Makefile.am | 2 +-
10 configure.ac | 2 +-
11 g10/Makefile.am | 2 +-
12 keyserver/Makefile.am | 2 +-
13 tools/Makefile.am | 2 +-
14 5 files changed, 5 insertions(+), 5 deletions(-)
15
16diff --git a/Makefile.am b/Makefile.am
17index 3423e70..1eebbc2 100644
18--- a/Makefile.am
19+++ b/Makefile.am
20@@ -28,7 +28,7 @@ else
21 checks = checks
22 endif
23
24-SUBDIRS = m4 intl zlib util mpi cipher tools g10 keyserver po doc ${checks}
25+SUBDIRS = m4 zlib util mpi cipher tools g10 keyserver po doc ${checks}
26 EXTRA_DIST = scripts/config.rpath PROJECTS BUGS config.h.in autogen.sh
27 DISTCLEANFILES =
28
29diff --git a/configure.ac b/configure.ac
30index 9f64b75..d9e5f69 100644
31--- a/configure.ac
32+++ b/configure.ac
33@@ -813,7 +813,7 @@ dnl Checks for libraries.
34
35 AM_GNU_GETTEXT_VERSION(0.14.1)
36 if test "$try_gettext" = yes; then
37- AM_GNU_GETTEXT(,[need-ngettext])
38+ AM_GNU_GETTEXT([external],[need-ngettext])
39
40 # gettext requires some extra checks. These really should be part of
41 # the basic AM_GNU_GETTEXT macro. TODO: move other gettext-specific
42diff --git a/g10/Makefile.am b/g10/Makefile.am
43index 74a8db1..ff51b7f 100644
44--- a/g10/Makefile.am
45+++ b/g10/Makefile.am
46@@ -32,7 +32,7 @@ AM_CPPFLAGS += -DGNUPG_LIBDIR="\"$(libdir)/@PACKAGE@\""
47 endif
48
49 needed_libs = ../cipher/libcipher.a ../mpi/libmpi.a ../util/libutil.a
50-other_libs = $(LIBICONV) $(DNSLIBS) $(LIBINTL) $(CAPLIBS)
51+other_libs = $(DNSLIBS) $(LIBINTL) $(CAPLIBS)
52
53 bin_PROGRAMS = gpg gpgv
54 dist_pkgdata_DATA = options.skel
55diff --git a/keyserver/Makefile.am b/keyserver/Makefile.am
56index 3379910..3527c60 100644
57--- a/keyserver/Makefile.am
58+++ b/keyserver/Makefile.am
59@@ -33,7 +33,7 @@ gpgkeys_hkp_SOURCES = gpgkeys_hkp.c ksutil.c ksutil.h
60 gpgkeys_finger_SOURCES = gpgkeys_finger.c ksutil.c ksutil.h
61 gpgkeys_curl_SOURCES = gpgkeys_curl.c ksutil.c ksutil.h
62
63-other_libs = $(LIBICONV) $(LIBINTL) $(CAPLIBS)
64+other_libs = $(LIBINTL) $(CAPLIBS)
65
66 gpgkeys_ldap_CPPFLAGS = @LDAP_CPPFLAGS@
67 gpgkeys_ldap_LDADD = ../util/libcompat.a @LDAPLIBS@ @NETLIBS@ $(other_libs) @GETOPT@ @W32LIBS@
68diff --git a/tools/Makefile.am b/tools/Makefile.am
69index 8a9c035..22cdb1e 100644
70--- a/tools/Makefile.am
71+++ b/tools/Makefile.am
72@@ -28,7 +28,7 @@ AM_CPPFLAGS += -DLOCALEDIR="\"$(localedir)\""
73 endif
74
75 needed_libs = ../cipher/libcipher.a ../mpi/libmpi.a ../util/libutil.a
76-other_libs = $(LIBICONV) $(LIBINTL) $(CAPLIBS)
77+other_libs = $(LIBINTL) $(CAPLIBS)
78
79
80 bin_PROGRAMS = gpgsplit