summaryrefslogtreecommitdiffstats
path: root/recipes-extended/msmtp/msmtp_1.4.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/msmtp/msmtp_1.4.12.bb')
-rw-r--r--recipes-extended/msmtp/msmtp_1.4.12.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-extended/msmtp/msmtp_1.4.12.bb b/recipes-extended/msmtp/msmtp_1.4.12.bb
new file mode 100644
index 0000000..e03d432
--- /dev/null
+++ b/recipes-extended/msmtp/msmtp_1.4.12.bb
@@ -0,0 +1,35 @@
1SUMMARY = "msmtp is an SMTP client."
2DESCRIPTION = "A sendmail replacement for use in MTAs like mutt"
3HOMEPAGE = "http://msmtp.sourceforge.net/"
4SECTION = "console/network"
5
6LICENSE = "GPLv2"
7
8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
9
10DEPENDS = "zlib gnutls"
11
12SRC_URI = "http://sourceforge.net/projects/msmtp/files/msmtp/${PV}/${BPN}-${PV}.tar.bz2 \
13 file://msmtp-fixup-api-and-compiler-warning.patch \
14 file://msmtp-replace-deprecated-function.patch \
15 "
16
17SRC_URI[md5sum] = "ba5b61d5f7667d288f1cfadccfff8ac5"
18SRC_URI[sha256sum] = "ab794bb014cdaeae0a1460a7aca1869dab8c93383bf01f41aca41b3d99b69509"
19
20EXTRA_OECONF += "--with-libgnutls-prefix=${STAGING_DIR}/${HOST_SYS}"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[libidn] = "--with-libidn,--without-libidn,libidn"
24
25inherit gettext autotools update-alternatives
26
27ALTERNATIVE_${PN} = "sendmail"
28ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp"
29ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail"
30ALTERNATIVE_PRIORITY = "100"
31
32pkg_postinst_${PN}_linuxstdbase () {
33 # /usr/lib/sendmail is required by LSB specification
34 [ ! -L $D/usr/lib/sendmail ] && ln -sf ${sbindir}/sendmail $D/usr/lib
35}