summaryrefslogtreecommitdiffstats
path: root/recipes-extended/gawk/gawk_3.1.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/gawk/gawk_3.1.5.bb')
-rw-r--r--recipes-extended/gawk/gawk_3.1.5.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes-extended/gawk/gawk_3.1.5.bb b/recipes-extended/gawk/gawk_3.1.5.bb
new file mode 100644
index 0000000..63fd32f
--- /dev/null
+++ b/recipes-extended/gawk/gawk_3.1.5.bb
@@ -0,0 +1,44 @@
1SUMMARY = "GNU awk text processing utility"
2DESCRIPTION = "The GNU version of awk, a text processing utility. \
3Awk interprets a special-purpose programming language to do \
4quick and easy text pattern matching and reformatting jobs."
5HOMEPAGE = "www.gnu.org/software/gawk"
6BUGTRACKER = "bug-gawk@gnu.org"
7SECTION = "console/utils"
8
9# gawk <= 3.1.5: GPLv2
10# gawk >= 3.1.6: GPLv3
11LICENSE = "GPLv2"
12LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
13
14RDEPENDS_gawk += "gawk-common"
15RDEPENDS_pgawk += "gawk-common"
16PR = "r2"
17
18SRC_URI = "\
19 ${GNU_MIRROR}/gawk/gawk-${PV}.tar.gz \
20 file://gawk-3.1.5_fix_for_automake-1.12.patch \
21 file://0001-gawk-fix-non-glibc-gcc-4-compilation.patch \
22"
23
24SRC_URI[md5sum] = "4760325489479cac17fe0114b8f62f30"
25SRC_URI[sha256sum] = "463dcb9d0ca398b1d4f5a332f6cd9cec56441265fca616f2ea1b44d459e9f0f8"
26
27inherit autotools gettext texinfo update-alternatives
28
29PACKAGES += "gawk-common pgawk"
30
31FILES_${PN} = "${bindir}/gawk* ${bindir}/igawk"
32FILES_gawk-common += "${datadir}/awk/* ${libexecdir}/awk/*"
33FILES_pgawk = "${bindir}/pgawk*"
34
35ALTERNATIVE_${PN} = "awk"
36ALTERNATIVE_TARGET[awk] = "${bindir}/gawk"
37ALTERNATIVE_PRIORITY = "100"
38
39CFLAGS += "-D PROTOTYPES"
40
41do_install_append() {
42 # remove the link since we don't package it
43 rm ${D}${bindir}/awk
44}