summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-08-18 05:29:42 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-18 23:58:48 +0100
commit5396115fe36e0c88b65f0b0770569ff65793dd45 (patch)
tree27f46aff43d350a03d5cb30630904182d23f73fc /recipes-extended
parentcc59f9faa713cee1518538fc5a9d8c6b54945911 (diff)
downloadmeta-gplv2-5396115fe36e0c88b65f0b0770569ff65793dd45.tar.gz
Revert "mc: Drop from meta-gplv2 as incompatible with newer ncurses versions"
This reverts commit ec80d2cac67a952b06ed27fbd4d71f17641e9a7c. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/mc/mc/mc-CTRL.patch31
-rw-r--r--recipes-extended/mc/mc_4.7.5.2.bb47
2 files changed, 78 insertions, 0 deletions
diff --git a/recipes-extended/mc/mc/mc-CTRL.patch b/recipes-extended/mc/mc/mc-CTRL.patch
new file mode 100644
index 0000000..ee4ba9f
--- /dev/null
+++ b/recipes-extended/mc/mc/mc-CTRL.patch
@@ -0,0 +1,31 @@
1Fix build with musl by ensuring CTRL is defined.
2
3musl does not define CTRL in <termios.h>, we could include <sys/ttydefaults.h>
4explicitly but it's easier just to ensure CTRL is defined.
5
6This patch is taken from Sabotage Linux, the license statement for patches and
7build scripts in Sabotage Linux says:
8
9 To the extent possible under law, Christian Neukirchen has waived
10 all copyright and related or neighboring rights to this work.
11
12 http://creativecommons.org/publicdomain/zero/1.0/
13
14Therefore this should be good to include in OpenEmbedded.
15
16Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
17
18Upstream-Status: Accepted (should be included in v4.8.14)
19
20diff -u mc-4.8.1.7.org/lib/tty/tty-ncurses.c mc-4.8.1.7/lib/tty/tty-ncurses.c
21--- mc-4.8.1.7.org/lib/tty/tty-ncurses.c
22+++ mc-4.8.1.7/lib/tty/tty-ncurses.c
23@@ -65,7 +65,7 @@
24
25 /*** file scope macro definitions ****************************************************************/
26
27-#if defined(_AIX) && !defined(CTRL)
28+#if !defined(CTRL)
29 #define CTRL(x) ((x) & 0x1f)
30 #endif
31
diff --git a/recipes-extended/mc/mc_4.7.5.2.bb b/recipes-extended/mc/mc_4.7.5.2.bb
new file mode 100644
index 0000000..b38964d
--- /dev/null
+++ b/recipes-extended/mc/mc_4.7.5.2.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Midnight Commander is an ncurses based file manager"
2HOMEPAGE = "http://www.midnight-commander.org/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
5SECTION = "console/utils"
6DEPENDS = "ncurses glib-2.0"
7RDEPENDS_${PN} = "ncurses-terminfo"
8
9PR = "r3"
10
11SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
12 file://mc-CTRL.patch \
13 "
14
15SRC_URI[md5sum] = "bdae966244496cd4f6d282d80c9cf3c6"
16SRC_URI[sha256sum] = "a68338862bb30017eb65ed569a58e80ab66ae8cef11c886440c9e9f4d1efc6ab"
17
18inherit autotools gettext pkgconfig
19
20EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --without-samba"
21
22do_install_append () {
23 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
24 sed -i -e '1s,#!.*python,#!${bindir}/env python,' ${D}${libexecdir}/mc/extfs.d/*
25}
26
27PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers-python ${BPN}-helpers ${BPN}-fish"
28
29SUMMARY_${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
30FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
31 ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
32 ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
33 ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
34 ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
35 ${libexecdir}/mc/extfs.d/uzip"
36RDEPENDS_${BPN}-helpers-perl = "perl"
37
38SUMMARY_${BPN}-helpers-python = "Midnight Commander Python-based helper scripts"
39FILES_${BPN}-helpers-python = "${libexecdir}/mc/extfs.d/s3+ ${libexecdir}/mc/extfs.d/uc1541"
40RDEPENDS_${BPN}-helpers-python = "python"
41
42SUMMARY_${BPN}-helpers = "Midnight Commander shell helper scripts"
43FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
44
45SUMMARY_${BPN}-fish = "Midnight Commander Fish scripts"
46FILES_${BPN}-fish = "${libexecdir}/mc/fish"
47