summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-06-29 22:50:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-03 23:05:31 +0100
commit914de841682af20da0e9f739df0cefe73d10ce3f (patch)
treed79320dca76ce2686a25056c05b3d0fabb70f088 /recipes-core
parent1ee1a73070d91e0c727f9d0db11943a61765c8d9 (diff)
downloadmeta-gplv2-914de841682af20da0e9f739df0cefe73d10ce3f.tar.gz
coreutils_6.9.bb: Fix build with glibc 2.34
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/coreutils/coreutils-6.9/0001-sort.c-Reorder-includes-for-glibc-2.34-portability.patch39
-rw-r--r--recipes-core/coreutils/coreutils_6.9.bb1
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-core/coreutils/coreutils-6.9/0001-sort.c-Reorder-includes-for-glibc-2.34-portability.patch b/recipes-core/coreutils/coreutils-6.9/0001-sort.c-Reorder-includes-for-glibc-2.34-portability.patch
new file mode 100644
index 0000000..0d9b5e2
--- /dev/null
+++ b/recipes-core/coreutils/coreutils-6.9/0001-sort.c-Reorder-includes-for-glibc-2.34-portability.patch
@@ -0,0 +1,39 @@
1From e241a55767c4eaac7d14c412d880037cb6d2ee33 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 29 Jun 2021 22:43:16 -0700
4Subject: [PATCH] sort.c: Reorder includes for glibc 2.34 portability
5
6With glibc 2.34 config.h will include stdlib.h and that would disable
7sys/wait.h to include needed definitions from bits/waitflags.h since
8_STDLIB_H would have been defined already and sys/wait.h would think
9these paths are included already, this is fixed with newer gnulib and
10configure so this is to get this old version to compile with latest
11glibc headers
12
13Upstream-Status: Inappropriate [OE-Specific]
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 src/sort.c | 4 ++--
17 1 file changed, 2 insertions(+), 2 deletions(-)
18
19diff --git a/src/sort.c b/src/sort.c
20index 58ca66a..48b22c8 100644
21--- a/src/sort.c
22+++ b/src/sort.c
23@@ -21,11 +21,11 @@
24
25 Ørn E. Hansen added NLS support in 1997. */
26
27+#include <sys/types.h>
28+#include <sys/wait.h>
29 #include <config.h>
30
31 #include <getopt.h>
32-#include <sys/types.h>
33-#include <sys/wait.h>
34 #include <signal.h>
35 #include "system.h"
36 #include "argmatch.h"
37--
382.32.0
39
diff --git a/recipes-core/coreutils/coreutils_6.9.bb b/recipes-core/coreutils/coreutils_6.9.bb
index 42b4f3c..69e5489 100644
--- a/recipes-core/coreutils/coreutils_6.9.bb
+++ b/recipes-core/coreutils/coreutils_6.9.bb
@@ -27,6 +27,7 @@ SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.bz2 \
27 file://no-man.patch \ 27 file://no-man.patch \
28 file://build-don-t-need-charset.alias-when-building-for-mus.patch \ 28 file://build-don-t-need-charset.alias-when-building-for-mus.patch \
29 file://no-su.patch \ 29 file://no-su.patch \
30 file://0001-sort.c-Reorder-includes-for-glibc-2.34-portability.patch \
30 " 31 "
31 32
32SRC_URI[md5sum] = "c9607d8495f16e98906e7ed2d9751a06" 33SRC_URI[md5sum] = "c9607d8495f16e98906e7ed2d9751a06"