summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndr? Draszik <git@andred.net>2020-01-06 10:19:34 +0000
committerRoss Burton <ross.burton@intel.com>2020-01-07 12:55:15 +0000
commite3979dcefbf3f4ef7a489ea932b1cccd1c68e7be (patch)
tree605d1f449554c5af74200bba81def77d57cccb8a
parent1e8d51d0363fde36b97cd7d68d07d67d411630b9 (diff)
downloadmeta-gplv2-e3979dcefbf3f4ef7a489ea932b1cccd1c68e7be.tar.gz
grep: fix builds with gettext 0.20.x (musl)
Update patch to also AC_CHECK_FUNCS([setlocale]). Various #include <locale.h> are guarded by the outcome of that, and otherwise compilation fails, e.g.: | ../../grep-2.5.1a/src/dfa.c:1366:34: error: 'LC_COLLATE' undeclared (first use in this function); did you mean 'REG_ECOLLATE'? | 1366 | hard_LC_COLLATE = hard_locale (LC_COLLATE); | | ^~~~~~~~~~ | | REG_ECOLLATE It appears that this test used to be triggered by (implied with) the old gettext version, but now it isn't. Signed-off-by: André Draszik <git@andred.net> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--recipes-extended/grep/grep-2.5.1a/0001-Fix-builds-with-gettext-0.20.patch35
1 files changed, 30 insertions, 5 deletions
diff --git a/recipes-extended/grep/grep-2.5.1a/0001-Fix-builds-with-gettext-0.20.patch b/recipes-extended/grep/grep-2.5.1a/0001-Fix-builds-with-gettext-0.20.patch
index a8042eb..ee9a6b1 100644
--- a/recipes-extended/grep/grep-2.5.1a/0001-Fix-builds-with-gettext-0.20.patch
+++ b/recipes-extended/grep/grep-2.5.1a/0001-Fix-builds-with-gettext-0.20.patch
@@ -1,14 +1,27 @@
1From e11be23d694c8bd4e62252874d163d06b6de3117 Mon Sep 17 00:00:00 2001 1From cd814b2203a1b5e71eaf97c3b9efedc94b680a19 Mon Sep 17 00:00:00 2001
2From: Alexander Kanavin <alex.kanavin@gmail.com> 2From: Alexander Kanavin <alex.kanavin@gmail.com>
3Date: Tue, 17 Dec 2019 16:46:05 +0100 3Date: Tue, 17 Dec 2019 16:46:05 +0100
4Subject: [PATCH] Fix builds with gettext 0.20 4Subject: [PATCH] Fix builds with gettext 0.20
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9André:
10Updated patch to also AC_CHECK_FUNCS([setlocale]).
11Various #include <locale.h> are guarded by the outcome of that,
12and otherwise compilation fails, e.g.:
13| ../../grep-2.5.1a/src/dfa.c:1366:34: error: 'LC_COLLATE' undeclared (first use in this function); did you mean 'REG_ECOLLATE'?
14| 1366 | hard_LC_COLLATE = hard_locale (LC_COLLATE);
15| | ^~~~~~~~~~
16| | REG_ECOLLATE
5 17
6Upstream-Status: Inappropriate [fixing an old version] 18Upstream-Status: Inappropriate [fixing an old version]
7Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> 19Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
20Signed-off-by: André Draszik <git@andred.net>
8--- 21---
9 Makefile.am | 2 +- 22 Makefile.am | 2 +-
10 configure.in | 2 +- 23 configure.in | 4 +++-
11 2 files changed, 2 insertions(+), 2 deletions(-) 24 2 files changed, 4 insertions(+), 2 deletions(-)
12 25
13diff --git a/Makefile.am b/Makefile.am 26diff --git a/Makefile.am b/Makefile.am
14index e4b58c4..a851b9d 100644 27index e4b58c4..a851b9d 100644
@@ -24,10 +37,19 @@ index e4b58c4..a851b9d 100644
24 EXTRA_DIST = TODO README README-alpha PATCHES.AC PATCHES.AM 37 EXTRA_DIST = TODO README README-alpha PATCHES.AC PATCHES.AM
25 38
26diff --git a/configure.in b/configure.in 39diff --git a/configure.in b/configure.in
27index 2fa6c71..c042a10 100644 40index 2fa6c71..e1e04ea 100644
28--- a/configure.in 41--- a/configure.in
29+++ b/configure.in 42+++ b/configure.in
30@@ -70,7 +70,7 @@ esac 43@@ -48,6 +48,8 @@ AC_FUNC_ALLOCA
44 AC_FUNC_CLOSEDIR_VOID
45 AC_FUNC_MMAP
46
47+AC_CHECK_FUNCS([setlocale])
48+
49 dnl getpagesize is checked for by AC_FUNC_MMAP.
50 AC_CHECK_FUNCS(btowc isascii memmove setmode strerror wctype mbrtowc)
51 AC_REPLACE_FUNCS(memchr stpcpy strtoul atexit fnmatch)
52@@ -70,7 +72,7 @@ esac
31 53
32 dnl I18N feature 54 dnl I18N feature
33 ALL_LINGUAS="cs de el eo es et fr gl hr id it ja ko nl no pl pt_BR ru sl sv" 55 ALL_LINGUAS="cs de el eo es et fr gl hr id it ja ko nl no pl pt_BR ru sl sv"
@@ -36,3 +58,6 @@ index 2fa6c71..c042a10 100644
36 58
37 dnl DOS file name convention 59 dnl DOS file name convention
38 dnl sets HAVE_DOS_FILE_NAMES 60 dnl sets HAVE_DOS_FILE_NAMES
61--
622.23.0.rc1
63