diff options
author | Joakim Roubert <joakimr@axis.com> | 2019-09-18 08:37:04 +0200 |
---|---|---|
committer | Peter Kjellerstedt <pkj@axis.com> | 2019-09-18 17:34:57 +0200 |
commit | ac59327ce77d41264509af07b6b9923346643e38 (patch) | |
tree | 39e6b75c4113ec1cae07c8718b79e7afad111b7e | |
parent | 460ba027fd79b99151f95c826446f3aead5d17ff (diff) | |
download | meta-gplv2-ac59327ce77d41264509af07b6b9923346643e38.tar.gz |
tar: Make it build with GCC 8.3
This avoids the following error:
lib/argp-parse.c: In function 'argp_version_parser':
lib/argp-parse.c:158:2: error: format not a string literal and no
format arguments [-Werror=format-security]
__argp_error (state, dgettext (state->root_argp->argp_domain,
^~~~~~~~~~~~
Signed-off-by: Joakim Roubert <joakim.roubert@axis.com>
Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
-rw-r--r-- | recipes-extended/tar/tar/0001-lib-argp-parse.c-Fix-compiler-error.patch | 34 | ||||
-rw-r--r-- | recipes-extended/tar/tar_1.17.bb | 1 |
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes-extended/tar/tar/0001-lib-argp-parse.c-Fix-compiler-error.patch b/recipes-extended/tar/tar/0001-lib-argp-parse.c-Fix-compiler-error.patch new file mode 100644 index 0000000..3de9fd1 --- /dev/null +++ b/recipes-extended/tar/tar/0001-lib-argp-parse.c-Fix-compiler-error.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 153c0aab9e2a4a97b1a2c6b530594cd9a211e9ec Mon Sep 17 00:00:00 2001 | ||
2 | From: Joakim Roubert <joakimr@axis.com> | ||
3 | Date: Thu, 6 Dec 2018 10:33:14 +0100 | ||
4 | Subject: [PATCH] lib/argp-parse.c: Fix compiler error | ||
5 | |||
6 | This avoids the following error: | ||
7 | |||
8 | lib/argp-parse.c: In function 'argp_version_parser': | ||
9 | lib/argp-parse.c:158:2: error: format not a string literal and no | ||
10 | format arguments [-Werror=format-security] | ||
11 | __argp_error (state, dgettext (state->root_argp->argp_domain, | ||
12 | ^~~~~~~~~~~~ | ||
13 | |||
14 | Signed-off-by: Joakim Roubert <joakim.roubert@axis.com> | ||
15 | --- | ||
16 | lib/argp-parse.c | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/lib/argp-parse.c b/lib/argp-parse.c | ||
20 | index a7de729..09511ba 100644 | ||
21 | --- a/lib/argp-parse.c | ||
22 | +++ b/lib/argp-parse.c | ||
23 | @@ -155,7 +155,7 @@ argp_version_parser (int key, char *arg, struct argp_state *state) | ||
24 | else if (argp_program_version) | ||
25 | fprintf (state->out_stream, "%s\n", argp_program_version); | ||
26 | else | ||
27 | - __argp_error (state, dgettext (state->root_argp->argp_domain, | ||
28 | + __argp_error (state, "%s", dgettext (state->root_argp->argp_domain, | ||
29 | "(PROGRAM ERROR) No version known!?")); | ||
30 | if (! (state->flags & ARGP_NO_EXIT)) | ||
31 | exit (0); | ||
32 | -- | ||
33 | 2.11.0 | ||
34 | |||
diff --git a/recipes-extended/tar/tar_1.17.bb b/recipes-extended/tar/tar_1.17.bb index b9ca206..1ee5e34 100644 --- a/recipes-extended/tar/tar_1.17.bb +++ b/recipes-extended/tar/tar_1.17.bb | |||
@@ -8,6 +8,7 @@ PR = "r3" | |||
8 | SRC_URI += "file://m4extensions.patch \ | 8 | SRC_URI += "file://m4extensions.patch \ |
9 | file://gcc43build.patch \ | 9 | file://gcc43build.patch \ |
10 | file://avoid_heap_overflow.patch \ | 10 | file://avoid_heap_overflow.patch \ |
11 | file://0001-lib-argp-parse.c-Fix-compiler-error.patch \ | ||
11 | " | 12 | " |
12 | 13 | ||
13 | SRC_URI[md5sum] = "c6c4f1c075dbf0f75c29737faa58f290" | 14 | SRC_URI[md5sum] = "c6c4f1c075dbf0f75c29737faa58f290" |