summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWes Lindauer <wesley.lindauer@gmail.com>2018-11-14 17:32:33 -0500
committerRoss Burton <ross.burton@intel.com>2018-11-15 17:36:38 +0000
commit8975a6d34736cd98788a8393c3fad92c500428d9 (patch)
tree7dac2accd2015f8c2112d08ed025cbf697b5a188
parent379ea8dd144b06aeb459e9a82c792c84d8a5baf7 (diff)
downloadmeta-gplv2-8975a6d34736cd98788a8393c3fad92c500428d9.tar.gz
grep: fix install if bindir == base_bindir
This same fix was made to the grep recipe in poky at hash 5f137933c05646dee685d7846cba875ae74064cd. Not everyone gets the luxury of using GPLv3 code, so the same fix needs to be applied to the GPLv2 version. Signed-off-by: Wes Lindauer <wesley.lindauer@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--recipes-extended/grep/grep_2.5.1a.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/recipes-extended/grep/grep_2.5.1a.bb b/recipes-extended/grep/grep_2.5.1a.bb
index 97ca768..b331fee 100644
--- a/recipes-extended/grep/grep_2.5.1a.bb
+++ b/recipes-extended/grep/grep_2.5.1a.bb
@@ -38,11 +38,13 @@ do_configure_prepend () {
38 38
39do_install () { 39do_install () {
40 autotools_do_install 40 autotools_do_install
41 install -d ${D}${base_bindir} 41 if [ "${base_bindir}" != "${bindir}" ]; then
42 mv ${D}${bindir}/grep ${D}${base_bindir}/grep 42 install -d ${D}${base_bindir}
43 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep 43 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
44 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep 44 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
45 rmdir ${D}${bindir}/ 45 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
46 rmdir ${D}${bindir}/
47 fi
46} 48}
47 49
48inherit update-alternatives 50inherit update-alternatives