summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <jpewhacker@gmail.com>2019-07-02 10:51:05 -0500
committerRoss Burton <ross.burton@intel.com>2019-07-15 18:51:16 +0100
commit1e2480e50f34e55bdfd5e06f98441e03a3752d5a (patch)
tree5a907ce633f8f1e92d4730892a65ed33baf791fa
parent43668442f8ee8e7ceaad1e672a8032b651d9d2a9 (diff)
downloadmeta-gplv2-1e2480e50f34e55bdfd5e06f98441e03a3752d5a.tar.gz
gnupg: Enable native build support2.8_M32.8_M2
Adds support for building gnupg as a -native recipe. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--recipes-support/gnupg/gnupg_1.4.7.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-support/gnupg/gnupg_1.4.7.bb b/recipes-support/gnupg/gnupg_1.4.7.bb
index 85636ab..a7fbd11 100644
--- a/recipes-support/gnupg/gnupg_1.4.7.bb
+++ b/recipes-support/gnupg/gnupg_1.4.7.bb
@@ -84,6 +84,7 @@ EXTRA_OECONF = "--disable-ldap \
84 " 84 "
85 85
86# Force gcc's traditional handling of inline to avoid issues with gcc 5 86# Force gcc's traditional handling of inline to avoid issues with gcc 5
87BUILD_CFLAGS += "-fgnu89-inline"
87CFLAGS += "-fgnu89-inline" 88CFLAGS += "-fgnu89-inline"
88 89
89do_install () { 90do_install () {
@@ -95,6 +96,8 @@ do_install () {
95 96
96# split out gpgv from main package 97# split out gpgv from main package
97RDEPENDS_${PN} = "gpgv" 98RDEPENDS_${PN} = "gpgv"
99RDEPENDS_${PN}_class-native = ""
100
98PACKAGES =+ "gpgv" 101PACKAGES =+ "gpgv"
99FILES_gpgv = "${bindir}/gpgv" 102FILES_gpgv = "${bindir}/gpgv"
100 103
@@ -104,3 +107,5 @@ FILES_${PN} = "${bindir}/* ${datadir}/${BPN} ${libexecdir}/${BPN}/*"
104PACKAGECONFIG ??= "" 107PACKAGECONFIG ??= ""
105PACKAGECONFIG[curl] = "--with-libcurl=${STAGING_LIBDIR},--without-libcurl,curl" 108PACKAGECONFIG[curl] = "--with-libcurl=${STAGING_LIBDIR},--without-libcurl,curl"
106PACKAGECONFIG[libusb] = "--with-libusb=${STAGING_LIBDIR},--without-libusb,libusb-compat" 109PACKAGECONFIG[libusb] = "--with-libusb=${STAGING_LIBDIR},--without-libusb,libusb-compat"
110
111BBCLASSEXTEND += "native"