summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/u-boot/u-boot_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/u-boot/u-boot_git.bb')
-rw-r--r--recipes-kernel/u-boot/u-boot_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/recipes-kernel/u-boot/u-boot_git.bb b/recipes-kernel/u-boot/u-boot_git.bb
index 3d42aa8..fbb99bc 100644
--- a/recipes-kernel/u-boot/u-boot_git.bb
+++ b/recipes-kernel/u-boot/u-boot_git.bb
@@ -5,7 +5,7 @@ PROVIDES = "virtual/bootloader"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" 6LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
7 7
8PR = "r16" 8PR = "r17"
9INHIBIT_DEFAULT_DEPS = "1" 9INHIBIT_DEFAULT_DEPS = "1"
10DEPENDS = "boot-format-native virtual/${TARGET_PREFIX}gcc" 10DEPENDS = "boot-format-native virtual/${TARGET_PREFIX}gcc"
11 11
@@ -49,13 +49,14 @@ do_compile () {
49 esac 49 esac
50 50
51 if [ "x${UBOOT_TARGET}" != "x" ]; then 51 if [ "x${UBOOT_TARGET}" != "x" ]; then
52 if [ "${MACHINE_ARCH}" == "p1023rds" ] || \ 52 if [ "${UBOOT_TARGET}" == "u-boot-nand" ]; then
53 :
54 elif [ "${MACHINE_ARCH}" == "p1023rds" ] || \
53 [ "${MACHINE_ARCH}" == "p2041rdb" ] || \ 55 [ "${MACHINE_ARCH}" == "p2041rdb" ] || \
54 [ "${MACHINE_ARCH}" == "p3041ds" ] || \ 56 [ "${MACHINE_ARCH}" == "p3041ds" ] || \
55 [ "${MACHINE_ARCH}" == "p4080ds" ] || \ 57 [ "${MACHINE_ARCH}" == "p4080ds" ] || \
56 [ "${MACHINE_ARCH}" == "p5020ds" ] || \ 58 [ "${MACHINE_ARCH}" == "p5020ds" ] || \
57 [ "${UBOOT_TARGET}" == "u-boot-sd" ] || \ 59 [ "${UBOOT_TARGET}" == "u-boot-sd" ]; then
58 [ "${UBOOT_TARGET}" == "u-boot-nand" ]; then
59 cp ${S}/${board}/u-boot.bin ${S}/${board}/${UBOOT_TARGET}.bin 60 cp ${S}/${board}/u-boot.bin ${S}/${board}/${UBOOT_TARGET}.bin
60 else 61 else
61 ${STAGING_BINDIR_NATIVE}/boot_format \ 62 ${STAGING_BINDIR_NATIVE}/boot_format \