summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/skmm/skmm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/skmm/skmm_git.bb')
-rw-r--r--recipes-kernel/skmm/skmm_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-kernel/skmm/skmm_git.bb b/recipes-kernel/skmm/skmm_git.bb
new file mode 100644
index 0000000..224e556
--- /dev/null
+++ b/recipes-kernel/skmm/skmm_git.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "SKMM application for PCIe endpoint"
2SECTION = "skmm"
3LICENSE = "BSD & GPLv2"
4LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=39e58bedc879163c9338596e52df5b1f"
5
6DEPENDS = "libedit"
7
8SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-ep.git"
9SRCREV = "80d8393a2033b3b0cc8f885702d7b288956f3a37"
10
11COMPATIBLE_MACHINE = "(p4080ds|t4240qds)"
12
13S = "${WORKDIR}/git"
14
15EXTRA_OEMAKE = 'MACHINE=${MACHINE}'
16
17export LIBEDIT_CFLAGS="$(pkg-config --cflags libedit)"
18export LIBEDIT_LDFLAGS="$(pkg-config --libs --static libedit)"
19
20do_compile () {
21 export ARCH=${TARGET_ARCH}
22 oe_runmake HOST=x86_64 clean
23 oe_runmake HOST=x86_64
24 oe_runmake HOST=powerpc clean
25 oe_runmake HOST=powerpc
26}
27
28do_install () {
29 oe_runmake ARCH=${TARGET_ARCH} HOST=x86_64 install DESTDIR=${D}
30 oe_runmake ARCH=${TARGET_ARCH} HOST=powerpc install DESTDIR=${D}
31}
32
33FILES_${PN} += "/home/root/.skmm/*"