summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qoriq_3.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq_3.12.bb')
-rw-r--r--recipes-kernel/linux/linux-qoriq_3.12.bb51
1 files changed, 50 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_3.12.bb b/recipes-kernel/linux/linux-qoriq_3.12.bb
index 744aa4e..533225d 100644
--- a/recipes-kernel/linux/linux-qoriq_3.12.bb
+++ b/recipes-kernel/linux/linux-qoriq_3.12.bb
@@ -1,4 +1,10 @@
1require recipes-kernel/linux/linux-qoriq.inc 1inherit kernel kernel-arch qoriq_build_64bit_kernel
2require recipes-kernel/linux/linux-dtb.inc
3
4DESCRIPTION = "Linux kernel for Freescale platforms"
5SECTION = "kernel"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
2 8
3SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;branch=sdk-v1.9.x \ 9SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;branch=sdk-v1.9.x \
4 file://modify-defconfig-t1040-nr-cpus.patch \ 10 file://modify-defconfig-t1040-nr-cpus.patch \
@@ -8,3 +14,46 @@ SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;branch=sdk-v1.9.x \
8 file://module-remove-MODULE_GENERIC_TABLE.patch \ 14 file://module-remove-MODULE_GENERIC_TABLE.patch \
9" 15"
10SRCREV = "43cecda943a6c40a833b588801b0929e8bd48813" 16SRCREV = "43cecda943a6c40a833b588801b0929e8bd48813"
17
18KSRC ?= ""
19S = '${@base_conditional("KSRC", "", "${WORKDIR}/git", "${KSRC}", d)}'
20
21DEPENDS_append = " libgcc"
22# not put Images into /boot of rootfs, install kernel-image if needed
23RDEPENDS_kernel-base = ""
24
25KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}"
26KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}"
27
28SCMVERSION ?= "y"
29DELTA_KERNEL_DEFCONFIG ?= ""
30do_configure_prepend() {
31 # copy desired defconfig so we pick it up for the real kernel_do_configure
32 cp ${KERNEL_DEFCONFIG} ${B}/.config
33
34 # add config fragments
35 for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do
36 if [ -f "${deltacfg}" ]; then
37 ${S}/scripts/kconfig/merge_config.sh -m .config ${deltacfg}
38 elif [ -f "${WORKDIR}/${deltacfg}" ]; then
39 ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg}
40 elif [ -f "${S}/arch/${ARCH}/configs/${deltacfg}" ]; then
41 ${S}/scripts/kconfig/merge_config.sh -m .config \
42 ${S}/arch/powerpc/configs/${deltacfg}
43 fi
44 done
45
46 #add git revision to the local version
47 if [ "${SCMVERSION}" = "y" ]; then
48 # append sdk version if SDK_VERSION is defined
49 sdkversion=''
50 if [ -n "${SDK_VERSION}" ]; then
51 sdkversion="-${SDK_VERSION}"
52 fi
53 head=`git --git-dir=${S}/.git rev-parse --verify --short HEAD 2> /dev/null`
54 printf "%s%s%s" $sdkversion +g $head > ${B}/.scmversion
55 fi
56}
57
58# make everything compatible for the time being
59COMPATIBLE_MACHINE_$MACHINE = "$MACHINE"