summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/sdk_patches/0043-add-install-target-for-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/cryptodev/sdk_patches/0043-add-install-target-for-tests.patch')
-rw-r--r--recipes-kernel/cryptodev/sdk_patches/0043-add-install-target-for-tests.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/sdk_patches/0043-add-install-target-for-tests.patch b/recipes-kernel/cryptodev/sdk_patches/0043-add-install-target-for-tests.patch
new file mode 100644
index 0000000..f3b7022
--- /dev/null
+++ b/recipes-kernel/cryptodev/sdk_patches/0043-add-install-target-for-tests.patch
@@ -0,0 +1,46 @@
1From 44629033d47543d106299b6c8bed9e5c9fed1513 Mon Sep 17 00:00:00 2001
2From: Cristian Stoica <cristian.stoica@nxp.com>
3Date: Thu, 11 Feb 2016 16:48:53 +0200
4Subject: [PATCH 43/43] add install target for tests
5
6Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
7---
8 tests/Makefile | 12 +++++++++++-
9 1 file changed, 11 insertions(+), 1 deletion(-)
10
11diff --git a/tests/Makefile b/tests/Makefile
12index 89f88fe..5e3111d 100644
13--- a/tests/Makefile
14+++ b/tests/Makefile
15@@ -19,6 +19,10 @@ example-async-hmac-objs := async_hmac.o
16 example-async-speed-objs := async_speed.o
17 example-hashcrypt-speed-objs := hashcrypt_speed.c
18
19+prefix ?= /usr/local
20+execprefix ?= $(prefix)
21+bindir = $(execprefix)/bin
22+
23 all: $(hostprogs)
24
25 check: $(hostprogs)
26@@ -30,10 +34,16 @@ check: $(hostprogs)
27 ./cipher-gcm
28 ./cipher-aead
29
30+install:
31+ install -d $(DESTDIR)/$(bindir)
32+ for prog in $(hostprogs); do \
33+ install -m 755 $$prog $(DESTDIR)/$(bindir); \
34+ done
35+
36 clean:
37 rm -f *.o *~ $(hostprogs)
38
39 ${comp_progs}: LDLIBS += -lssl -lcrypto
40 ${comp_progs}: %: %.o openssl_wrapper.o
41
42-.PHONY: all clean check
43+.PHONY: all clean check install
44--
452.7.0
46