summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/sdk_patches/0041-add-separate-target-for-building-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/cryptodev/sdk_patches/0041-add-separate-target-for-building-tests.patch')
-rw-r--r--recipes-kernel/cryptodev/sdk_patches/0041-add-separate-target-for-building-tests.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/sdk_patches/0041-add-separate-target-for-building-tests.patch b/recipes-kernel/cryptodev/sdk_patches/0041-add-separate-target-for-building-tests.patch
new file mode 100644
index 0000000..ff73825
--- /dev/null
+++ b/recipes-kernel/cryptodev/sdk_patches/0041-add-separate-target-for-building-tests.patch
@@ -0,0 +1,38 @@
1From 0d58530f5c5970db9787a23aef4227c68f941fcc Mon Sep 17 00:00:00 2001
2From: Cristian Stoica <cristian.stoica@nxp.com>
3Date: Wed, 10 Feb 2016 16:22:05 +0200
4Subject: [PATCH 41/43] add separate target for building tests
5
6A separate target for build is useful with cross-compilation. In this
7case it makes sense to build the tests without running them on the host
8machine.
9
10The default target is now 'all' and only builds the tests
11
12Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
13---
14 tests/Makefile | 4 ++++
15 1 file changed, 4 insertions(+)
16
17diff --git a/tests/Makefile b/tests/Makefile
18index 3155da9..89f88fe 100644
19--- a/tests/Makefile
20+++ b/tests/Makefile
21@@ -19,6 +19,8 @@ example-async-hmac-objs := async_hmac.o
22 example-async-speed-objs := async_speed.o
23 example-hashcrypt-speed-objs := hashcrypt_speed.c
24
25+all: $(hostprogs)
26+
27 check: $(hostprogs)
28 ./cipher
29 ./hmac
30@@ -33,3 +35,5 @@ clean:
31
32 ${comp_progs}: LDLIBS += -lssl -lcrypto
33 ${comp_progs}: %: %.o openssl_wrapper.o
34+
35+.PHONY: all clean check
36--
372.7.0
38