summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/sdk_patches/0028-for-consistency-use-.-instead-of-.-in-makefiles.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/cryptodev/sdk_patches/0028-for-consistency-use-.-instead-of-.-in-makefiles.patch')
-rw-r--r--recipes-kernel/cryptodev/sdk_patches/0028-for-consistency-use-.-instead-of-.-in-makefiles.patch73
1 files changed, 73 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/sdk_patches/0028-for-consistency-use-.-instead-of-.-in-makefiles.patch b/recipes-kernel/cryptodev/sdk_patches/0028-for-consistency-use-.-instead-of-.-in-makefiles.patch
new file mode 100644
index 0000000..756ca33
--- /dev/null
+++ b/recipes-kernel/cryptodev/sdk_patches/0028-for-consistency-use-.-instead-of-.-in-makefiles.patch
@@ -0,0 +1,73 @@
1From 22b63631de17507c12355c30e408dbd88350bb3a Mon Sep 17 00:00:00 2001
2From: Cristian Stoica <cristian.stoica@nxp.com>
3Date: Thu, 10 Dec 2015 12:42:20 +0200
4Subject: [PATCH 28/38] for consistency, use $(...) instead of ${...} in
5 makefiles
6
7Both syntax rules are equaly valid and mixing them is permitted but
8looks inconsistent.
9
10See section "6.1 Basics of Variable References" of GNU make manual
11
12Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
13---
14 Makefile | 16 ++++++++--------
15 tests/Makefile | 2 +-
16 2 files changed, 9 insertions(+), 9 deletions(-)
17
18diff --git a/Makefile b/Makefile
19index 7c7e193..7f8df37 100644
20--- a/Makefile
21+++ b/Makefile
22@@ -14,11 +14,11 @@ cryptodev-objs = ioctl.o main.o cryptlib.o authenc.o zc.o util.o
23 obj-m += cryptodev.o
24
25 KERNEL_MAKE_OPTS := -C $(KERNEL_DIR) M=$(PWD)
26-ifneq (${ARCH},)
27-KERNEL_MAKE_OPTS += ARCH=${ARCH}
28+ifneq ($(ARCH),)
29+KERNEL_MAKE_OPTS += ARCH=$(ARCH)
30 endif
31-ifneq (${CROSS_COMPILE},)
32-KERNEL_MAKE_OPTS += CROSS_COMPILE=${CROSS_COMPILE}
33+ifneq ($(CROSS_COMPILE),)
34+KERNEL_MAKE_OPTS += CROSS_COMPILE=$(CROSS_COMPILE)
35 endif
36
37 build: version.h
38@@ -43,15 +43,15 @@ check:
39 CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests check
40
41 CPOPTS =
42-ifneq (${SHOW_TYPES},)
43+ifneq ($(SHOW_TYPES),)
44 CPOPTS += --show-types
45 endif
46-ifneq (${IGNORE_TYPES},)
47-CPOPTS += --ignore ${IGNORE_TYPES}
48+ifneq ($(IGNORE_TYPES),)
49+CPOPTS += --ignore $(IGNORE_TYPES)
50 endif
51
52 checkpatch:
53- $(KERNEL_DIR)/scripts/checkpatch.pl ${CPOPTS} --file *.c *.h
54+ $(KERNEL_DIR)/scripts/checkpatch.pl $(CPOPTS) --file *.c *.h
55
56 VERSIONTAG = refs/tags/cryptodev-linux-$(VERSION)
57 FILEBASE = cryptodev-linux-$(VERSION)
58diff --git a/tests/Makefile b/tests/Makefile
59index 20c52ba..3155da9 100644
60--- a/tests/Makefile
61+++ b/tests/Makefile
62@@ -6,7 +6,7 @@ comp_progs := cipher_comp hash_comp hmac_comp
63
64 hostprogs := cipher cipher-aead hmac speed async_cipher async_hmac \
65 async_speed sha_speed hashcrypt_speed fullspeed cipher-gcm \
66- cipher-aead-srtp ${comp_progs}
67+ cipher-aead-srtp $(comp_progs)
68
69 example-cipher-objs := cipher.o
70 example-cipher-aead-objs := cipher-aead.o
71--
722.7.0
73