summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/sdk_patches/0026-fix-Makefile-to-allow-parallel-make-with-j-option.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/cryptodev/sdk_patches/0026-fix-Makefile-to-allow-parallel-make-with-j-option.patch')
-rw-r--r--recipes-kernel/cryptodev/sdk_patches/0026-fix-Makefile-to-allow-parallel-make-with-j-option.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/sdk_patches/0026-fix-Makefile-to-allow-parallel-make-with-j-option.patch b/recipes-kernel/cryptodev/sdk_patches/0026-fix-Makefile-to-allow-parallel-make-with-j-option.patch
new file mode 100644
index 0000000..b8cf4e1
--- /dev/null
+++ b/recipes-kernel/cryptodev/sdk_patches/0026-fix-Makefile-to-allow-parallel-make-with-j-option.patch
@@ -0,0 +1,56 @@
1From d96ae48c87f80af1a202c2d2e837bf477edc0fb7 Mon Sep 17 00:00:00 2001
2From: Cristian Stoica <cristian.stoica@nxp.com>
3Date: Thu, 10 Dec 2015 12:42:18 +0200
4Subject: [PATCH 26/38] fix Makefile to allow parallel make with -j option
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Recursive make commands should always use the variable MAKE, not the
10explicit command name ‘make’
11
12Documented in section "5.7.1 How the MAKE Variable Works" of GNU Make manual
13
14Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
15---
16 Makefile | 10 +++++-----
17 1 file changed, 5 insertions(+), 5 deletions(-)
18
19diff --git a/Makefile b/Makefile
20index 9e56e9d..2f50210 100644
21--- a/Makefile
22+++ b/Makefile
23@@ -22,7 +22,7 @@ KERNEL_MAKE_OPTS += CROSS_COMPILE=${CROSS_COMPILE}
24 endif
25
26 build: version.h
27- make ${KERNEL_MAKE_OPTS} modules
28+ $(MAKE) $(KERNEL_MAKE_OPTS) modules
29
30 version.h: Makefile
31 @echo "#define VERSION \"$(VERSION)\"" > version.h
32@@ -30,17 +30,17 @@ version.h: Makefile
33 install: modules_install
34
35 modules_install:
36- make -C $(KERNEL_DIR) SUBDIRS=`pwd` modules_install
37+ $(MAKE) -C $(KERNEL_DIR) SUBDIRS=`pwd` modules_install
38 @echo "Installing cryptodev.h in $(PREFIX)/usr/include/crypto ..."
39 @install -D crypto/cryptodev.h $(PREFIX)/usr/include/crypto/cryptodev.h
40
41 clean:
42- make -C $(KERNEL_DIR) SUBDIRS=`pwd` clean
43+ $(MAKE) -C $(KERNEL_DIR) SUBDIRS=`pwd` clean
44 rm -f $(hostprogs) *~
45- CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) make -C tests clean
46+ CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests clean
47
48 check:
49- CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) make -C tests check
50+ CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests check
51
52 CPOPTS =
53 ifneq (${SHOW_TYPES},)
54--
552.7.0
56