summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/files/0004-Add-the-compile-and-install-rules-for-cryptodev-test.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/cryptodev/files/0004-Add-the-compile-and-install-rules-for-cryptodev-test.patch')
-rw-r--r--recipes-kernel/cryptodev/files/0004-Add-the-compile-and-install-rules-for-cryptodev-test.patch65
1 files changed, 0 insertions, 65 deletions
diff --git a/recipes-kernel/cryptodev/files/0004-Add-the-compile-and-install-rules-for-cryptodev-test.patch b/recipes-kernel/cryptodev/files/0004-Add-the-compile-and-install-rules-for-cryptodev-test.patch
deleted file mode 100644
index 25a52a9..0000000
--- a/recipes-kernel/cryptodev/files/0004-Add-the-compile-and-install-rules-for-cryptodev-test.patch
+++ /dev/null
@@ -1,65 +0,0 @@
1From 188f30f6233d05eb62b58bf6d94a16bcbeeae0ee Mon Sep 17 00:00:00 2001
2From: Cristian Stoica <cristian.stoica@freescale.com>
3Date: Mon, 27 Apr 2015 15:26:14 +0300
4Subject: [PATCH 4/4] Add the compile and install rules for cryptodev tests
5
6Change-Id: Ica10dc563c77220dcf0e0993515230df8a86c34d
7Signed-off-by: Yu Zongchun <b40527@freescale.com>
8---
9 Makefile | 6 ++++++
10 tests/Makefile | 8 ++++++++
11 2 files changed, 14 insertions(+)
12
13diff --git a/Makefile b/Makefile
14index 855bb54..5497037 100644
15--- a/Makefile
16+++ b/Makefile
17@@ -32,6 +32,9 @@ install: modules_install
18 modules_install:
19 make -C $(KERNEL_DIR) SUBDIRS=`pwd` modules_install
20
21+install_tests:
22+ make -C tests install DESTDIR=$(PREFIX)
23+
24 clean:
25 make -C $(KERNEL_DIR) SUBDIRS=`pwd` clean
26 rm -f $(hostprogs) *~
27@@ -40,6 +43,9 @@ clean:
28 check:
29 CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) make -C tests check
30
31+testprogs:
32+ KERNEL_DIR=$(KERNEL_DIR) make -C tests testprogs
33+
34 CPOPTS =
35 ifneq (${SHOW_TYPES},)
36 CPOPTS += --show-types
37diff --git a/tests/Makefile b/tests/Makefile
38index 20c52ba..67c3c83 100644
39--- a/tests/Makefile
40+++ b/tests/Makefile
41@@ -19,6 +19,12 @@ example-async-hmac-objs := async_hmac.o
42 example-async-speed-objs := async_speed.o
43 example-hashcrypt-speed-objs := hashcrypt_speed.c
44
45+install:
46+ install -d $(DESTDIR)/usr/bin/tests_cryptodev
47+ for bin in $(hostprogs); do \
48+ install -m 755 $${bin} $(DESTDIR)/usr/bin/tests_cryptodev/; \
49+ done
50+
51 check: $(hostprogs)
52 ./cipher
53 ./hmac
54@@ -28,6 +34,8 @@ check: $(hostprogs)
55 ./cipher-gcm
56 ./cipher-aead
57
58+testprogs: $(hostprogs)
59+
60 clean:
61 rm -f *.o *~ $(hostprogs)
62
63--
642.3.5
65