summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/files/0002-tests-Makefile-fix-arg-passing-to-CC-in-implicit-rul.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/cryptodev/files/0002-tests-Makefile-fix-arg-passing-to-CC-in-implicit-rul.patch')
-rw-r--r--recipes-kernel/cryptodev/files/0002-tests-Makefile-fix-arg-passing-to-CC-in-implicit-rul.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/recipes-kernel/cryptodev/files/0002-tests-Makefile-fix-arg-passing-to-CC-in-implicit-rul.patch b/recipes-kernel/cryptodev/files/0002-tests-Makefile-fix-arg-passing-to-CC-in-implicit-rul.patch
deleted file mode 100644
index 68c48e0..0000000
--- a/recipes-kernel/cryptodev/files/0002-tests-Makefile-fix-arg-passing-to-CC-in-implicit-rul.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From da730106c2558c8e0c8e1b1b1812d32ef9574ab7 Mon Sep 17 00:00:00 2001
2From: Phil Sutter <phil@nwl.cc>
3Date: Sat, 11 Apr 2015 12:45:05 +0200
4Subject: [PATCH 2/4] tests/Makefile: fix arg passing to CC in implicit rule
5
6GCC docs suggest passing -lfoo after object files referring to functions
7in libfoo. Therefore use LDLIBS to specify libraries, which puts them at
8the right place when make calls CC implicitly.
9
10Signed-off-by: Phil Sutter <phil@nwl.cc>
11---
12 tests/Makefile | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/tests/Makefile b/tests/Makefile
16index c9f04e8..20c52ba 100644
17--- a/tests/Makefile
18+++ b/tests/Makefile
19@@ -31,5 +31,5 @@ check: $(hostprogs)
20 clean:
21 rm -f *.o *~ $(hostprogs)
22
23-${comp_progs}: LDFLAGS += -lssl -lcrypto
24+${comp_progs}: LDLIBS += -lssl -lcrypto
25 ${comp_progs}: %: %.o openssl_wrapper.o
26--
272.3.5
28