summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb')
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb
new file mode 100644
index 0000000..18bc3c5
--- /dev/null
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb
@@ -0,0 +1,24 @@
1require cryptodev-qoriq_${PV}.inc
2
3SUMMARY = "A test suite for /dev/crypto device driver"
4
5DEPENDS += "openssl"
6
7PROVIDES += "cryptodev-tests"
8
9SRC_URI_append = " \
10file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
11"
12
13EXTRA_OEMAKE='KERNEL_DIR="${STAGING_EXECPREFIXDIR}" DESTDIR="${D}"'
14
15do_compile() {
16 oe_runmake testprogs
17}
18
19do_install() {
20 oe_runmake install_tests
21}
22
23FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug"
24FILES_${PN} = "${bindir}/tests_cryptodev/*"