summaryrefslogtreecommitdiffstats
path: root/recipes-extended/fsl-pme/fsl-pme_1.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/fsl-pme/fsl-pme_1.0.3.bb')
-rw-r--r--recipes-extended/fsl-pme/fsl-pme_1.0.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-extended/fsl-pme/fsl-pme_1.0.3.bb b/recipes-extended/fsl-pme/fsl-pme_1.0.3.bb
new file mode 100644
index 0000000..20b8163
--- /dev/null
+++ b/recipes-extended/fsl-pme/fsl-pme_1.0.3.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "User space application for Pattern Matcher"
2LICENSE = "Freescale-EULA"
3LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f"
4
5DEPENDS="libedit"
6RDEPENDS_${PN} += "bash"
7
8SRC_URI = "git://git.freescale.com/ppc/sdk/fsl-pme.git;branch=sdk-v2.0.x"
9SRCREV = "f49fb57960ff5ee649be97a9587ede88e433ea71"
10
11S = "${WORKDIR}/git"
12
13do_compile(){
14 oe_runmake SYS_PATH=${STAGING_LIBDIR}/../
15}
16
17do_install() {
18 install -d ${D}${datadir}/fsl-pme
19 install -d ${D}${base_sbindir}
20 install -d ${D}${sysconfdir}/hotplug
21 install bin/* ${D}${base_sbindir}/
22 install -m 644 sample* ${D}${datadir}/fsl-pme/
23 install -m 644 modprobe.conf ${D}${sysconfdir}
24 install -m 755 misc.agent ${D}${sysconfdir}/hotplug
25}
26
27FILES_${PN} += "${datadir}/*"
28INSANE_SKIP_${PN} += "ldflags"
29COMPATIBLE_MACHINE = "(e500v2)"