summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/qemu_fslgit.bb28
1 files changed, 13 insertions, 15 deletions
diff --git a/recipes-devtools/qemu/qemu_fslgit.bb b/recipes-devtools/qemu/qemu_fslgit.bb
index 32e738e..f977a37 100644
--- a/recipes-devtools/qemu/qemu_fslgit.bb
+++ b/recipes-devtools/qemu/qemu_fslgit.bb
@@ -3,19 +3,17 @@ require recipes-devtools/qemu/qemu.inc
3LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \ 3LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
4 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913" 4 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
5 5
6# This means QEMU v1.7 with FSL specific patches applied 6# This means QEMU v2.2.0 with FSL specific patches applied
7PV = "1.7+fsl" 7PV = "2.2.0+fsl"
8 8
9# NOTE: these options are note available in qemu 1.7, but qemu.inc assumes 9# NOTE: this recipe requires poky's qemu.inc which assumes version 2.3
10# version 2.0+ where they are available. For now we unset them, but we should 10# where glx enable config option changed to --enable-opengl. For now we
11# remove the following lines when upgrading to qemu 2.0+: 11# restore it, but we should remove the following lines when upgrading
12PACKAGECONFIG[quorum] = "" 12# to qemu 2.3:
13PACKAGECONFIG[lzo] = "" 13PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,mesa"
14PACKAGECONFIG[numa] = ""
15PACKAGECONFIG[gtk+] = ""
16 14
17SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;nobranch=1" 15SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=master"
18SRCREV = "6ac4597c059d35e2737b234747243e56d340f4db" 16SRCREV = "00ac004143e9fe46944a1885b04268fcd3a95a3a"
19 17
20S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
21 19
@@ -29,20 +27,20 @@ EXTRA_OECONF_e500v2 = "--target-list=ppc-softmmu ${PPC_OECONF}"
29EXTRA_OECONF_e500mc = "--target-list=ppc-softmmu ${PPC_OECONF}" 27EXTRA_OECONF_e500mc = "--target-list=ppc-softmmu ${PPC_OECONF}"
30 28
31do_configure_prepend() { 29do_configure_prepend() {
32 export PKG_CONFIG=${STAGING_DIR_NATIVE}${bindir_native}/pkg-config 30 export PKG_CONFIG=${STAGING_DIR_NATIVE}${bindir_native}/pkg-config
33} 31}
34 32
35do_configure_append () { 33do_configure_append () {
36 grep 'CONFIG_FDT=y' config-host.mak 34 grep 'CONFIG_FDT=y' config-host.mak
37} 35}
38 36
39# gets around qemu.inc trying to install powerpc_rom.bin 37# gets around qemu.inc trying to install powerpc_rom.bin
40do_install_prepend() { 38do_install_prepend() {
41 touch ${WORKDIR}/powerpc_rom.bin 39 touch ${WORKDIR}/powerpc_rom.bin
42} 40}
43 41
44do_install_append() { 42do_install_append() {
45 rm ${WORKDIR}/powerpc_rom.bin 43 rm ${WORKDIR}/powerpc_rom.bin
46 # Prevent QA warnings about installed ${localstatedir}/run 44 # Prevent QA warnings about installed ${localstatedir}/run
47 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi 45 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
48} 46}