summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/openssl/openssl_1.0.1i.bbappend')
-rw-r--r--recipes-connectivity/openssl/openssl_1.0.1i.bbappend40
1 files changed, 0 insertions, 40 deletions
diff --git a/recipes-connectivity/openssl/openssl_1.0.1i.bbappend b/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
deleted file mode 100644
index 7b381ff..0000000
--- a/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
+++ /dev/null
@@ -1,40 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/openssl-fsl:"
2
3RDEPENDS_${PN}_class-target += "cryptodev-module"
4
5SRC_URI_append_class-target = " file://0001-remove-double-initialization-of-cryptodev-engine.patch \
6 file://0002-eng_cryptodev-add-support-for-TLS-algorithms-offload.patch \
7 file://0003-cryptodev-fix-algorithm-registration.patch \
8 file://0004-linux-pcc-make-it-more-robust-and-recognize-KERNEL_B.patch \
9 file://0005-ECC-Support-header-for-Cryptodev-Engine.patch \
10 file://0006-Fixed-private-key-support-for-DH.patch \
11 file://0007-Fixed-private-key-support-for-DH.patch \
12 file://0008-Initial-support-for-PKC-in-cryptodev-engine.patch \
13 file://0009-Added-hwrng-dev-file-as-source-of-RNG.patch \
14 file://0010-Asynchronous-interface-added-for-PKC-cryptodev-inter.patch \
15 file://0011-Add-RSA-keygen-operation-and-support-gendsa-command-.patch \
16 file://0012-RSA-Keygen-Fix.patch \
17 file://0013-Removed-local-copy-of-curve_t-type.patch \
18 file://0014-Modulus-parameter-is-not-populated-by-dhparams.patch \
19 file://0015-SW-Backoff-mechanism-for-dsa-keygen.patch \
20 file://0016-Fixed-DH-keygen-pair-generator.patch \
21 file://0017-cryptodev-add-support-for-aes-gcm-algorithm-offloadi.patch \
22 file://0018-eng_cryptodev-extend-TLS-offload-with-3des_cbc_hmac_.patch \
23 file://0019-eng_cryptodev-add-support-for-TLSv1.1-record-offload.patch \
24 file://0020-eng_cryptodev-add-support-for-TLSv1.2-record-offload.patch \
25 file://0021-cryptodev-drop-redundant-function.patch \
26 file://0022-cryptodev-do-not-zero-the-buffer-before-use.patch \
27 file://0023-cryptodev-clean-up-code-layout.patch \
28 file://0024-cryptodev-do-not-cache-file-descriptor-in-open.patch \
29 file://0025-cryptodev-put_dev_crypto-should-be-an-int.patch \
30 file://0026-cryptodev-simplify-cryptodev-pkc-support-code.patch \
31"
32
33# Digest offloading through cryptodev is not recommended because of the
34# performance penalty of the Openssl engine interface. Openssl generates a huge
35# number of calls to digest functions for even a small amount of work data.
36# For example there are 70 calls to cipher code and over 10000 to digest code
37# when downloading only 10 files of 700 bytes each.
38# Do not build OpenSSL with cryptodev digest support until engine digest
39# interface gets some rework:
40CFLAG_class-target := "${@'${CFLAG}'.replace('-DUSE_CRYPTODEV_DIGESTS', '')}"