summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/openssl/openssl_1.0.1i.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/openssl/openssl_1.0.1i.bb')
-rw-r--r--recipes-connectivity/openssl/openssl_1.0.1i.bb53
1 files changed, 0 insertions, 53 deletions
diff --git a/recipes-connectivity/openssl/openssl_1.0.1i.bb b/recipes-connectivity/openssl/openssl_1.0.1i.bb
deleted file mode 100644
index 9d093ef..0000000
--- a/recipes-connectivity/openssl/openssl_1.0.1i.bb
+++ /dev/null
@@ -1,53 +0,0 @@
1require openssl.inc
2
3# For target side versions of openssl enable support for cryptodev Linux driver
4# if they are available.
5DEPENDS_class-target += "cryptodev-linux"
6CFLAG_class-target += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
9
10export DIRS = "crypto ssl apps engines"
11export OE_LDFLAGS="${LDFLAGS}"
12
13SRC_URI += "file://configure-targets.patch \
14 file://shared-libs.patch \
15 file://oe-ldflags.patch \
16 file://engines-install-in-libdir-ssl.patch \
17 file://openssl-fix-link.patch \
18 file://debian/version-script.patch \
19 file://debian/pic.patch \
20 file://debian/c_rehash-compat.patch \
21 file://debian/ca.patch \
22 file://debian/make-targets.patch \
23 file://debian/no-rpath.patch \
24 file://debian/man-dir.patch \
25 file://debian/man-section.patch \
26 file://debian/no-symbolic.patch \
27 file://debian/debian-targets.patch \
28 file://openssl_fix_for_x32.patch \
29 file://fix-cipher-des-ede3-cfb1.patch \
30 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
31 file://openssl-avoid-NULL-pointer-dereference-in-dh_pub_encode.patch \
32 file://initial-aarch64-bits.patch \
33 file://find.pl \
34 file://openssl-fix-des.pod-error.patch \
35 "
36
37SRC_URI[md5sum] = "c8dc151a671b9b92ff3e4c118b174972"
38SRC_URI[sha256sum] = "3c179f46ca77069a6a0bac70212a9b3b838b2f66129cb52d568837fc79d8fcc7"
39
40PACKAGES =+ " \
41 ${PN}-engines-dbg \
42 ${PN}-engines \
43"
44
45FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
46FILES_${PN}-engines-dbg = "${libdir}/engines/.debug ${libdir}/ssl/engines/.debug"
47
48PARALLEL_MAKE = ""
49PARALLEL_MAKEINST = ""
50
51do_configure_prepend() {
52 cp ${WORKDIR}/find.pl ${S}/util/find.pl
53}