summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb')
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb96
1 files changed, 96 insertions, 0 deletions
diff --git a/recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb b/recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb
new file mode 100644
index 0000000..3b9d56e
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb
@@ -0,0 +1,96 @@
1require openssl-qoriq.inc
2
3# For target side versions of openssl enable support for cryptodev Linux driver
4# if they are available.
5DEPENDS_class-target += "cryptodev-linux"
6CFLAG_class-target += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
9
10export DIRS = "crypto ssl apps engines"
11export OE_LDFLAGS="${LDFLAGS}"
12
13SRC_URI += "file://configure-targets.patch \
14 file://shared-libs.patch \
15 file://oe-ldflags.patch \
16 file://engines-install-in-libdir-ssl.patch \
17 file://openssl-fix-link.patch \
18 file://debian/version-script.patch \
19 file://debian/pic.patch \
20 file://debian/c_rehash-compat.patch \
21 file://debian/ca.patch \
22 file://debian/make-targets.patch \
23 file://debian/no-rpath.patch \
24 file://debian/man-dir.patch \
25 file://debian/man-section.patch \
26 file://debian/no-symbolic.patch \
27 file://debian/debian-targets.patch \
28 file://openssl_fix_for_x32.patch \
29 file://fix-cipher-des-ede3-cfb1.patch \
30 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
31 file://openssl-avoid-NULL-pointer-dereference-in-dh_pub_encode.patch \
32 file://initial-aarch64-bits.patch \
33 file://find.pl \
34 file://openssl-fix-des.pod-error.patch \
35 "
36
37SRC_URI_append_class-target = "\
38 file://qoriq/0001-remove-double-initialization-of-cryptodev-engine.patch \
39 file://qoriq/0002-eng_cryptodev-add-support-for-TLS-algorithms-offload.patch \
40 file://qoriq/0003-cryptodev-fix-algorithm-registration.patch \
41 file://qoriq/0004-linux-pcc-make-it-more-robust-and-recognize-KERNEL_B.patch \
42 file://qoriq/0005-ECC-Support-header-for-Cryptodev-Engine.patch \
43 file://qoriq/0006-Fixed-private-key-support-for-DH.patch \
44 file://qoriq/0007-Fixed-private-key-support-for-DH.patch \
45 file://qoriq/0008-Initial-support-for-PKC-in-cryptodev-engine.patch \
46 file://qoriq/0009-Added-hwrng-dev-file-as-source-of-RNG.patch \
47 file://qoriq/0010-Asynchronous-interface-added-for-PKC-cryptodev-inter.patch \
48 file://qoriq/0011-Add-RSA-keygen-operation-and-support-gendsa-command-.patch \
49 file://qoriq/0012-RSA-Keygen-Fix.patch \
50 file://qoriq/0013-Removed-local-copy-of-curve_t-type.patch \
51 file://qoriq/0014-Modulus-parameter-is-not-populated-by-dhparams.patch \
52 file://qoriq/0015-SW-Backoff-mechanism-for-dsa-keygen.patch \
53 file://qoriq/0016-Fixed-DH-keygen-pair-generator.patch \
54 file://qoriq/0017-cryptodev-add-support-for-aes-gcm-algorithm-offloadi.patch \
55 file://qoriq/0018-eng_cryptodev-extend-TLS-offload-with-3des_cbc_hmac_.patch \
56 file://qoriq/0019-eng_cryptodev-add-support-for-TLSv1.1-record-offload.patch \
57 file://qoriq/0020-eng_cryptodev-add-support-for-TLSv1.2-record-offload.patch \
58 file://qoriq/0021-cryptodev-drop-redundant-function.patch \
59 file://qoriq/0022-cryptodev-do-not-zero-the-buffer-before-use.patch \
60 file://qoriq/0023-cryptodev-clean-up-code-layout.patch \
61 file://qoriq/0024-cryptodev-do-not-cache-file-descriptor-in-open.patch \
62 file://qoriq/0025-cryptodev-put_dev_crypto-should-be-an-int.patch \
63 file://qoriq/0026-cryptodev-simplify-cryptodev-pkc-support-code.patch \
64"
65
66SRC_URI[md5sum] = "c8dc151a671b9b92ff3e4c118b174972"
67SRC_URI[sha256sum] = "3c179f46ca77069a6a0bac70212a9b3b838b2f66129cb52d568837fc79d8fcc7"
68
69PACKAGES =+ " \
70 ${PN}-engines-dbg \
71 ${PN}-engines \
72"
73
74FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
75FILES_${PN}-engines-dbg = "${libdir}/engines/.debug ${libdir}/ssl/engines/.debug"
76
77PARALLEL_MAKE = ""
78PARALLEL_MAKEINST = ""
79
80# Digest offloading through cryptodev is not recommended because of the
81# performance penalty of the Openssl engine interface. Openssl generates a huge
82# number of calls to digest functions for even a small amount of work data.
83# For example there are 70 calls to cipher code and over 10000 to digest code
84# when downloading only 10 files of 700 bytes each.
85# Do not build OpenSSL with cryptodev digest support until engine digest
86# interface gets some rework:
87CFLAG_class-target := "${@'${CFLAG}'.replace('-DUSE_CRYPTODEV_DIGESTS', '')}"
88
89do_configure_prepend() {
90 cp ${WORKDIR}/find.pl ${S}/util/find.pl
91}
92
93
94RDEPENDS_${PN}_class-target += "cryptodev-module"
95
96COMPATIBLE_MACHINE = "(qoriq)"