summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/files/add-fgnu89-inline-option-for-gcc5.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/files/add-fgnu89-inline-option-for-gcc5.patch')
-rw-r--r--recipes-bsp/u-boot/files/add-fgnu89-inline-option-for-gcc5.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/recipes-bsp/u-boot/files/add-fgnu89-inline-option-for-gcc5.patch b/recipes-bsp/u-boot/files/add-fgnu89-inline-option-for-gcc5.patch
deleted file mode 100644
index cfe1c07..0000000
--- a/recipes-bsp/u-boot/files/add-fgnu89-inline-option-for-gcc5.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1Upstream-Status: Pending
2
3From 4d4fcfc41288134b48b72ac69702f68741d7631f Mon Sep 17 00:00:00 2001
4From: Ting Liu <ting.liu@freescale.com>
5Date: Tue, 28 Jul 2015 16:29:26 +0800
6Subject: [PATCH] add -fgnu89-inline option for gcc5
7
8Fix the below build issues:
9 CC drivers/crypto/fsl/sec.o
10 LD arch/powerpc/cpu/mpc8xxx/built-in.o
11arch/powerpc/cpu/mpc8xxx/fdt.o: In function `ld_le16':
12../arch/powerpc/include/asm/byteorder.h:12: multiple definition of `ld_le16'
13
14The problem is the change of the default C standard from gnu89 to gnu11
15which changes the semantics of 'inline'. The issue is described in the
16Porting guide at https://gcc.gnu.org/gcc-5/porting_to.html. Adding the
17'-fgnu89-inline' option fixes the issue.
18
19Signed-off-by: Ting Liu <ting.liu@freescale.com>
20---
21 Makefile | 2 +-
22 1 file changed, 1 insertion(+), 1 deletion(-)
23
24diff --git a/Makefile b/Makefile
25index 9995e00..00497cc 100644
26--- a/Makefile
27+++ b/Makefile
28@@ -349,7 +349,7 @@ CHECKFLAGS := -D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ \
29
30 KBUILD_CPPFLAGS := -D__KERNEL__ -D__UBOOT__
31
32-KBUILD_CFLAGS := -Wall -Wstrict-prototypes \
33+KBUILD_CFLAGS := -fgnu89-inline -Wall -Wstrict-prototypes \
34 -Wno-format-security \
35 -fno-builtin -ffreestanding
36 KBUILD_AFLAGS := -D__ASSEMBLY__
37--
381.9.2
39