summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/rcw
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/rcw')
-rw-r--r--recipes-bsp/rcw/rcw_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
new file mode 100644
index 0000000..c532a9d
--- /dev/null
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "Reset Control Words (RCW)"
2SECTION = "rcw"
3LICENSE = "BSD"
4PR = "r8"
5
6LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b6c8ebcfdd208e"
7
8# this package is specific to the machine itself
9INHIBIT_DEFAULT_DEPS = "1"
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11COMPATIBLE_HOST_fslmachine = ".*"
12COMPATIBLE_HOST ?= "(none)"
13
14inherit deploy
15
16SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git"
17SRCREV = "5d3c819bcca6d09dcf7b52b3f2855dda304a5997"
18
19S = "${WORKDIR}/git"
20
21do_install () {
22 make install
23
24 M=`echo ${MACHINE} | sed s/-64b//g`
25 install -d ${D}/boot/rcw
26 cp -r ${S}/${M}/${M}/* ${D}/boot/rcw
27}
28
29do_deploy () {
30 M=`echo ${MACHINE} | sed s/-64b//g`
31 install -d ${DEPLOYDIR}/rcw
32 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/rcw
33}
34addtask deploy after do_install
35
36PACKAGES += "${PN}-image"
37FILES_${PN}-image += "/boot"
38
39ALLOW_EMPTY_${PN} = "1"