summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/rcw
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-07-08 11:08:16 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-07-10 11:22:18 +0800
commit851c7ff26de131b871bd5a64274c1a2b13d60fc3 (patch)
tree92eac21a1e1e6c3c0d27bdeaca2ff967e85c2e65 /recipes-bsp/rcw
parent55f7692b69fe273aa41f7362a9324c80515d7b52 (diff)
downloadmeta-fsl-ppc-851c7ff26de131b871bd5a64274c1a2b13d60fc3.tar.gz
change layout to follow oe-core guidelines of recipes
Follow the rules defined in: http://git.yoctoproject.org/cgit/cgit.cgi/poky/tree/meta/recipes.txt recipes-bsp - Anything with links to specific hardware or hardware configuration information recipes-connectivity - Libraries and applications related to communication with other devices recipes-core - What's needed to build a basic working Linux image including commonly used dependencies recipes-devtools - Tools primarily used by the build system (but can also be used on targets) recipes-extended - Applications which whilst not essential add features compared to the alternatives in core. May be needed for full tool functionality or LSB compliance. recipes-gnome - All things related to the GTK+ application framework recipes-graphics - X and other graphically related system libraries recipes-kernel - The kernel and generic applications/libraries with strong kernel dependencies recipes-lsb4 - Recipes added for the sole purpose of supporting the Linux Standard Base (LSB) 4.x recipes-multimedia - Codecs and support utilties for audio, images and video recipes-rt - Provides package and image recipes for using and testing the PREEMPT_RT kernel recipes-qt - All things related to the Qt application framework recipes-sato - The Sato demo/reference UI/UX, its associated apps and configuration recipes-support - Recipes used by other recipes but that are not directly included in images recipes-dpaa - recipes related to fsl dpaa feature recipes-virtualization - recipes related to fsl virtualization feature Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-bsp/rcw')
-rw-r--r--recipes-bsp/rcw/rcw_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
new file mode 100644
index 0000000..c532a9d
--- /dev/null
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "Reset Control Words (RCW)"
2SECTION = "rcw"
3LICENSE = "BSD"
4PR = "r8"
5
6LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b6c8ebcfdd208e"
7
8# this package is specific to the machine itself
9INHIBIT_DEFAULT_DEPS = "1"
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11COMPATIBLE_HOST_fslmachine = ".*"
12COMPATIBLE_HOST ?= "(none)"
13
14inherit deploy
15
16SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git"
17SRCREV = "5d3c819bcca6d09dcf7b52b3f2855dda304a5997"
18
19S = "${WORKDIR}/git"
20
21do_install () {
22 make install
23
24 M=`echo ${MACHINE} | sed s/-64b//g`
25 install -d ${D}/boot/rcw
26 cp -r ${S}/${M}/${M}/* ${D}/boot/rcw
27}
28
29do_deploy () {
30 M=`echo ${MACHINE} | sed s/-64b//g`
31 install -d ${DEPLOYDIR}/rcw
32 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/rcw
33}
34addtask deploy after do_install
35
36PACKAGES += "${PN}-image"
37FILES_${PN}-image += "/boot"
38
39ALLOW_EMPTY_${PN} = "1"