summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/boot-format
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/boot-format')
-rw-r--r--recipes-bsp/boot-format/boot-format_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-bsp/boot-format/boot-format_git.bb b/recipes-bsp/boot-format/boot-format_git.bb
new file mode 100644
index 0000000..ac1504d
--- /dev/null
+++ b/recipes-bsp/boot-format/boot-format_git.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "Boot format utility for booting from eSDHC/eSPI"
2LICENSE = "GPLv2"
3PR = "r6"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/boot-format.git"
7SRCREV = "d9bbfaba0c9316ae33455099c47bae429479e530"
8
9S = "${WORKDIR}/git"
10EXTRA_OEMAKE = 'CC="${CC}"'
11
12do_install(){
13 oe_runmake DESTDIR=${D} PREFIX=${prefix} install
14}
15
16PACKAGES =+ "${PN}-config"
17FILES_${PN}-config += "${datadir}/*"
18
19BBCLASSEXTEND = "native nativesdk"