summaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf')
-rw-r--r--conf/layer.conf14
-rw-r--r--conf/machine/b4420qds-64b.conf18
-rw-r--r--conf/machine/b4420qds.conf17
-rw-r--r--conf/machine/b4860qds-64b.conf29
-rw-r--r--conf/machine/b4860qds.conf17
-rw-r--r--conf/machine/bsc9131rdb.conf16
-rw-r--r--conf/machine/bsc9132qds.conf16
-rw-r--r--conf/machine/c293pcie.conf17
-rw-r--r--conf/machine/e500mc.inc17
-rw-r--r--conf/machine/e500v2.inc15
-rw-r--r--conf/machine/e5500-64b.inc18
-rw-r--r--conf/machine/e5500.inc17
-rw-r--r--conf/machine/e6500-64b.inc18
-rw-r--r--conf/machine/e6500.inc17
-rw-r--r--conf/machine/p1010rdb.conf20
-rw-r--r--conf/machine/p1020rdb.conf19
-rw-r--r--conf/machine/p1021rdb.conf18
-rw-r--r--conf/machine/p1022ds.conf27
-rw-r--r--conf/machine/p1023rdb.conf16
-rw-r--r--conf/machine/p1025twr.conf18
-rw-r--r--conf/machine/p2020ds.conf17
-rw-r--r--conf/machine/p2020rdb.conf18
-rw-r--r--conf/machine/p2041rdb.conf16
-rw-r--r--conf/machine/p3041ds.conf16
-rw-r--r--conf/machine/p4080ds.conf16
-rw-r--r--conf/machine/p5020ds-64b.conf17
-rw-r--r--conf/machine/p5020ds.conf16
-rw-r--r--conf/machine/p5040ds-64b.conf16
-rw-r--r--conf/machine/p5040ds.conf16
-rw-r--r--conf/machine/t2080qds-64b.conf17
-rw-r--r--conf/machine/t2080qds.conf17
-rw-r--r--conf/machine/t4160qds-64b.conf17
-rw-r--r--conf/machine/t4160qds.conf17
-rw-r--r--conf/machine/t4240qds-64b.conf17
-rw-r--r--conf/machine/t4240qds.conf17
35 files changed, 614 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..0f81db0
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,14 @@
1# We have a packages directory, add to BBFILES
2BBPATH .= ":${LAYERDIR}"
3
4BBFILES += "${LAYERDIR}/recipes-*/*/*.bb*"
5BBFILES += "${LAYERDIR}/images/*.bb*"
6
7BBFILE_COLLECTIONS += "fsl-ppc"
8BBFILE_PATTERN_fsl-ppc = "^${LAYERDIR}/"
9BBFILE_PRIORITY_fsl-ppc = "5"
10
11BB_ENV_EXTRAWHITE := "KSRC USRC"
12
13LICENSE_PATH += "${LAYERDIR}/custom-licenses"
14
diff --git a/conf/machine/b4420qds-64b.conf b/conf/machine/b4420qds-64b.conf
new file mode 100644
index 0000000..0bb959c
--- /dev/null
+++ b/conf/machine/b4420qds-64b.conf
@@ -0,0 +1,18 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running B4420QDS in 64-bit mode
3
4require e6500-64b.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "b4420"
8
9# TODO: fix 32bit build of u-boot
10UBOOT_MACHINES ?= "B4420QDS"
11KERNEL_DEVICETREE ?= "b4420qds.dtb b4420qds-usdpaa.dtb"
12KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/85xx/e6500rev2_defconfig"
13
14JFFS2_ERASEBLOCK = "0x10000"
15
16SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
17SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
18USE_VT = "0"
diff --git a/conf/machine/b4420qds.conf b/conf/machine/b4420qds.conf
new file mode 100644
index 0000000..b07ab5d
--- /dev/null
+++ b/conf/machine/b4420qds.conf
@@ -0,0 +1,17 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running B4420QDS in 32-bit mode
3
4require e6500.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "b4420"
8UBOOT_MACHINES ?= "B4420QDS"
9KERNEL_DEVICETREE ?= "b4420qds.dtb b4420qds-usdpaa.dtb"
10KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/85xx/e6500rev2_defconfig"
11
12JFFS2_ERASEBLOCK = "0x10000"
13
14SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
15SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
16USE_VT = "0"
17BUILD_64BIT_KERNEL = "1"
diff --git a/conf/machine/b4860qds-64b.conf b/conf/machine/b4860qds-64b.conf
new file mode 100644
index 0000000..528f900
--- /dev/null
+++ b/conf/machine/b4860qds-64b.conf
@@ -0,0 +1,29 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running B4860QDS in 64-bit mode
3
4require e6500-64b.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "b4860"
8# TODO: fix 32bit build of u-boot
9UBOOT_MACHINES ?= "B4860QDS"
10KERNEL_DEVICETREE ?= "b4860qds.dtb b4860qds-usdpaa.dtb"
11KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/85xx/e6500rev2_defconfig"
12
13JFFS2_ERASEBLOCK = "0x10000"
14
15SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
16SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
17USE_VT = "0"
18
19#required to build u-boot recipe
20require conf/multilib.conf
21MULTILIBS = "multilib:lib32"
22DEFAULTTUNE_virtclass-multilib-lib32 = "powerpc"
23
24#required to boot rootfs from RAM
25IMAGE_FSTYPES += "ext2.gz.u-boot"
26
27#removed rootfs image-prelink because some errors
28#appeared when prelink of the libs was done
29USER_CLASSES = "buildstats image-mklibs"
diff --git a/conf/machine/b4860qds.conf b/conf/machine/b4860qds.conf
new file mode 100644
index 0000000..2aa471e
--- /dev/null
+++ b/conf/machine/b4860qds.conf
@@ -0,0 +1,17 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running B4860QDS in 32-bit mode
3
4require e6500.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "b4860"
8UBOOT_MACHINES ?= "B4860QDS"
9KERNEL_DEVICETREE ?= "b4860qds.dtb b4860qds-usdpaa.dtb"
10KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/85xx/e6500rev2_defconfig"
11
12JFFS2_ERASEBLOCK = "0x10000"
13
14SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
15SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
16USE_VT = "0"
17BUILD_64BIT_KERNEL = "1"
diff --git a/conf/machine/bsc9131rdb.conf b/conf/machine/bsc9131rdb.conf
new file mode 100644
index 0000000..c145a04
--- /dev/null
+++ b/conf/machine/bsc9131rdb.conf
@@ -0,0 +1,16 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e500v2.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "bsc9131"
8UBOOT_MACHINES ?= "BSC9131RDB_SPIFLASH BSC9131RDB_NAND BSC9131RDB_NAND_SYSCLK100 BSC9131RDB_SPIFLASH_SYSCLK100"
9KERNEL_DEVICETREE ?= "bsc9131rdb.dtb"
10KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/85xx/bsc913x_defconfig"
11
12JFFS2_ERASEBLOCK = "0x10000"
13
14SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
15SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
16USE_VT = "0"
diff --git a/conf/machine/bsc9132qds.conf b/conf/machine/bsc9132qds.conf
new file mode 100644
index 0000000..5b9a100
--- /dev/null
+++ b/conf/machine/bsc9132qds.conf
@@ -0,0 +1,16 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e500v2.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "bsc9132"
8UBOOT_MACHINES ?= " BSC9132QDS_NAND_DDRCLK133 BSC9132QDS_NAND_DDRCLK100 BSC9132QDS_NOR_DDRCLK100 BSC9132QDS_NOR_DDRCLK133 BSC9132QDS_SDCARD_DDRCLK100 BSC9132QDS_SDCARD_DDRCLK133 BSC9132QDS_SPIFLASH_DDRCLK100 BSC9132QDS_SPIFLASH_DDRCLK133"
9KERNEL_DEVICETREE ?= "bsc9132qds.dtb"
10KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/85xx/bsc913x_smp_defconfig"
11
12JFFS2_ERASEBLOCK = "0x10000"
13
14SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
15SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
16USE_VT = "0"
diff --git a/conf/machine/c293pcie.conf b/conf/machine/c293pcie.conf
new file mode 100644
index 0000000..9e7252a
--- /dev/null
+++ b/conf/machine/c293pcie.conf
@@ -0,0 +1,17 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running C293PCIE in 36-bit mode
3
4require e500v2.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "c293pcie"
8BOOTFORMAT_CONFIG = "config_ddr3_512m_c29xpcie_800M.dat"
9UBOOT_MACHINES ?= "C293PCIE C293PCIE_NAND C293PCIE_SPIFLASH C293PCIE_SECBOOT C293PCIE_SPIFLASH_SECBOOT"
10KERNEL_DEVICETREE ?= "c293pcie_36b.dtb"
11KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/mpc85xx_defconfig"
12
13JFFS2_ERASEBLOCK = "0x10000"
14
15SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
16SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
17USE_VT = "0"
diff --git a/conf/machine/e500mc.inc b/conf/machine/e500mc.inc
new file mode 100644
index 0000000..57952e7
--- /dev/null
+++ b/conf/machine/e500mc.inc
@@ -0,0 +1,17 @@
1TARGET_FPU = "hard"
2
3require conf/machine/include/tune-ppce500mc.inc
4
5MACHINE_FEATURES = "kernel26 keyboard pci ext2 ext3 serial"
6MACHINE_EXTRA_RRECOMMENDS = "u-boot udev-extraconf"
7
8PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk"
9PREFERRED_VERSION_virtual/kernel ?= "3.0.34"
10PREFERRED_VERSION_qemu = "1.4+fsl"
11
12KERNEL_IMAGETYPE ?= "uImage"
13# disable the images below for now
14# ext2.bz2 ext2.lzma \
15# ext2.gz.u-boot ext2.bz2.u-boot ext2.lzma.u-boot"
16
17MACHINEOVERRIDES .= ":e500mc:fslmachine"
diff --git a/conf/machine/e500v2.inc b/conf/machine/e500v2.inc
new file mode 100644
index 0000000..befc296
--- /dev/null
+++ b/conf/machine/e500v2.inc
@@ -0,0 +1,15 @@
1require conf/machine/include/tune-ppce500v2.inc
2
3MACHINE_FEATURES = "kernel26 pci ext2 ext3 serial"
4MACHINE_EXTRA_RRECOMMENDS = "u-boot udev-extraconf"
5
6PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk"
7PREFERRED_VERSION_virtual/kernel ?= "3.0.34"
8PREFERRED_VERSION_qemu = "1.4+fsl"
9
10KERNEL_IMAGETYPE ?= "uImage"
11# disable the images below for now
12# ext2.bz2 ext2.lzma \
13# ext2.gz.u-boot ext2.bz2.u-boot ext2.lzma.u-boot"
14
15MACHINEOVERRIDES .= ":e500v2:fslmachine"
diff --git a/conf/machine/e5500-64b.inc b/conf/machine/e5500-64b.inc
new file mode 100644
index 0000000..0ce7f11
--- /dev/null
+++ b/conf/machine/e5500-64b.inc
@@ -0,0 +1,18 @@
1TARGET_FPU = "hard"
2
3DEFAULTTUNE ?= "ppc64e5500"
4require conf/machine/include/tune-ppce5500.inc
5
6MACHINE_FEATURES = "kernel26 keyboard pci ext2 ext3 serial"
7MACHINE_EXTRA_RRECOMMENDS = "u-boot udev-extraconf"
8
9PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk"
10PREFERRED_VERSION_virtual/kernel ?= "3.0.34"
11PREFERRED_VERSION_qemu = "1.4+fsl"
12
13KERNEL_IMAGETYPE ?= "uImage"
14# disable the images below for now
15# ext2.bz2 ext2.lzma \
16# ext2.gz.u-boot ext2.bz2.u-boot ext2.lzma.u-boot"
17
18MACHINEOVERRIDES .= ":e5500-64b:fslmachine"
diff --git a/conf/machine/e5500.inc b/conf/machine/e5500.inc
new file mode 100644
index 0000000..ae66342
--- /dev/null
+++ b/conf/machine/e5500.inc
@@ -0,0 +1,17 @@
1TARGET_FPU = "hard"
2
3require conf/machine/include/tune-ppce5500.inc
4
5MACHINE_FEATURES = "kernel26 keyboard pci ext2 ext3 serial"
6MACHINE_EXTRA_RRECOMMENDS = "u-boot udev-extraconf"
7
8PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk"
9PREFERRED_VERSION_virtual/kernel ?= "3.0.34"
10PREFERRED_VERSION_qemu = "1.4+fsl"
11
12KERNEL_IMAGETYPE ?= "uImage"
13# disable the images below for now
14# ext2.bz2 ext2.lzma \
15# ext2.gz.u-boot ext2.bz2.u-boot ext2.lzma.u-boot"
16
17MACHINEOVERRIDES .= ":e5500:fslmachine"
diff --git a/conf/machine/e6500-64b.inc b/conf/machine/e6500-64b.inc
new file mode 100644
index 0000000..2007353
--- /dev/null
+++ b/conf/machine/e6500-64b.inc
@@ -0,0 +1,18 @@
1TARGET_FPU = "hard"
2
3DEFAULTTUNE ?= "ppc64e6500"
4require conf/machine/include/tune-ppce6500.inc
5
6MACHINE_FEATURES = "kernel26 keyboard pci ext2 ext3 serial"
7MACHINE_EXTRA_RRECOMMENDS = "u-boot udev-extraconf"
8
9PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk"
10PREFERRED_VERSION_virtual/kernel ?= "3.0.34"
11PREFERRED_VERSION_qemu = "1.4+fsl"
12
13KERNEL_IMAGETYPE ?= "uImage"
14# disable the images below for now
15# ext2.bz2 ext2.lzma \
16# ext2.gz.u-boot ext2.bz2.u-boot ext2.lzma.u-boot"
17
18MACHINEOVERRIDES .= ":e6500-64b:fslmachine"
diff --git a/conf/machine/e6500.inc b/conf/machine/e6500.inc
new file mode 100644
index 0000000..23adf15
--- /dev/null
+++ b/conf/machine/e6500.inc
@@ -0,0 +1,17 @@
1TARGET_FPU = "hard"
2
3require conf/machine/include/tune-ppce6500.inc
4
5MACHINE_FEATURES = "kernel26 keyboard pci ext2 ext3 serial"
6MACHINE_EXTRA_RRECOMMENDS = "u-boot udev-extraconf"
7
8PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk"
9PREFERRED_VERSION_virtual/kernel ?= "3.0.34"
10PREFERRED_VERSION_qemu = "1.4+fsl"
11
12KERNEL_IMAGETYPE ?= "uImage"
13# disable the images below for now
14# ext2.bz2 ext2.lzma \
15# ext2.gz.u-boot ext2.bz2.u-boot ext2.lzma.u-boot"
16
17MACHINEOVERRIDES .= ":e6500:fslmachine"
diff --git a/conf/machine/p1010rdb.conf b/conf/machine/p1010rdb.conf
new file mode 100644
index 0000000..a921747
--- /dev/null
+++ b/conf/machine/p1010rdb.conf
@@ -0,0 +1,20 @@
1#@TYPE: Machine
2#@Name: Freescale P1010RDB
3#@DESCRIPTION: Machine configuration for the Freescale P1010RDB
4
5require e500v2.inc
6require conf/machine/include/soc-family.inc
7
8SOC_FAMILY = "p1010"
9BOOTFORMAT_CONFIG = "config_sram_p1010rdb.dat"
10UBOOT_MACHINES ?= "P1010RDB-PB_NAND P1010RDB-PB_NOR \
11 P1010RDB-PB_SPIFLASH P1010RDB-PB_36BIT_NOR P1010RDB-PB_36BIT_NAND \
12 P1010RDB-PB_36BIT_SPIFLASH"
13KERNEL_DEVICETREE ?= "p1010rdb-pa.dtb p1010rdb-pb.dtb"
14KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/mpc85xx_defconfig"
15
16JFFS2_ERASEBLOCK = "0x20000"
17
18SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
19SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
20USE_VT = "0"
diff --git a/conf/machine/p1020rdb.conf b/conf/machine/p1020rdb.conf
new file mode 100644
index 0000000..9adac79
--- /dev/null
+++ b/conf/machine/p1020rdb.conf
@@ -0,0 +1,19 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e500v2.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "p1020"
8BOOTFORMAT_CONFIG = "config_sram_p1022ds.dat"
9UBOOT_MACHINES ?= " P1020RDB-PD P1020RDB-PD_NAND P1020RDB-PD_SDCARD P1020RDB-PD_SPIFLASH"
10
11KERNEL_DEVICETREE ?= "p1020rdb-pd_32b.dtb"
12
13KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/mpc85xx_smp_defconfig"
14
15JFFS2_ERASEBLOCK = "0x20000"
16
17SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
18SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
19USE_VT = "0"
diff --git a/conf/machine/p1021rdb.conf b/conf/machine/p1021rdb.conf
new file mode 100644
index 0000000..37c17a4
--- /dev/null
+++ b/conf/machine/p1021rdb.conf
@@ -0,0 +1,18 @@
1#@TYPE: Machine
2#@Name: Freescale P1021RDB
3#@DESCRIPTION: Machine configuration for the Freescale P1021RDB
4
5require e500v2.inc
6require conf/machine/include/soc-family.inc
7
8SOC_FAMILY = "p1021"
9BOOTFORMAT_CONFIG = "config_sram_p1022ds.dat"
10UBOOT_MACHINES ?= "P1021RDB-PC P1021RDB-PC_NAND P1021RDB-PC_SDCARD P1021RDB-PC_SPIFLASH P1021RDB-PC_36BIT P1021RDB-PC_36BIT_SPIFLASH P1021RDB-PC_36BIT_NAND P1021RDB-PC_36BIT_SDCARD"
11KERNEL_DEVICETREE ?= "p1021rdb-pc_32b.dtb"
12KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/mpc85xx_smp_defconfig"
13
14JFFS2_ERASEBLOCK = "0x20000"
15
16SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
17SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
18USE_VT = "0"
diff --git a/conf/machine/p1022ds.conf b/conf/machine/p1022ds.conf
new file mode 100644
index 0000000..b06da81
--- /dev/null
+++ b/conf/machine/p1022ds.conf
@@ -0,0 +1,27 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e500v2.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "p1022"
8BOOTFORMAT_CONFIG = "config_sram_p1022ds.dat"
9UBOOT_MACHINES ?= "P1022DS P1022DS_NAND P1022DS_SPIFLASH P1022DS_SDCARD P1022DS_36BIT P1022DS_36BIT_SPIFLASH P1022DS_36BIT_NAND P1022DS_36BIT_SDCARD"
10KERNEL_DEVICETREE ?= "p1022ds_32b.dtb"
11KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/mpc85xx_smp_defconfig"
12
13PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
14
15XSERVER = " \
16 xserver-xorg \
17 xf86-input-evdev \
18 xf86-input-mouse \
19 xf86-input-keyboard \
20 xf86-video-fbdev \
21"
22
23JFFS2_ERASEBLOCK = "0x20000"
24
25SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
26SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
27USE_VT = "0"
diff --git a/conf/machine/p1023rdb.conf b/conf/machine/p1023rdb.conf
new file mode 100644
index 0000000..ece7e3f
--- /dev/null
+++ b/conf/machine/p1023rdb.conf
@@ -0,0 +1,16 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e500v2.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "p1023"
8UBOOT_MACHINES ?= "P1023RDB"
9KERNEL_DEVICETREE ?= "p1023rdb.dtb"
10KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/85xx/p1023rds_defconfig"
11
12JFFS2_ERASEBLOCK = "0x10000"
13
14SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
15SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
16USE_VT = "0"
diff --git a/conf/machine/p1025twr.conf b/conf/machine/p1025twr.conf
new file mode 100644
index 0000000..eb7c439
--- /dev/null
+++ b/conf/machine/p1025twr.conf
@@ -0,0 +1,18 @@
1#@TYPE: Machine
2#@Name: Freescale P1025TWR
3#@DESCRIPTION: Machine configuration for the Freescale P1025TWR
4
5require e500v2.inc
6require conf/machine/include/soc-family.inc
7
8SOC_FAMILY = "p1025"
9BOOTFORMAT_CONFIG = "config_ddr3_1gb_p1_p2_rdb_pc_667M.dat"
10UBOOT_MACHINES ?= "TWR-P1025"
11KERNEL_DEVICETREE ?= "p1025twr_32b.dtb"
12KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/mpc85xx_smp_defconfig"
13
14JFFS2_ERASEBLOCK = "0x20000"
15
16SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
17SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
18USE_VT = "0"
diff --git a/conf/machine/p2020ds.conf b/conf/machine/p2020ds.conf
new file mode 100644
index 0000000..3dbaf3f
--- /dev/null
+++ b/conf/machine/p2020ds.conf
@@ -0,0 +1,17 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e500v2.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "p2020"
8BOOTFORMAT_CONFIG = "config_sram_p2020ds.dat"
9UBOOT_MACHINES ?= "P2020DS P2020DS_36BIT P2020DS_DDR2 P2020DS_SDCARD P2020DS_SPIFLASH"
10KERNEL_DEVICETREE ?= "p2020ds.dtb"
11KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/mpc85xx_smp_defconfig"
12
13JFFS2_ERASEBLOCK = "0x20000"
14
15SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1"
16SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
17USE_VT = "0"
diff --git a/conf/machine/p2020rdb.conf b/conf/machine/p2020rdb.conf
new file mode 100644
index 0000000..e7c5c9c
--- /dev/null
+++ b/conf/machine/p2020rdb.conf
@@ -0,0 +1,18 @@
1#@TYPE: Machine
2#@Name: Freescale P2020RDB
3#@DESCRIPTION: Machine configuration for the Freescale P2020RDB
4
5require e500v2.inc
6require conf/machine/include/soc-family.inc
7
8SOC_FAMILY = "p2020"
9BOOTFORMAT_CONFIG = "config_sram_p1022ds.dat"
10UBOOT_MACHINES ?= " P2020RDB-PC P2020RDB-PC_NAND P2020RDB-PC_SDCARD P2020RDB-PC_SPIFLASH P2020RDB-PC_36BIT P2020RDB-PC_36BIT_SPIFLASH P2020RDB-PC_36BIT_NAND P2020RDB-PC_36BIT_SDCARD"
11KERNEL_DEVICETREE ?= "p2020rdb-pc_32b.dtb"
12KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/mpc85xx_smp_defconfig"
13
14JFFS2_ERASEBLOCK = "0x20000"
15
16SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1"
17SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
18USE_VT = "0"
diff --git a/conf/machine/p2041rdb.conf b/conf/machine/p2041rdb.conf
new file mode 100644
index 0000000..517adad
--- /dev/null
+++ b/conf/machine/p2041rdb.conf
@@ -0,0 +1,16 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e500mc.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "p2041"
8UBOOT_MACHINES ?= "P2041RDB P2041RDB_NAND P2041RDB_SECURE_BOOT P2041RDB_SDCARD P2041RDB_SPIFLASH"
9KERNEL_DEVICETREE ?= "p2041rdb.dtb p2041rdb-usdpaa.dtb"
10KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/corenet32_smp_defconfig"
11
12JFFS2_ERASEBLOCK = "0x10000"
13
14SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1"
15SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
16USE_VT = "0"
diff --git a/conf/machine/p3041ds.conf b/conf/machine/p3041ds.conf
new file mode 100644
index 0000000..0116ab5
--- /dev/null
+++ b/conf/machine/p3041ds.conf
@@ -0,0 +1,16 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e500mc.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "p3041"
8UBOOT_MACHINES ?= "P3041DS P3041DS_NAND P3041DS_SECURE_BOOT P3041DS_SDCARD P3041DS_SPIFLASH"
9KERNEL_DEVICETREE ?= "p3041ds.dtb p3041ds-usdpaa.dtb"
10KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/corenet32_smp_defconfig"
11
12JFFS2_ERASEBLOCK = "0x10000"
13
14SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
15SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
16USE_VT = "0"
diff --git a/conf/machine/p4080ds.conf b/conf/machine/p4080ds.conf
new file mode 100644
index 0000000..e285fd3
--- /dev/null
+++ b/conf/machine/p4080ds.conf
@@ -0,0 +1,16 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e500mc.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "p4080"
8UBOOT_MACHINES ?= "P4080DS P4080DS_SECURE_BOOT P4080DS_SDCARD P4080DS_SPIFLASH "
9KERNEL_DEVICETREE ?= "p4080ds.dtb p4080ds-usdpaa.dtb"
10KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/corenet32_smp_defconfig"
11
12JFFS2_ERASEBLOCK = "0x10000"
13
14SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1"
15SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
16USE_VT = "0"
diff --git a/conf/machine/p5020ds-64b.conf b/conf/machine/p5020ds-64b.conf
new file mode 100644
index 0000000..144781b
--- /dev/null
+++ b/conf/machine/p5020ds-64b.conf
@@ -0,0 +1,17 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e5500-64b.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "p5020"
8# TODO: fix 32bit build of u-boot for p5020ds-64b
9UBOOT_MACHINES ?= "P5020DS"
10KERNEL_DEVICETREE ?= "p5020ds.dtb p5020ds-usdpaa.dtb"
11KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/corenet64_smp_defconfig"
12
13JFFS2_ERASEBLOCK = "0x10000"
14
15SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
16SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
17USE_VT = "0"
diff --git a/conf/machine/p5020ds.conf b/conf/machine/p5020ds.conf
new file mode 100644
index 0000000..8c263d8
--- /dev/null
+++ b/conf/machine/p5020ds.conf
@@ -0,0 +1,16 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e5500.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "p5020"
8UBOOT_MACHINES ?= "P5020DS P5020DS_NAND P5020DS_SECURE_BOOT P5020DS_SDCARD P5020DS_SPIFLASH "
9KERNEL_DEVICETREE ?= "p5020ds.dtb p5020ds-usdpaa.dtb"
10KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/corenet32_smp_defconfig"
11
12JFFS2_ERASEBLOCK = "0x10000"
13
14SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
15SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
16USE_VT = "0"
diff --git a/conf/machine/p5040ds-64b.conf b/conf/machine/p5040ds-64b.conf
new file mode 100644
index 0000000..e3f6ce1
--- /dev/null
+++ b/conf/machine/p5040ds-64b.conf
@@ -0,0 +1,16 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e5500-64b.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "p5040"
8UBOOT_MACHINES ?= "P5040DS P5040DS_NAND P5040DS_SECURE_BOOT P5040DS_SDCARD P5040DS_SPIFLASH"
9KERNEL_DEVICETREE ?= "p5040ds.dtb p5040ds-usdpaa.dtb"
10KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/corenet64_smp_defconfig"
11
12JFFS2_ERASEBLOCK = "0x10000"
13
14SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
15SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
16USE_VT = "0"
diff --git a/conf/machine/p5040ds.conf b/conf/machine/p5040ds.conf
new file mode 100644
index 0000000..5692ab0
--- /dev/null
+++ b/conf/machine/p5040ds.conf
@@ -0,0 +1,16 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e5500.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "p5040"
8UBOOT_MACHINES ?= "P5040DS P5040DS_NAND P5040DS_SECURE_BOOT P5040DS_SDCARD P5040DS_SPIFLASH"
9KERNEL_DEVICETREE ?= "p5040ds.dtb p5040ds-usdpaa.dtb"
10KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/corenet32_smp_defconfig"
11
12JFFS2_ERASEBLOCK = "0x10000"
13
14SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
15SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
16USE_VT = "0"
diff --git a/conf/machine/t2080qds-64b.conf b/conf/machine/t2080qds-64b.conf
new file mode 100644
index 0000000..d149b6e
--- /dev/null
+++ b/conf/machine/t2080qds-64b.conf
@@ -0,0 +1,17 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running T2080QDS in 64-bit mode
3
4require e6500-64b.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "t2080"
8# TODO: fix 32bit build of u-boot
9UBOOT_MACHINES ?= "T2080QDS T2080QDS_SDCARD T2080QDS_SPIFLASH T2080QDS_NAND T2080QDS_SRIO_PCIE_BOOT"
10KERNEL_DEVICETREE ?= "t2080qds.dtb t2080qds-usdpaa.dtb"
11KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/85xx/e6500rev2_defconfig"
12
13JFFS2_ERASEBLOCK = "0x10000"
14
15SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
16SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
17USE_VT = "0"
diff --git a/conf/machine/t2080qds.conf b/conf/machine/t2080qds.conf
new file mode 100644
index 0000000..a9874b5
--- /dev/null
+++ b/conf/machine/t2080qds.conf
@@ -0,0 +1,17 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running T2080QDS in 32-bit mode
3
4require e6500.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "t2080"
8UBOOT_MACHINES ?= "T2080QDS T2080QDS_SDCARD T2080QDS_SPIFLASH T2080QDS_NAND T2080QDS_SRIO_PCIE_BOOT"
9KERNEL_DEVICETREE ?= "t2080qds.dtb t2080qds-usdpaa.dtb"
10KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/85xx/e6500rev2_defconfig"
11
12JFFS2_ERASEBLOCK = "0x10000"
13
14SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
15SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
16USE_VT = "0"
17BUILD_64BIT_KERNEL = "1"
diff --git a/conf/machine/t4160qds-64b.conf b/conf/machine/t4160qds-64b.conf
new file mode 100644
index 0000000..83696d5
--- /dev/null
+++ b/conf/machine/t4160qds-64b.conf
@@ -0,0 +1,17 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running T4160QDS in 64-bit mode
3
4require e6500-64b.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "t4160"
8# TODO: fix 32bit build of u-boot
9UBOOT_MACHINES ?= "T4160QDS"
10KERNEL_DEVICETREE ?= "t4240qds.dtb t4240qds-usdpaa.dtb"
11KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/85xx/e6500rev2_defconfig"
12
13JFFS2_ERASEBLOCK = "0x10000"
14
15SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
16SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
17USE_VT = "0"
diff --git a/conf/machine/t4160qds.conf b/conf/machine/t4160qds.conf
new file mode 100644
index 0000000..34b2b2e
--- /dev/null
+++ b/conf/machine/t4160qds.conf
@@ -0,0 +1,17 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running T4160QDS in 32-bit mode
3
4require e6500.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "t4160"
8UBOOT_MACHINES ?= "T4160QDS"
9KERNEL_DEVICETREE ?= "t4240qds.dtb t4240qds-usdpaa.dtb"
10KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/85xx/e6500rev2_defconfig"
11
12JFFS2_ERASEBLOCK = "0x10000"
13
14SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
15SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
16USE_VT = "0"
17BUILD_64BIT_KERNEL = "1"
diff --git a/conf/machine/t4240qds-64b.conf b/conf/machine/t4240qds-64b.conf
new file mode 100644
index 0000000..ffdf658
--- /dev/null
+++ b/conf/machine/t4240qds-64b.conf
@@ -0,0 +1,17 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running T4240QDS in 64-bit mode
3
4require e6500-64b.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "t4240"
8# TODO: fix 32bit build of u-boot
9UBOOT_MACHINES ?= "T4240QDS"
10KERNEL_DEVICETREE ?= "t4240qds.dtb t4240qds-usdpaa.dtb"
11KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/85xx/e6500rev2_defconfig"
12
13JFFS2_ERASEBLOCK = "0x10000"
14
15SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
16SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
17USE_VT = "0"
diff --git a/conf/machine/t4240qds.conf b/conf/machine/t4240qds.conf
new file mode 100644
index 0000000..c2c31dd
--- /dev/null
+++ b/conf/machine/t4240qds.conf
@@ -0,0 +1,17 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running T4240QDS in 32-bit mode
3
4require e6500.inc
5require conf/machine/include/soc-family.inc
6
7SOC_FAMILY = "t4240"
8UBOOT_MACHINES ?= "T4240QDS"
9KERNEL_DEVICETREE ?= "t4240qds.dtb t4240qds-usdpaa.dtb"
10KERNEL_DEFCONFIG ?= "${S}/arch/powerpc/configs/85xx/e6500rev2_defconfig"
11
12JFFS2_ERASEBLOCK = "0x10000"
13
14SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyEHV0"
15SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
16USE_VT = "0"
17BUILD_64BIT_KERNEL = "1"