summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-dpaa/fm-ucode/fm-ucode_git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes-dpaa/fm-ucode/fm-ucode_git.bb b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
index 768a9c6..bf6a326 100644
--- a/recipes-dpaa/fm-ucode/fm-ucode_git.bb
+++ b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
@@ -1,14 +1,14 @@
1DESCRIPTION = "Fman microcode binary" 1DESCRIPTION = "Fman microcode binary"
2SECTION = "fm-ucode" 2SECTION = "fm-ucode"
3LICENSE = "Freescale-EULA" 3LICENSE = "Freescale-EULA"
4LIC_FILES_CHKSUM = "file://EULA;md5=60037ccba533a5995e8d1a838d85799c" 4LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f"
5 5
6PR = "r1" 6PR = "r1"
7 7
8inherit deploy 8inherit deploy
9 9
10SRC_URI = "git://git.freescale.com/ppc/sdk/fm-ucode.git;branch=sdk-v1.9.x" 10SRC_URI = "git://git.freescale.com/ppc/sdk/fm-ucode.git;branch=sdk-v2.0.x"
11SRCREV = "33c6c7a4ba1d057afd739bd0106471ffb3299e0e" 11SRCREV = "7ebea4539f6e075448a12ee8808a1fc17a558bfd"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
@@ -18,6 +18,8 @@ REGLEX_t1040 = "t1040"
18REGLEX_t1042 = "t1040" 18REGLEX_t1042 = "t1040"
19REGLEX_b4420 = "b4860" 19REGLEX_b4420 = "b4860"
20REGLEX_t4160 = "t4240" 20REGLEX_t4160 = "t4240"
21REGLEX_ls1043ardb = "t2080"
22REGLEX_ls1043ardb-be = "t2080"
21 23
22do_install () { 24do_install () {
23 UCODE=`echo ${REGLEX} | sed -e 's,-.*$,,' -e 's,[a-zA-Z]*$,,'` 25 UCODE=`echo ${REGLEX} | sed -e 's,-.*$,,' -e 's,[a-zA-Z]*$,,'`
@@ -35,4 +37,4 @@ addtask deploy before do_build after do_install
35PACKAGES += "${PN}-image" 37PACKAGES += "${PN}-image"
36FILES_${PN}-image += "/boot" 38FILES_${PN}-image += "/boot"
37ALLOW_EMPTY_${PN} = "1" 39ALLOW_EMPTY_${PN} = "1"
38COMPATIBLE_MACHINE = "(p1023rdb|e500mc|e5500|e5500-64b|e6500|e6500-64b)" 40COMPATIBLE_MACHINE = "(p1023rdb|e500mc|e5500|e5500-64b|e6500|e6500-64b|fsl-lsch2)"