summaryrefslogtreecommitdiffstats
path: root/recipes-virtualization
diff options
context:
space:
mode:
authorSujith H <sujith.h@gmail.com>2016-04-29 12:24:46 +0530
committerZhenhua Luo <zhenhua.luo@nxp.com>2016-05-09 17:08:00 +0800
commit19f9b87894f188c8b8fb58df5e310f15a07df973 (patch)
tree07b3f761020de9971933909191fee0b4bd85463f /recipes-virtualization
parentcd0ba65d48ec067775297f859084913dfe10a180 (diff)
downloadmeta-fsl-ppc-19f9b87894f188c8b8fb58df5e310f15a07df973.tar.gz
mux-server: Fix build warnings caused by external toolchain
This patch resolves the warning: QA Issue: No GNU_HASH in the elf binary when built with external toolchain. Signed-off-by: Sujith H <sujith.h@gmail.com> Signed-off-by: Sujith Haridasan <Sujith_Haridasan@mentor.com>
Diffstat (limited to 'recipes-virtualization')
-rw-r--r--recipes-virtualization/mux-server/mux-server/0001-Makefile-Fix-the-warning-during-build.patch31
-rw-r--r--recipes-virtualization/mux-server/mux-server_1.02.bb4
2 files changed, 34 insertions, 1 deletions
diff --git a/recipes-virtualization/mux-server/mux-server/0001-Makefile-Fix-the-warning-during-build.patch b/recipes-virtualization/mux-server/mux-server/0001-Makefile-Fix-the-warning-during-build.patch
new file mode 100644
index 0000000..32b0f19
--- /dev/null
+++ b/recipes-virtualization/mux-server/mux-server/0001-Makefile-Fix-the-warning-during-build.patch
@@ -0,0 +1,31 @@
1From bcb58c751a7ff82095642d2c9424a7ae18bca3c6 Mon Sep 17 00:00:00 2001
2From: Sujith Haridasan <Sujith_Haridasan@mentor.com>
3Date: Wed, 27 Apr 2016 16:49:09 +0530
4Subject: [PATCH] Makefile: Fix the warning during build
5
6Fix QA Issue: No GNU_HASH in the elf binary
7This warning is caused when built with external
8toolchain sourcery.
9
10Signed-off-by: Sujith H <sujith.h@gmail.com>
11Signed-off-by: Sujith Haridasan <Sujith_Haridasan@mentor.com>
12---
13 Makefile | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/Makefile b/Makefile
17index c41030d..fa69b6f 100644
18--- a/Makefile
19+++ b/Makefile
20@@ -36,7 +36,7 @@ HOSTCC_OPTS_C= -Wall \
21 all: mux_server
22
23 mux_server: mux_server.c
24- $(HOSTCC) $(HOSTCC_OPTS) $(HOSTCC_OPTS_C) -o $@ $< -lpthread
25+ $(HOSTCC) $(HOSTCC_OPTS) $(HOSTCC_OPTS_C) -o $@ $< -lpthread ${LDFLAGS}
26
27 clean:
28 rm -f mux_server
29--
301.9.1
31
diff --git a/recipes-virtualization/mux-server/mux-server_1.02.bb b/recipes-virtualization/mux-server/mux-server_1.02.bb
index 744a84c..680ea08 100644
--- a/recipes-virtualization/mux-server/mux-server_1.02.bb
+++ b/recipes-virtualization/mux-server/mux-server_1.02.bb
@@ -3,7 +3,9 @@ SECTION = "mux-server"
3LICENSE = "LGPL-2.1" 3LICENSE = "LGPL-2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" 4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5 5
6SRC_URI = "git://git.freescale.com/ppc/sdk/hypervisor/mux_server.git;branch=master" 6SRC_URI = "git://git.freescale.com/ppc/sdk/hypervisor/mux_server.git;branch=master \
7 file://0001-Makefile-Fix-the-warning-during-build.patch \
8 "
7SRCREV = "3e4c6a44a81bb5cf2996830e8034d26850f80efc" 9SRCREV = "3e4c6a44a81bb5cf2996830e8034d26850f80efc"
8 10
9S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"